#opnfv-meeting: OPNFV TSC 2019-09-03

Meeting started by mbeierl at 12:58:27 UTC (full logs).

Meeting summary

  1. Roll Call (mbeierl, 13:00:17)
    1. Bin Hu (bh526r, 13:00:25)
    2. Mark Beierl (mbeierl, 13:00:31)
    3. Sofia Wallin (proxy for Georg) (sofiawallin, 13:00:37)
    4. Jack Morgan (jento, 13:00:42)
    5. Fu Qiao (bh526r, 13:01:48)
    6. Parker Berberian (bh526r, 13:02:21)
    7. Sridhar Rao (SRao, 13:02:34)
    8. fuqiao (fuqiao, 13:03:03)
    9. Reminder of Antitrust Policy Notice: https://r.lfnetworking.org/Antitrust%20Slide.pdf (mbeierl, 13:03:21)
    10. Frank Brockners (frankbrockners, 13:03:34)
    11. Dan Xu (bh526r, 13:04:16)

  2. Approval of Previous Meeting Minutes (mbeierl, 13:05:21)
    1. call for comments (mbeierl, 13:05:27)
    2. bh526r proposes approval (mbeierl, 13:05:34)
    3. minutes approved (mbeierl, 13:05:39)

  3. Agenda Bashing (mbeierl, 13:05:59)
    1. special TSC meeting August 30 with 5 members (mbeierl, 13:06:24)
    2. time ran out, so Trevor Cooper recommended using this meeting to finish the budget review (mbeierl, 13:06:51)
    3. call for changes to this recommendation? (mbeierl, 13:07:33)
    4. Jack Morgan asks if there are notes for review (mbeierl, 13:07:55)
    5. https://wiki.opnfv.org/display/meetings/2020+planning+-+Community+Input (mbeierl, 13:08:25)
    6. AGREED: to proceed with budget discussion (mbeierl, 13:08:52)

  4. Review of OPNFV FY20 Budget (mbeierl, 13:09:11)
    1. Jim notes that the infra budget was under discussion and should pick up there (mbeierl, 13:09:42)
    2. Jim also requests ranking be done (mbeierl, 13:09:57)
    3. Sunku Ranganath (bh526r, 13:10:54)
    4. Trevor Bramwel (bramwelt) was not present Aug 30, but is familiar will all work being done (mbeierl, 13:10:59)
    5. Jack asks was lab is being refreshed (mbeierl, 13:11:33)
    6. frankbrockners confirms part of that is the Portland lab - to see if we need new boxes, or hosted metal as a service (mbeierl, 13:12:05)
    7. conversation was started a while back, but lost steam this past spring (mbeierl, 13:12:26)
    8. the budget line item is independent of FY2020 (mbeierl, 13:12:42)
    9. frankbrockners notes the budget from FY19 does not 'expire', but we cannot ask for the same amount again if we have not used the existing amount (mbeierl, 13:13:25)
    10. bh526r details breakdown of infrastructure budget (mbeierl, 13:14:09)
    11. LaaS budget has moved from OPNFV to LFN (mbeierl, 13:14:46)
    12. Aug 30 call started with discussion of priorities (mbeierl, 13:15:12)
    13. a) see what we can do to help and grow the community (mbeierl, 13:15:34)
    14. b) to see what we can do to lower the barrier to entry (mbeierl, 13:15:44)
    15. discussion of sandbox - for example K8s has minikube, so what would an OPNFV version look like (mbeierl, 13:16:10)
    16. which ties into CNTT (mbeierl, 13:16:18)
    17. to have dev environment where things look like a mini CNTT and deploy all OPNFV tooling (mbeierl, 13:16:38)
    18. could be hosted or even on a laptop (mbeierl, 13:16:44)
    19. c) evolve the tooling to have a lower barrier for developers (mbeierl, 13:17:05)
    20. how to convey this sandbox and lower barrier to entry to something that finance can use (mbeierl, 13:17:58)
    21. Jack asks if we need a plan to finish FY19 budget (mbeierl, 13:19:15)
    22. frankbrockners states that we focus on FY20 direction, but use the FY19 money if needed (mbeierl, 13:19:38)
    23. Jack suggests FY19 budget gets handed over to infra working group (mbeierl, 13:19:56)
    24. have infra group report back to TSC on Portland and other labs (mbeierl, 13:20:17)
    25. frankbrockners states there are no CNTT requirements yet, so it would be a guess as to what is needed (mbeierl, 13:21:12)
    26. Jack suggests we use what we have now as a rough framework for now (mbeierl, 13:21:28)
    27. frankbrockners suggests that we do the same as what we did when starting OPNFV (mbeierl, 13:21:46)
    28. it was 6 servers, but opens the question - is that enough for CNTT? We do not know (mbeierl, 13:22:06)
    29. Jonathon (?) from CNTT asks if there is a sample of sizing (mbeierl, 13:22:45)
    30. Jack replies with information about Pharos specification (mbeierl, 13:23:01)
    31. https://wiki.opnfv.org/display/meetings/Pharos (mbeierl, 13:23:25)
    32. bh526r asks if Developer Design Forum / Plugfest should be first priority (mbeierl, 13:25:14)
    33. frankbrockners asks how many of each - we need to quantify (mbeierl, 13:25:37)
    34. bh526r suggests 2 plugfests and 2 or 4 meetups? (mbeierl, 13:25:50)
    35. https://wiki.opnfv.org/display/pharos (jento, 13:26:38)
    36. 8 meetups - 3 in Portland (mbeierl, 13:29:04)
    37. Jack will work with bramwelt and OPNFV infra group to get more information on hardware infra (mbeierl, 13:30:21)
    38. jento confirms that relates to the FY19 budget (mbeierl, 13:30:41)
    39. frankbrockners asks CNTT reps if there is an idea of what CNTT development environment would look like (mbeierl, 13:31:17)
    40. CNTT confirms it is OpenStack based, so 3 controllers, 5-6 compute ? (mbeierl, 13:31:34)
    41. spine-leaf based (mbeierl, 13:31:43)
    42. frankbrockners asks if it must be bare metal (mbeierl, 13:31:53)
    43. CNTT confirms performance must be bare metal based (mbeierl, 13:32:04)
    44. CNTT hopes after ONS they will have the info (mbeierl, 13:32:25)
    45. frankbrockners confirms that is too late for this budget process (mbeierl, 13:32:37)
    46. CNTT (Mark) suggests give a rough estimate anyway (mbeierl, 13:32:50)
    47. frankbrockners suggests come up with a really rough guideline - walked through OPNFV history of how we arrived at 6 nodes to do real traffic testing (mbeierl, 13:33:58)
    48. CNTT suggests 2 compute is not enough (mbeierl, 13:34:46)
    49. frankbrockners asks if OPNFV infra group can check to see if this hardware spec is going to be sustainable for a few years with our upcoming plan (mbeierl, 13:36:25)
    50. CNTT could become an additional community lab like other projects have done (mbeierl, 13:39:14)
    51. CNTT confirms that they have no community labs (mbeierl, 13:39:38)
    52. CNTT suggests that as labs are acquired, they could become community labs (mbeierl, 13:40:02)
    53. ^ Mark S (mbeierl, 13:40:13)
    54. frankbrockners notes that tooling projects are independent enough that they can continue to operate (mbeierl, 13:41:40)
    55. frankbrockners the feature projects depend on installers and that hardware is not fully understood yet (mbeierl, 13:42:13)
    56. jento suggests adding 30% to last year's DDF/Plugfest budget to accommodate increased CNTT engagement (mbeierl, 13:48:29)
    57. Mark S suggests that CNTT should wrap up eventually and just be part of OPNFV, so marketing should be considered in that (mbeierl, 13:50:13)
    58. frankbrockners points out that we should focus on developer engagement or CNTT/etc will not flourish and become successful (mbeierl, 13:51:06)
    59. frankbrockners repeats focus should be on enabling the deveoper (mbeierl, 13:51:30)
    60. what additional things can we do from a community to enable thios? (mbeierl, 13:51:51)
    61. jento suggests what we need to do by Monday (mbeierl, 13:54:20)
    62. 1) info from infra WG (mbeierl, 13:54:31)
    63. 2) increase hardware infra (mbeierl, 13:55:23)
    64. 3) DDF/Plugfest increase (mbeierl, 13:56:16)
    65. TSC discretionary budget stays the same (mbeierl, 13:56:32)
    66. Mark S suggests that CNTT is going to drive new work in the 3rd Party Consulting area (reports, whitepapers, etc) (mbeierl, 13:57:44)
    67. Marketing material will increase with CNTT (mbeierl, 13:57:58)
    68. jento asks about MAC and bh526r, frankbrockners confirmed Bob Monkman is our rep (mbeierl, 14:01:21)

  5. AoB (mbeierl, 14:01:38)
  6. call for vote on proposal (mbeierl, 14:02:05)
    1. jento asks for email vote (mbeierl, 14:02:15)
    2. frankbrockners suggests #agree instead as this is just a first round (mbeierl, 14:02:30)
    3. Does the TSC agree to the draft of the budget? (mbeierl, 14:02:59)
    4. AGREED: The TSC agrees to the draft of the budget: https://wiki.opnfv.org/display/meetings/2020+planning+-+Community+Input (mbeierl, 14:03:27)
    5. TSC approves the budget (mbeierl, 14:03:37)
    6. v. 11 of the page linked above, published Sep 03, 2019 10:01 EDT (mbeierl, 14:04:24)
    7. Proposed email vote for Iruya (mbeierl, 14:05:19)
    8. AGREED: TSC will vote by email. (mbeierl, 14:05:38)

  7. AoB (mbeierl, 14:05:56)


Meeting ended at 14:06:00 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mbeierl (99)
  2. collabot` (6)
  3. bh526r (5)
  4. jento (3)
  5. frankbrockners (2)
  6. fuqiao (1)
  7. SRao (1)
  8. sofiawallin (1)
  9. LFNjbaker (0)


Generated by MeetBot 0.1.4.