#opnfv-meeting: OPNFV TSC Meeting 2019-10-01

Meeting started by bh526r at 13:04:39 UTC (full logs).

Meeting summary

    1. Since neither Jim nor David starts Zoom meeting, we may have IRC-only TSC meeting here (bh526r, 13:05:17)
    2. Georg Kunz (georgk, 13:05:20)
    3. Roll Call (bh526r, 13:05:28)
    4. Al Morton (acmacm, 13:05:34)

  1. Roll Call (bh526r, 13:05:35)
    1. Parker Berberian (pberberian, 13:05:46)
    2. Bin Hu (bh526r, 13:05:53)
    3. Georg Kunz (bh526r, 13:06:22)
    4. Frank Brockners (frankbrockners, 13:06:23)
    5. Al Morton (bh526r, 13:09:37)
    6. Cedric Ollivier (bh526r, 13:10:08)
    7. Trevor Cooper (bh526r, 13:10:51)
    8. Cristina Pauna (CristinaPauna, 13:13:31)
    9. We have quorum. (bh526r, 13:14:28)
    10. Frank suggested to discuss Python first, followed by project termination review, then normal items (bh526r, 13:17:26)
    11. Last week's meeting minutes (bh526r, 13:19:23)
    12. http://meetbot.opnfv.org/meetings/opnfv-meeting/2019/opnfv-meeting.2019-09-24-13.01.html (bh526r, 13:19:26)
    13. though no quorum (bh526r, 13:19:36)
    14. All agreed to Frank's suggestion to discuss Python first followed by termination review (bh526r, 13:20:09)

  2. Python 2 Dependencies (bh526r, 13:20:40)
    1. We had an email vote, and approved switch to Python 3 (bh526r, 13:21:10)
    2. https://lists.opnfv.org/g/opnfv-tsc/message/5601 (bh526r, 13:22:26)
    3. Frank provided more information regarding Python 3 in OpenStack (bh526r, 13:23:17)
    4. https://wiki.openstack.org/wiki/Python3 (bh526r, 13:23:21)
    5. Cedric will check overall status of Python 3, and make sure upstream (e.g. OpenStack) is really ready (bh526r, 13:25:33)
    6. Cedric will report any findings after his investigation (bh526r, 13:26:01)
    7. e.g. Fuel depends on Python 2.7, and swift issue with Python 3 (bh526r, 13:26:31)
    8. ACTION: Every PTL needs to check their dependency status on upstream, and their readiness of supporting Python 3 in upstream (bh526r, 13:28:11)
    9. Correction: OpenStack has dependency on Python 2.7. Fuel has NO Python code. (bh526r, 13:28:50)
    10. There is indirect dependency of Fuel, and Cristina plans to look into it (in the backlog) (bh526r, 13:29:42)
    11. https://review.opendev.org/#/c/685503/ (ollivier, 13:30:59)
    12. ACTION: Cedric looks into Python 3 status in OpenStack, and report to TSC after his findings. (bh526r, 13:31:01)
    13. https://openstack.fortnebula.com:13808/v1/AUTH_e8fd161dc34c421a979a9e6421f823e9/zuul_opendev_logs_886/685503/2/check/swift-tox-py37/8865c51/job-output.txt (ollivier, 13:31:44)
    14. ACTION: Al Morton will send an email to tech-discuss mailing list to make sure PTLs are aware of this action (bh526r, 13:32:02)
    15. Sridhar Rao (bh526r, 13:32:47)
    16. Python3 seems supported by jjb. https://pypi.org/project/jenkins-job-builder/ (ollivier, 13:33:19)
    17. The purpose is to make sure if there is an issue, we will be aware of it, and find a way to deal with it. (bh526r, 13:34:52)

  3. Project Termination Review (bh526r, 13:36:08)
    1. First is IPv6 Project (bh526r, 13:36:24)
    2. https://lists.opnfv.org/g/opnfv-tsc/message/5444 (bh526r, 13:38:53)
    3. On behalf of Sridhar Rao (bh526r, 13:40:32)
    4. VOTE: Voted on "Does TSC approve the termination proposal for the IPv6 project? (+1, 0, -1)?" Results are (bh526r, 13:40:45)
    5. all voted +1, and termination request was approved (bh526r, 13:41:34)
    6. Second is Armband (bh526r, 13:43:31)
    7. https://lists.opnfv.org/g/opnfv-tsc/message/5575 (bh526r, 13:44:24)
    8. Arm supported build servers remain functional (bh526r, 13:45:32)
    9. VOTE: Voted on "Does TSC approve the termination proposal for the Armband project?" Results are (bh526r, 13:47:35)
    10. All voted +1 and/or Yes, termination request was approved (bh526r, 13:48:32)
    11. ACTION: Bin works with LF to figure out the IRC vote issue. (bh526r, 13:48:55)
    12. It might be that we just needed to add (+1, 0, -1) without question mark '?' (bh526r, 13:49:18)
    13. Documentation says we need to provide options after question. (bh526r, 13:50:30)

  4. Budget Status (bh526r, 13:51:13)
    1. Individual roll ups were provided to finance committee of Board (bh526r, 13:52:07)
    2. Finance committee is waiting for additional input from LFN (bh526r, 13:52:54)
    3. Project/SPC input were provided to Board. Board reviewed SPC status and provided input to SPC as well. (bh526r, 13:54:00)

  5. SPC Update (bh526r, 13:54:32)
    1. Jonne reported to Board regarding strategy recommendations (bh526r, 13:55:20)
    2. Next step is to provide more input to Board in the meeting in November (bh526r, 13:57:29)

  6. Logistics: TSC Meeting Recording Practice (bh526r, 13:59:56)
    1. Cedric suggested if we could consider to switch to IRC-only meeting. (bh526r, 14:01:06)
    2. This is the best way to capture minutes (bh526r, 14:01:22)
    3. Mark asked what if presentation to be made? (bh526r, 14:01:52)
    4. ACTION: mbeierl to send an email to start the discussion (mbeierl, 14:02:20)
    5. acm send Python 2 Upstream e-mail DONE (acmacm, 14:02:56)

  7. AOB (bh526r, 14:03:28)
    1. Meeting adjourned (bh526r, 14:03:35)


Meeting ended at 14:03:38 UTC (full logs).

Action items

  1. Every PTL needs to check their dependency status on upstream, and their readiness of supporting Python 3 in upstream
  2. Cedric looks into Python 3 status in OpenStack, and report to TSC after his findings.
  3. Al Morton will send an email to tech-discuss mailing list to make sure PTLs are aware of this action
  4. Bin works with LF to figure out the IRC vote issue.
  5. mbeierl to send an email to start the discussion


Action items, by person

  1. mbeierl
    1. mbeierl to send an email to start the discussion
  2. UNASSIGNED
    1. Every PTL needs to check their dependency status on upstream, and their readiness of supporting Python 3 in upstream
    2. Cedric looks into Python 3 status in OpenStack, and report to TSC after his findings.
    3. Al Morton will send an email to tech-discuss mailing list to make sure PTLs are aware of this action
    4. Bin works with LF to figure out the IRC vote issue.


People present (lines said)

  1. bh526r (68)
  2. collabot` (10)
  3. pberberian (7)
  4. ollivier (7)
  5. acmacm (5)
  6. CristinaPauna (5)
  7. frankbrockners (4)
  8. georgk (3)
  9. trevor_intel (2)
  10. mbeierl (2)
  11. ildikov (1)
  12. SRao (1)


Generated by MeetBot 0.1.4.