#opnfv-meeting: OPNFV TSC Meeting 2019-10-08

Meeting started by mbeierl at 13:00:16 UTC (full logs).

Meeting summary

  1. Roll Call (mbeierl, 13:01:21)
    1. Bin Hu (bh526r, 13:01:33)
    2. Trevor Cooper (trevor_intel, 13:02:14)
    3. Manuel Buil (mbuil, 13:02:32)
    4. Georg Kunz (IRC only) (georgk, 13:02:38)
    5. Mark Beierl (bh526r, 13:03:25)
    6. Panagiotis Karalis (IRC only) (pkaralis, 13:05:15)
    7. Frank Brockners (bh526r, 13:06:13)

  2. Antitrust Policy Notice (mbeierl, 13:06:40)
    1. Jim presented the policy (mbeierl, 13:06:53)

  3. Approval of previous minutes (mbeierl, 13:07:01)
    1. Cedric Ollivier (bh526r, 13:07:39)
    2. http://meetbot.opnfv.org/meetings/opnfv-meeting/2019/opnfv-meeting.2019-10-01-13.04.html (mbeierl, 13:07:51)
    3. any comments on the previous meeting minutes? (mbeierl, 13:08:04)
    4. Minutes are approved (mbeierl, 13:08:12)
    5. Frank Brockners (frankbrockners, 13:08:14)

  4. Agenda Bashing (mbeierl, 13:08:27)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-October8,2019 (mbeierl, 13:08:46)
    2. Bin reads out the proposed agenda from the link above (mbeierl, 13:09:31)
    3. no chair report today (mbeierl, 13:09:41)
    4. if anyone on IRC wants to add to agenda, please let me know (mbeierl, 13:10:09)
    5. mbeierl would like to discuss the recording of zoom meetings (mbeierl, 13:11:43)
    6. Cedric mentions there is also an email thread on IRC only (mbeierl, 13:13:23)
    7. discussion - if Zoom recording does not pass, and IRC only does not pass, then we would keep status quo (mbeierl, 13:13:45)
    8. mbeierl suggests that the recording of audio/video or IRC only should serve the community to provide more transparency to the discussions (mbeierl, 13:15:58)
    9. that is why the two proposals are being tied together (mbeierl, 13:16:11)
    10. agenda is approved (mbeierl, 13:16:16)

  5. Python 3 status (mbeierl, 13:16:26)
    1. Cedric checked, there are 2/3 projects that are missing python 3 support (mbeierl, 13:17:19)
    2. tempest is in Python 2 (mbeierl, 13:17:43)
    3. Cedric believes there should be no impact to OPNFV committing to Python 3 completely (mbeierl, 13:18:32)
    4. Cedric will double check with OSLO and Swift to confirm (mbeierl, 13:18:56)
    5. Cedric confirms Jan 1 2020 is EOL for Python 2 and it is clear to all that this is a hard date (mbeierl, 13:19:24)
    6. ollivier suggests we can also run the python2 checker to ensure we are completely moved over (mbeierl, 13:20:56)
    7. ollivier says even Linux find command can be used to search (mbeierl, 13:21:29)
    8. ollivier also states a heavy approach could be to remove python2 from the build infrastructure (mbeierl, 13:22:05)
    9. dmcbride asks ollivier to send an email with the search methods (mbeierl, 13:22:22)
    10. ACTION: ollivier will send out email about how to check for python2 (mbeierl, 13:22:37)

  6. Next DDF/Plugfest update (mbeierl, 13:22:50)
    1. Jim states there are different locations being investigated (mbeierl, 13:23:09)
    2. Decision should come this week (mbeierl, 13:23:18)
    3. sites are Warsaw, Prague, Budapest and Singapore (mbeierl, 13:23:32)
    4. Board embraced the idea of LF sponsored events (mbeierl, 13:23:46)
    5. shift will allow us to set dates in advance (mbeierl, 13:24:15)
    6. Panama did not receive quorum for decision, so the opportunity is gone (mbeierl, 13:24:58)

  7. Role, Responsibility and Expectation of LFN Infra Support for Issues in Community Labs (mbeierl, 13:25:02)
    1. trevor_intel: As CNTT activities are ramping up, we want to use our community labs (mbeierl, 13:25:43)
    2. trevor_intel: as new members are starting to use resources, this is becoming more important (mbeierl, 13:26:07)
    3. trevor_intel: we used to have infra working group and pharos, which are no longer operating (mbeierl, 13:26:24)
    4. trevor_intel: an example - issues in Intel lab have been going around between LF helpdesk and others, with no owner (mbeierl, 13:26:51)
    5. trevor_intel: where do users go for support - JIRA, mailing list, helpdesk email (mbeierl, 13:27:14)
    6. trevor_intel: this is going to get worse as CNTT ramps up (mbeierl, 13:27:29)
    7. trevor_intel: as Jack Morgan no longer works for Intel, and he was one of the primary resources, the remaining resources are not in a position to provide that level of support (mbeierl, 13:28:25)
    8. trevor_intel: we seem to have lost some visibility into the community labs, and we should try to revitalize the infra community (mbeierl, 13:28:55)
    9. Jim: labs are critical to success, Mark Cotrell suggest federating labs (mbeierl, 13:29:32)
    10. trevor_intel: 1) have a clear understanding of communication mechanisms, requesting support, (mbeierl, 13:30:13)
    11. trevor_intel: 2) what level of support can LFN support provide for community labs (mbeierl, 13:30:32)
    12. ollivier: question - how can the community help with the infra support (mbeierl, 13:31:04)
    13. trevor_intel: have someone step up to lead the infra working group / combined pharos+infra with regular calls and work through the issues and make recommendations (mbeierl, 13:32:10)
    14. Jim: we are defining the problem space (mbeierl, 13:32:29)
    15. trevor_intel: agrees, but how do we go about tackling this (mbeierl, 13:32:47)
    16. bh526r: start email thread and discuss in weekly tech call (mbeierl, 13:33:01)
    17. ollivier: maybe question for community role should be asked at TAC level (mbeierl, 13:33:14)
    18. Mike Fix: Heather volunteered to look into health of labs (mbeierl, 13:33:43)
    19. Mike Fix will cycle back with her to where that is at (mbeierl, 13:34:04)
    20. bh526r: comments status of labs is unknown (there are 18 or more of them) (mbeierl, 13:34:35)
    21. ollivier: there are a few Jenkins slave that are down, which is an indication that the community lab is also down (mbeierl, 13:35:05)
    22. Mike Fix: clarifies his action is to follow up with Heather to see if she is still available to volunteer (mbeierl, 13:35:55)
    23. Jim Baker: can we have a TSC volunteer to drive this (mbeierl, 13:36:08)
    24. trevor_intel: suggests we follow bh526r's suggestion of email and weekly tech call follow up to find leader (mbeierl, 13:36:39)
    25. bh526r suggests two actions: 1) Mike to follow up with Heather, 2) discuss in Monday weekly tech calls (mbeierl, 13:37:24)
    26. any other comments? (mbeierl, 13:38:16)

  8. SPC Update (mbeierl, 13:38:21)
    1. trevor_intel: SPC is working on asks from Board after the strategy presentation in Antwerp (mbeierl, 13:38:51)
    2. trevor_intel: board requested info on end user input and KPIs and metrics relating to the objectives (mbeierl, 13:39:26)
    3. trevor_intel: SPC is getting input from EUAG. Vodafone is chair and is providing info (mbeierl, 13:39:57)
    4. any questions? (mbeierl, 13:40:06)

  9. CNTT in OPNFV Update (mbeierl, 13:40:20)
    1. Qiao Fu (bh526r, 13:40:47)
    2. Mike: coming out of Antwerp, we aligned on needing to secure a lab, extract requirements from RI, and define installer requirements (mbeierl, 13:41:26)
    3. Al Morton (bh526r, 13:41:30)
    4. Mike: we are going to work through the next steps to get RA deployed (mbeierl, 13:41:39)
    5. Mike: working with trevor_intel on securing a lab (mbeierl, 13:41:57)
    6. any questions? (mbeierl, 13:42:11)
    7. trevor_intel: re CNTT-RI project, do we have regular meetings? (mbeierl, 13:43:07)
    8. trevor_intel: are we waiting for definition from CNTT? (mbeierl, 13:43:26)
    9. Mike: plan is to start weekly meetings next week (mbeierl, 13:43:37)
    10. Mike: the RA is available in terms of requirements, now to translate that to an installer and test project (mbeierl, 13:43:59)
    11. trevor_intel: what is confusing to trevor_intel is the structure: we have reference implementation, we are going from available requirements, now we have CNTT RI in OPNFV, then what is the work of the RI within the CNTT? As opposed to CNTT-RI in OPNFV? (mbeierl, 13:45:12)
    12. Rabi: CNTT is temporary, so OPNFV CNTT-RI is a mirror of the workstream RI in CNTT, so when CNTT disappears, CNTT-RI lives on (mbeierl, 13:46:21)
    13. trevor_intel: will there be CNTT RI meetings as well as OPNFV CNTT-RI meetings? (mbeierl, 13:46:38)
    14. Rabi: No (mbeierl, 13:46:42)
    15. JIm: CNTT-RI is the implementation of the CNTT task force (mbeierl, 13:47:03)
    16. Mike: this was started in OPNFV with the purpose of OPNFV being the delivery vehicle (mbeierl, 13:47:27)
    17. Rabi: work was started in GSMA to create a reference model, so the same thing is expected from OPNFV: CNTT does the definition, OPNFV implements it and the RI lives on there (mbeierl, 13:48:18)
    18. Jonathan Beltran: resources come from CNTT, and continue collaboratively under the umbrella of OPNFV (mbeierl, 13:48:51)
    19. Al Morton: Mike, can we do a doodle poll for the time slot of CNTT-RI weekly meeting? (mbeierl, 13:49:22)
    20. Mike agrees (mbeierl, 13:49:28)
    21. Jonathan: would love ideas on CNTT as a group - rotating schedule to accommodate international hours (mbeierl, 13:50:28)
    22. Al: confirms it can be successful, and has not been successful on other projects, but hopes it will work for CNTT-RI to have rotating times (mbeierl, 13:51:12)
    23. Jim: asks about 10 concurrent RI - is our toolchain ready to handle that? (mbeierl, 13:51:38)
    24. Jim: ask if there is anyone who wants to engage on this project? (mbeierl, 13:51:53)
    25. Jim: we have contracting resources, but need clear deliverable and objectives (mbeierl, 13:52:18)
    26. Jim: is anyone interested? (mbeierl, 13:52:24)
    27. Jim received no reply (mbeierl, 13:52:30)

  10. Iruya Release Update (mbeierl, 13:52:32)
    1. dmcbride: has been out for a few weeks (mbeierl, 13:52:45)
    2. dmcbride: Milestone 1 was September 30 (mbeierl, 13:52:56)
    3. dmcbride: as of that date, 14 projects expressed intent (mbeierl, 13:53:06)
    4. dmcbride:part of MS1 is release plan (mbeierl, 13:53:12)
    5. dmcbride:we have 50% compliance with release plans, and is following up with the PTLs (mbeierl, 13:53:36)
    6. dmcbride:MS2 is OpenStack integration (mbeierl, 13:53:42)
    7. dmcbride: reminder this is a compressed schedule, dates are coming up fast (mbeierl, 13:53:58)
    8. dmcbride: MS2 is mainly for installers, which is only FUEL and Airship (mbeierl, 13:54:23)
    9. any questions? (mbeierl, 13:54:26)
    10. ollivier: reminds that email about releng participating in the release, would like clarification (mbeierl, 13:55:11)
    11. bramwelt: releng is participating due to releng-xci (mbeierl, 13:55:33)
    12. bramwelt: releng participates due to historical support (mbeierl, 13:55:52)
    13. : ollivier should clarify releng vs releng-xci (mbeierl, 13:56:14)
    14. dmcbride: suggests breaking projects out into projects types, including support projects like releng and opnfvdocs (mbeierl, 13:56:39)
    15. dmcbride: once we move to the new process, we should have more clarification (mbeierl, 13:57:08)

  11. LF IT/Infra update (mbeierl, 13:57:20)
    1. no update (mbeierl, 13:57:25)

  12. IRC and Zoom recording (mbeierl, 13:59:17)
    1. https://lists.opnfv.org/g/opnfv-tsc/topic/32967803#5484 (ollivier, 13:59:27)
    2. mbeierl questions - is this a TSC decision, a community decision, or should we just ask the LFN to decide for us? (mbeierl, 14:00:53)
    3. https://lists.opnfv.org/g/opnfv-tsc/message/5492 (ollivier, 14:01:53)
    4. : it's not time to vote as we need to know what the community wants (mbeierl, 14:02:10)
    5. Jim: let's start an actual poll (mbeierl, 14:02:31)
    6. : will discuss next week (mbeierl, 14:02:38)
    7. ACTION: mbeierl to send email and start poll (mbeierl, 14:02:47)
    8. we are past the hour (mbeierl, 14:05:21)
    9. any further questions, comments from IRC? (mbeierl, 14:07:14)
    10. ending meeting in 3, 2, 1.... (mbeierl, 14:07:26)


Meeting ended at 14:07:33 UTC (full logs).

Action items

  1. ollivier will send out email about how to check for python2
  2. mbeierl to send email and start poll


Action items, by person

  1. mbeierl
    1. mbeierl to send email and start poll
  2. ollivier
    1. ollivier will send out email about how to check for python2


People present (lines said)

  1. mbeierl (130)
  2. bh526r (7)
  3. collabot_ (6)
  4. ollivier (2)
  5. trevor_intel (1)
  6. frankbrockners (1)
  7. pkaralis (1)
  8. georgk (1)
  9. mbuil (1)


Generated by MeetBot 0.1.4.