#opnfv-meeting: Weekly Technical Discussion 154

Meeting started by bh526r at 13:00:19 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r, 13:00:28)
    1. Liang Chen (bh526r, 13:00:48)
    2. Qiao Fu (bh526r, 13:01:25)
    3. Hongli Zhang (bh526r, 13:01:34)
    4. Bin Hu (bh526r, 13:01:40)
    5. Denver Williams (bh526r, 13:02:08)
    6. Jack Morgan (bh526r, 13:02:16)
    7. Cedric Ollivier (bh526r, 13:02:56)
    8. Watson W (bh526r, 13:07:01)
    9. Trevor Cooper (bh526r, 13:07:08)
    10. Trevor Bramwell (bh526r, 13:07:16)
    11. Cédric Ollivier (ollivier, 13:07:21)

  2. Role, Responsibility and Expectation of LFN Infra Support for Issues in Community Labs by Trevor Cooper (bh526r, 13:07:50)
    1. Trevor Cooper described the issue that was discussed in TSC meeting on 10/08. (bh526r, 13:08:34)
    2. e.g. when there was an issue in community lab (e.g. Intel lab), there wasn't a forum to discuss how to resolve the issue. (bh526r, 13:09:34)
    3. This was because the lab admin usually doesn't participate in community, and they usually just are responsible for hardware configuration. When an issue becomes more complex, there isn't a place to discussion and resolve related issues. (bh526r, 13:11:18)
    4. So we need a consolidated forum, e.g. Pharos + Infra Forum, to help resolve the issues (bh526r, 13:12:34)
    5. Cedric Ollivier indicated that even if he has the skillset to help, e.g. set up Jenkins slave, he doesn't have access permission to do it. (bh526r, 13:13:52)
    6. Jack Morgan summarized (1) Lab support issue (who will do what) (2) Current community lab status (3) Future of Community Labs (e.g. Infra evolution, other features change to the lab when CNTT joins us, etc.) (4) open credentials (e.g. Jenkins slave) to community (bh526r, 13:19:29)
    7. Discussing (1) Lab support issue (who will do what) (bh526r, 13:20:00)
    8. Support process to be clarified (trevor_intel, 13:20:42)
    9. Ticket support through Jira service desk (bh526r, 13:21:43)
    10. https://support.linuxfoundation.org (bh526r, 13:22:10)
    11. Al Morton (bh526r, 13:23:02)
    12. Cedric indicated that although there is a resource pool for every project, but 2 resources are budgeted and dedicated to OPNFV, so we should get quicker support (bh526r, 13:24:18)
    13. Trevor Bramwell indicated that if support is needed from LF staff, it should go to https://support.linuxfoundation.org (bh526r, 13:25:49)
    14. Exception is that if there is issue related to OPNFV Community Lab, it should go to OPNFV Jira: https://jira.opnfv.org (bh526r, 13:26:24)
    15. https://jira.linuxfoundation.org/servicedesk/customer/portal/2 (bramwelt, 13:26:40)
    16. support.linuxfoundation.org (bramwelt, 13:26:44)
    17. Al Morton (acmacm, 13:27:36)
    18. e.g. if issue related to Jenkins master or connection to Jenkins slave, it should go to LF support: support.linuxfoundation.org (bh526r, 13:28:14)
    19. Trevor Bramwell will organize a training session to community (bh526r, 13:28:52)
    20. ACTION: Trevor Bramwell will organize a training session for community (bh526r, 13:29:15)
    21. Mark Shostak (bh526r, 13:33:00)
    22. Trevor Cooper gave an example: a VM wasn't working on a pod, and lab admin had no clue why we need the VM, and why it stopped working (bh526r, 13:35:34)
    23. Jack Morgan indicated the gap of Lab admin wasn't aware anything of OPNFV. (bh526r, 13:36:12)
    24. Infra WG needs to document those, i.e. gaps and proposed process of where to escalate, and who will do what (bh526r, 13:38:50)
    25. ACTION: Jack Morgan and Trevor Bramwell to revive Infra WG meeting to take care of above task (bh526r, 13:40:07)
    26. https://wiki.opnfv.org/display/pharos/Community+Labs (jentoio, 13:40:47)
    27. Pharos Project will also take the task of assessing current lab status so that above information will be up to date (bh526r, 13:42:00)
    28. (3) Future Lab (bh526r, 13:47:17)
    29. e.g infra evolution, TAC Infra WG etc. (bh526r, 13:49:13)
    30. Trevor Bramwell have been representing OPNFV in TAC Infra WG (bh526r, 13:49:51)
    31. Both Jack Morgan and Trevor Bramwell will represent OPNFV in Infra WG of TAC. They will bring back the guidelines from TAC, clarity of decisions that OPNFV TSC needs to make in terms of CI evolution, cloud-based CI/CD etc. (bh526r, 13:54:33)
    32. Cedric indicated that FuncTest has successfully experimented Traverse CI etc. (bh526r, 13:55:14)
    33. Nothing has been decided in TSC level (bh526r, 13:55:44)
    34. We need to experiment, get lessons and experience, and bring the topic to TSC regarding what recommendation and decision TSC needs to make. (bh526r, 13:58:23)
    35. (4) Open credentials to community (bh526r, 13:58:35)
    36. Cedric raised the topic in TSC last week, and email to mailing list, and waiting for feedback/response (bh526r, 13:59:43)
    37. ACTION: Trevor Bramwell set up meeting of Infra WG (bh526r, 14:00:12)
    38. Jack Morgan and Trevor Bramwell will bring the topic of "open credential to community" in TAC Infra WG meeting on Friday, because it involves other communities such as ODL and ONAP (bh526r, 14:04:46)
    39. All 4 issues will be taken care of in details in OPNFV Infra WG (issue 1), Pharos Project (issue 2), and TAC Infra WG represented by Jack and Trevor on behalf of OPNFV (issue 3 and 4). (bh526r, 14:06:45)
    40. We will see how it goes, and if still gaps (possible) and how to solve it in future meetings (bh526r, 14:07:37)

  3. AOB (bh526r, 14:07:53)
    1. Meeting adjourned (bh526r, 14:07:59)


Meeting ended at 14:08:03 UTC (full logs).

Action items

  1. Trevor Bramwell will organize a training session for community
  2. Jack Morgan and Trevor Bramwell to revive Infra WG meeting to take care of above task
  3. Trevor Bramwell set up meeting of Infra WG


People present (lines said)

  1. bh526r (57)
  2. collabot (6)
  3. ollivier (2)
  4. bramwelt (2)
  5. trevor_intel (1)
  6. jentoio (1)
  7. acmacm (1)


Generated by MeetBot 0.1.4.