#opnfv-meeting: OPNFV TSC 2020-08-11

Meeting started by frankbrockners at 13:02:07 UTC (full logs).

Meeting summary

  1. roll call (frankbrockners, 13:02:15)
    1. Frank Brockners (frankbrockners, 13:02:21)
    2. Sridhar Rao (SRao, 13:02:31)
    3. Emma Foley (efoley, 13:02:33)
    4. Al Morton (acmacm, 13:02:56)
    5. Georg Kunz (georgk, 13:03:27)
    6. Cédric Ollivier (ollivier, 13:03:47)
    7. fuqiao (fuqiao, 13:06:47)

  2. agenda bashing (frankbrockners, 13:06:58)
    1. https://wiki.opnfv.org/display/meetings/OPNFV+TSC+Meeting+2020-08-11 (frankbrockners, 13:07:13)
    2. no updates to the agenda received (frankbrockners, 13:07:43)

  3. approval of last weeks minutes (frankbrockners, 13:07:55)
    1. AGREED: last week's minutes approved (frankbrockners, 13:08:08)

  4. announcements (frankbrockners, 13:08:43)
    1. Kanagaraj Manickam self-nominated by was not eligible based on his past contributions (frankbrockners, 13:09:11)
    2. LF ops survey - results beautification in progress (frankbrockners, 13:09:47)
    3. we still need a volunteer for the Fall Technical Event planning... please volunteer (frankbrockners, 13:10:20)
    4. TAC presentation up on Aug/26 (frankbrockners, 13:10:53)

  5. new CI (frankbrockners, 13:11:00)
    1. Trevor introduces gitlab-ci as the future option (frankbrockners, 13:11:28)
    2. https://wiki.opnfv.org/download/attachments/56296802/opnfv-cicd-transformation.pdf?api=v2 (bramwelt, 13:12:25)
    3. https://wiki.opnfv.org/display/INF/GitLab-CI+Migration (frankbrockners, 13:13:29)
    4. suggestion is for "gitlab + gitlab-CI" (frankbrockners, 13:17:40)
    5. I would consider Gerrit as better than Gitlab for review management (see opendev.org) (ollivier, 13:18:35)
    6. Jenkins JJB are very powerful and Jenkins fits the test daily jobs (not linked to any code repo) (ollivier, 13:19:04)
    7. I would consider the existing choice as very good and quite a huge rewrite (ollivier, 13:19:17)
    8. we could have rather implementing the jjb middleware (jjb per branch) in releng. (ollivier, 13:20:00)
    9. could we host Functest jjbs in ONAP if it's just about more about savings? (ollivier, 13:21:08)
    10. Gitlab-CI would continue to allow to schedule jobs to different bare-metal sites / community labs (frankbrockners, 13:22:55)
    11. temp move to HPE agenda topic b/c Georg needs to drop early (frankbrockners, 13:23:22)

  6. HPE Conformance Exception Documentation (frankbrockners, 13:23:44)
    1. Georg summarizes the situation (frankbrockners, 13:24:16)
    2. https://lists.opnfv.org/g/opnfv-tsc/message/6305 (frankbrockners, 13:24:19)
    3. I don't understand yet how endpoint connectivities could be related to bug in ovp... (ollivier, 13:25:01)
    4. Outstanding item (per CVC process): Exemption still has to be properly documented on the Web-portal (frankbrockners, 13:27:41)
    5. ACTION: georgk to check with Brandon/Jim to get the Web-portal updated (frankbrockners, 13:28:26)
    6. Cendric offers to help with "OVP tooling problem" (which might not be an OVP tooling problem) (frankbrockners, 13:29:47)
    7. AGREED: https://lists.opnfv.org/g/opnfv-tsc/message/6305 to be used as documentation for Exemption granting (frankbrockners, 13:30:20)

  7. Plans for New CI - 2nd part (discussion) (frankbrockners, 13:31:06)
    1. OPNFV is the first LFN project to try the new CI (frankbrockners, 13:31:24)
    2. suggestion is to move from (git/gerrit/jenkins) to (gitlab/gitlab-ci) - that means we also move away from gerrit for code review (frankbrockners, 13:33:13)
    3. Heather suggests a "trial" period to gain experience with the new system before the TSC would vote and decide (frankbrockners, 13:34:06)
    4. Trevor already has an OPNFV POC group on gitlab. Contact Trevor if you like access. (frankbrockners, 13:34:36)
    5. Cedric asks whether could we continue to host JJB (for ONAP Jenkins) (frankbrockners, 13:37:00)
    6. Releng and LF staff would help with rewriting Jenkins jobs to gitlab-ci (major effort for projects like Functest, which has > 1000 jobs) (frankbrockners, 13:38:13)

  8. Release process (frankbrockners, 13:38:56)
    1. there was no release meeting last week (frankbrockners, 13:39:13)
    2. Release schedule kicks off today (Aug/11) (frankbrockners, 13:40:52)

  9. CNTT Engagement status updates (frankbrockners, 13:41:43)
    1. Slides for the board meeting due Friday (Aug/14) (frankbrockners, 13:42:16)
    2. 2 FMO options presented so far (CNTT as a committee, CNTT as a LFN project) (frankbrockners, 13:42:52)
    3. 3rd option (OPNFV+CNTT integration) presented but not fully discussed so far (frankbrockners, 13:43:20)

  10. OVP Engagement status update (frankbrockners, 13:46:02)
    1. RC2 pull request needs updating (definitions for performance testing and benchmarking) before any further discussions could happen (frankbrockners, 13:50:46)

  11. OPNFV Project Reviews (frankbrockners, 13:51:10)
    1. OVN4NFV (typo in the agenda) up as the next review (frankbrockners, 13:51:33)

  12. Status Updates (frankbrockners, 13:51:59)
    1. DONE: Program management - website cleanup: https://wiki.opnfv.org/x/jAFbAw (frankbrockners, 13:52:12)
    2. Portland lab upgrade: New quote just arrived (-5k per server). (frankbrockners, 13:53:01)
    3. Lincoln to place the order for the Intel servers (frankbrockners, 13:54:22)
    4. LF infra: LaaS downtime tomorrow (11am - 5pm PT on Wednesday) (frankbrockners, 13:55:18)

  13. future topics (frankbrockners, 13:55:30)
    1. https://lists.opnfv.org/g/opnfv-tech-discuss/message/24293 (bramwelt, 13:55:31)
    2. Mark suggests to re-visit the recording discussion w/ transcripts to use for meeting minutes. Will be added to the agenda next week. (frankbrockners, 13:58:07)


Meeting ended at 13:59:08 UTC (full logs).

Action items

  1. georgk to check with Brandon/Jim to get the Web-portal updated


Action items, by person

  1. georgk
    1. georgk to check with Brandon/Jim to get the Web-portal updated


People present (lines said)

  1. frankbrockners (55)
  2. ollivier (7)
  3. collab-meetbot (4)
  4. bramwelt (2)
  5. SRao (1)
  6. efoley (1)
  7. acmacm (1)
  8. georgk (1)
  9. fuqiao (1)


Generated by MeetBot 0.1.4.