#opnfv-meeting: OPNFV TSC 2020-11-03

Meeting started by frankbrockners at 14:01:11 UTC (full logs).

Meeting summary

  1. rollcall (frankbrockners, 14:01:50)
    1. fuqiao (fuqiao, 14:03:16)
    2. Emma Foley (efoley, 14:03:37)
    3. Al Morton (acmacm, 14:03:40)
    4. Georg Kunz (efoley, 14:03:48)
    5. Sridhar Rao (SRao, 14:03:49)
    6. Mark Beierl (mbeierl, 14:05:03)
    7. Trevor Cooper (frankbrockners, 14:05:41)
    8. we're at quorum (frankbrockners, 14:05:55)

  2. agenda bashing (frankbrockners, 14:06:02)
    1. https://wiki.opnfv.org/display/meetings/OPNFV+TSC+Meeting+2020-11-03 (frankbrockners, 14:06:30)
    2. AGREED: agenda agreed (frankbrockners, 14:07:12)

  3. approval of last week's minutes (frankbrockners, 14:07:23)
    1. AGREED: minutes of Oct-27 are approved (frankbrockners, 14:07:33)

  4. OPNFV JERMA Release (frankbrockners, 14:07:49)
    1. sunkuranganath (sunkuranganath, 14:08:17)
    2. RC0 is today - compliance to RC0 milestone is "limited" (frankbrockners, 14:09:39)
    3. https://jira.opnfv.org/issues/?filter=13104 (dmcbride, 14:10:28)
    4. https://jira.opnfv.org/issues/?filter=13104 list of open issues for Jerma (frankbrockners, 14:10:55)
    5. Reminder: R0 is the start of integration testing, RC1 is the first release candidate (frankbrockners, 14:11:14)
    6. https://usercontent.irccloud-cdn.com/file/OU3PqkjP/jerma%20status.png (frankbrockners, 14:18:20)
    7. Stor4NFV has not responded to any questions wrt/ release status. Suggestion by David is to exclude Stor4NFV from Jerma (frankbrockners, 14:19:22)
    8. Key issues listed in the screenshot above. One key question is "what do we release" for Jerma (i.e. which artefacts) (frankbrockners, 14:20:55)
    9. Question to David: What does the "create project test plan mean?" -> Answer: As part of the project plan, each project was asked to define a test strategy. The testplan implements the test strategy. (frankbrockners, 14:26:27)
    10. proposal: Slip RC0 based on limited readiness by 1 week (frankbrockners, 14:26:51)
    11. AGREED: TSC agrees to move RC0 to Nov/10 (frankbrockners, 14:27:12)
    12. 2 teams are working on getting the integration platform in place this week (frankbrockners, 14:28:13)
    13. team setup for integration team is being discussed as part of the release meeting (-> consider joining the release meeting) (frankbrockners, 14:32:23)
    14. Question: When projects follow the self-release process, should their artefacts be included in the release moving forward? -> Something for future discussion (frankbrockners, 14:33:25)
    15. The next tech discuss meeting (next Monday, 14:00 UTC) will discuss the manifest for the release (i.e. what is included) (frankbrockners, 14:34:15)

  5. MELD Topics and status updates (frankbrockners, 14:34:30)
    1. Tool chain and tool change (i.e. even the current tools might be used differently in the new organization) (frankbrockners, 14:35:49)
    2. Tooling likely a topic for the interim TSC (frankbrockners, 14:36:56)
    3. Release naming deferred to interim TSC (frankbrockners, 14:38:21)
    4. there is a proposal for an interim TSC: 15 members, 8 from current OPNFV TSC (frankbrockners, 14:38:46)
    5. TBD what artefacts Anuket will release. There will be reference specs, there will be verification/certification; mbeierl suggests that those always go in synch. (frankbrockners, 14:41:04)
    6. Reference Implementation: The number of reference implementations seems to be an open topic (is there one or multiple?) (frankbrockners, 14:41:43)
    7. Discussion: Should there be a reference implementation and "vendor implementations"? -> Topic to be resolved by the Anuket TSC. (frankbrockners, 14:43:07)
    8. Key question is what Anuket would release (frankbrockners, 14:43:27)
    9. Trever Cooper mentions that OPNFV has a lot of experience with the topic - and the fact that it is hard to create *one* reference implementation which would represent *the* platform (frankbrockners, 14:45:01)
    10. Implementation would mostly be a vehicle to define a test suite (frankbrockners, 14:45:35)
    11. Cedric mentions that we should not link testing and implementation - because we will and should have multiple implementations (frankbrockners, 14:46:34)
    12. Interim TSC election calendar: https://wiki.lfnetworking.org/display/MZ/MeldOps+2020-10-29+Meeting+notes (frankbrockners, 14:49:18)
    13. For the meld, the OPNFV community will select 8 out of the current 12 TSC members for the new Anuket TSC (frankbrockners, 14:50:07)
    14. Interim TSC will have a 9 month term (frankbrockners, 14:51:34)
    15. AGREED: OPNFV TSC agrees the TSC election calendar (frankbrockners, 14:56:57)

  6. Gitlab Pilot (frankbrockners, 14:57:43)
    1. Tech Discuss meeting (on Nov/2) reviewed the gitlab pilot (frankbrockners, 14:58:37)
    2. One topic discussed was concurrent changes (e.g. a name change across the various efforts within the Storperf project) - and see how well that works (frankbrockners, 14:59:58)
    3. https://wiki.opnfv.org/pages/viewpage.action?spaceKey=~mbeierl&title=GitLab+and+StorPerf (frankbrockners, 15:00:47)
    4. We'll come back to the topic next week (frankbrockners, 15:02:01)

  7. Infra updates (frankbrockners, 15:02:07)
    1. no updates from LF infra (frankbrockners, 15:02:17)


Meeting ended at 15:02:20 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. frankbrockners (50)
  2. collab-meetbot (9)
  3. efoley (2)
  4. acmacm (1)
  5. mbeierl (1)
  6. fuqiao (1)
  7. SRao (1)
  8. sunkuranganath (1)
  9. dmcbride (1)
  10. jentoio (0)


Generated by MeetBot 0.1.4.