#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (17th August 2015)

Meeting started by mdgray at 13:02:23 UTC (full logs).

Meeting summary

    1. mdgray (mdgray, 13:02:28)
    2. Mike Lynch (mdgray, 13:02:36)

  1. Roll Call (mdgray, 13:02:47)
    1. mdgray (mdgray, 13:02:51)
    2. Mike Lynch (mdgray, 13:03:03)
    3. Gabor (mdgray, 13:04:44)
    4. therbert (tfherbert, 13:04:54)

  2. Agenda Items (mdgray, 13:05:12)
    1. Release Planning (mdgray, 13:05:37)
    2. Instructions to add package to an installer (mdgray, 13:05:56)
    3. SFC (mdgray, 13:06:25)
    4. and NSH (tfherbert, 13:06:42)

  3. Release Planning (mdgray, 13:07:03)
    1. ppt was sent out to Debra Scott (mdgray, 13:07:22)
    2. sounds right (tfherbert, 13:08:44)
    3. May need to update due to a dependency on Openstack Liberty (mdgray, 13:09:05)
    4. There is a risk that Brahmaputra will not have Openstack Liberty (mdgray, 13:10:30)
    5. SFC requires NSH aware openvswitch. If we are deploying user space accelerated openvswitch, that would need to be NSH aware as well. (tfherbert, 13:13:17)
    6. Both userspace and kernel space patches for NSH will be released together and will be based on the original Cisco code (mdgray, 13:17:49)
    7. ACTION: Mark to update ppt to reflect these dependencies (mdgray, 13:18:22)
    8. We will also need more detail in the plan which we can do at a later stage when we have more information. (mdgray, 13:20:05)
    9. Gabor asks if we have any hardware for this project (mdgray, 13:20:52)
    10. Mike Lynch: There will be access to the Intel OPNFV lab or the LF lab. (mdgray, 13:22:05)
    11. Follow the HW requirements of Pharos (mdgray, 13:23:15)
    12. We may need to book time on lab infrastrucure in order to run tests. (mdgray, 13:24:48)
    13. ACTION: Mike Lynch to check the procedure for reserving lab infrastructure. (mdgray, 13:26:09)
    14. Gabor: What are the supported NICs in the userspace datapath with DPDK? (mdgray, 13:27:47)
    15. There is a baseline specification for Pharos servers. Inclusing NICs. Those are all DPDK-supported. (mdgray, 13:28:23)
    16. Gabor: Memory and hugepages are not an issue either. (mdgray, 13:29:10)

  4. Instructions to add package to an installer (mdgray, 13:29:28)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004178.html (mdgray, 13:29:56)
    2. : there is a link to the current Pharos HW Specification (mlynch, 13:32:04)
    3. https://wiki.opnfv.org/pharos/pharos_specification (mlynch, 13:32:11)
    4. There are few options for installers (mdgray, 13:33:16)
    5. Mark suggests Fuel is a good option as the documentation, support from the mailing list, it also supports checkboxes for different builds, it also supports a virtual deployment (mdgray, 13:34:44)
    6. Gabor +1 (mdgray, 13:34:57)
    7. Robin: Is RDO another option? (mdgray, 13:35:28)
    8. therbert: Franck Brockner gave the exact methodology for doing what we need to do. (mdgray, 13:36:31)
    9. It might be Michal. The following link outlines this. (mdgray, 13:37:42)
    10. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004185.html (mdgray, 13:37:47)
    11. Fuel +1 (mlynch, 13:37:50)
    12. We only need to support one. (mdgray, 13:38:35)
    13. AGREED: We will target Fuel as the first installer. (mdgray, 13:39:20)
    14. We need to take the list of tasks highlighted in the above e-mail thread into Jira to indicate what we need to do to complete an integration of userspace ovs into OPNFV (mdgray, 13:41:00)
    15. ACTION: Tom will build a description of the work we need to do using the info in this e-mail and populate into Jira. The first purpose of this is really to help direct work so that people can contribute. (mdgray, 13:43:31)
    16. mailing list with [ovsnfv] tag, individual email or this chat channel for comms (tfherbert, 13:44:43)
    17. Gabor wants to know how to contact this group in general during the week? (mdgray, 13:45:09)
    18. Let's use e-mail as there is a record of it. (mdgray, 13:45:33)
    19. Tom we are in different timezones so email is probably better (mdgray, 13:46:05)

  5. SFC and NSH (mdgray, 13:46:11)
    1. SFC requires NSH-aware Open vSwitch (mdgray, 13:46:42)
    2. This is the first example of a NFV requirement that we need pushed into upstream. (mdgray, 13:47:27)

  6. Actions (mdgray, 13:49:25)
    1. Tom to arrange presentation from someone on Genesis team on integration - Closed via the email chain http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004178.html (mdgray, 13:49:57)

  7. Other topics (mdgray, 13:50:48)
    1. Tom: Where do we put the package? (mdgray, 13:51:01)
    2. Needs to be somewhere accessible by CI (mdgray, 13:52:07)
    3. +1 (tfherbert, 13:52:18)
    4. artifacts is a possibility (mdgray, 13:52:21)
    5. Mike: How do we formalize the userspace ovs as part of the CI (mdgray, 13:52:42)
    6. ACTION: Mike to talk to Octopus project to understand how to do this. (mdgray, 13:54:03)


Meeting ended at 13:55:30 UTC (full logs).

Action items

  1. Mark to update ppt to reflect these dependencies
  2. Mike Lynch to check the procedure for reserving lab infrastructure.
  3. Tom will build a description of the work we need to do using the info in this e-mail and populate into Jira. The first purpose of this is really to help direct work so that people can contribute.
  4. Mike to talk to Octopus project to understand how to do this.


People present (lines said)

  1. mdgray (58)
  2. tfherbert (7)
  3. collabot (5)
  4. mlynch (3)


Generated by MeetBot 0.1.4.