#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (31st August 2015)

Meeting started by mdgray at 13:02:00 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:03:31)
    1. Tom Herbert (tfherbert1, 13:03:46)
    2. billyom (billyom, 13:03:54)
    3. mdgray (mdgray, 13:04:00)
    4. rgiller (rgiller, 13:04:37)

  2. Agenda Items (mdgray, 13:04:52)
    1. NSH Discussion (mdgray, 13:05:25)
    2. Requirements (mdgray, 13:05:57)
    3. RPM Build (mdgray, 13:06:07)
    4. Fuel Deployment (mdgray, 13:06:24)
    5. Octopus Integration (mdgray, 13:06:36)

  3. NSH Discussion (mdgray, 13:07:12)
    1. How to plumb the NSH has been an active discussion on the mailing list. (mdgray, 13:07:58)
    2. Slides were shared showing the architecture of NSH in vswitch from Sam Hague. (mdgray, 13:09:55)
    3. Main concern is that it is currently suported and there may be performance impacts with this implementation. (mdgray, 13:12:05)
    4. Danny Zhou's NSH/vxLAN patch for OVS/DPDK is functional but he is cleaning up details. (tfherbert1, 13:12:54)
    5. submitted in next few weeks. (tfherbert1, 13:13:21)
    6. Concern about how vSwitch handles VxLAN vports may affect performance. (mdgray, 13:14:24)
    7. Shannon team looking into vxLAN performance. (tfherbert1, 13:17:34)

  4. Requirements (mdgray, 13:18:28)
    1. #NSH https://docs.google.com/presentation/d/1y0A1DNA1bB6y-1hR-ZfvtW8cKL4psMvj8BdaEMC4n2I/edit#slide=id.p (tfherbert1, 13:19:42)
    2. Starting to note vswitch requirements on the mailing list (mdgray, 13:20:35)
    3. How do we deal with these? (mdgray, 13:20:47)
    4. rgiller suggests collating them in etherpad (mdgray, 13:22:34)
    5. billyom: Need to prioritize requirements and get more detail. (mdgray, 13:23:05)
    6. #nsh https://lists.opendaylight.org/pipermail/sfc-dev/2015-August/001709.html (tfherbert1, 13:23:19)
    7. We need to engage more on these requirements. (mdgray, 13:23:46)
    8. #nsh more: https://lists.opendaylight.org/pipermail/sfc-dev/2015-August/001673.html (tfherbert1, 13:23:59)
    9. ACTION: billyoma and mdgray to look for standard requirements template within opnfv projects (mdgray, 13:25:34)
    10. ACTION: mdgray to note current requirements in etherpad (mdgray, 13:26:25)
    11. ACTION: tfherfert to bring up requirements gathering as a discussion on the tech-discuss mailing list. (mdgray, 13:26:50)

  5. RPM Build (mdgray, 13:30:15)
    1. RPMs seem to have been created for OVS 2.4 (mdgray, 13:31:29)
    2. http://openvswitch.org/pipermail/dev/2015-August/059403.html (mdgray, 13:31:32)
    3. These are not for userspace OVS (mdgray, 13:32:11)

  6. Fuel Deployment (mdgray, 13:32:41)
    1. Currently trying to use Fuel to deploy opnfv in Virtual environment (mdgray, 13:37:51)
    2. mdray: says need to setup up arno in virtual environment. (tfherbert1, 13:43:06)
    3. should we revisit whether fuel should be used as first deployment then? (tfherbert1, 13:44:14)
    4. we liked fuel because it is easy to use the post install to deploy alternate RPM. (tfherbert1, 13:45:03)
    5. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004484.html (mdgray, 13:45:15)
    6. This link outlines how to deploy in virtual environment. (mdgray, 13:45:31)

  7. Octopus Integration (mdgray, 13:47:14)
    1. It is also a goto meeting (mdgray, 13:48:07)
    2. We sent an email to project leads last week regarding the milestone approval process (fdegir, 13:49:37)
    3. which includes some info which could help you to get started with Octopus integration (fdegir, 13:49:54)
    4. We can review this information and we will discuss next week (mdgray, 13:50:17)
    5. Please have a look at the Etherpad linked on below mail to see what could be the expectations of Octopus and Installer projects (fdegir, 13:50:21)
    6. http://lists.opnfv.org/pipermail/opnfv-project-leads/2015-August/000012.html (fdegir, 13:50:25)
    7. Please note that the info on the Etherpad is still under discussion and hasn't been agreed on yet (fdegir, 13:50:45)
    8. Ok, thanks. (mdgray, 13:51:06)

  8. Any other topics? (mdgray, 13:54:09)


Meeting ended at 13:54:33 UTC (full logs).

Action items

  1. billyoma and mdgray to look for standard requirements template within opnfv projects
  2. mdgray to note current requirements in etherpad
  3. tfherfert to bring up requirements gathering as a discussion on the tech-discuss mailing list.


Action items, by person

  1. mdgray
    1. billyoma and mdgray to look for standard requirements template within opnfv projects
    2. mdgray to note current requirements in etherpad


People present (lines said)

  1. mdgray (42)
  2. fdegir (14)
  3. tfherbert1 (10)
  4. collabot (3)
  5. rgiller (1)
  6. billyom (1)


Generated by MeetBot 0.1.4.