#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (7th September 2015

Meeting started by mdgray at 13:00:52 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:01:03)
    1. mdgray (mdgray, 13:01:10)
    2. billyoma (billyoma, 13:01:11)
    3. tfherbert (tfherbert1, 13:01:17)
    4. gdunne (mdgray, 13:01:22)

  2. Agenda Bashing (mdgray, 13:03:47)
    1. Genesis Integration Requirements (mdgray, 13:05:49)
    2. Fuel Deployment in a VM (mdgray, 13:06:06)
    3. Userspace OVS RPM status (mdgray, 13:06:27)
    4. NSH status (mdgray, 13:06:32)
    5. Requirements format (mdgray, 13:06:42)

  3. Genesis Integration Requirements (mdgray, 13:07:27)
    1. Projects need to submit requirements to Genesis (mdgray, 13:08:41)
    2. https://wiki.opnfv.org/genesis/integration_guidelines (mdgray, 13:09:41)
    3. It's a three-step process:1. Submit requirement to Genesis and wait for approval. 2. Implement change in Genesis. 3. Submit code and wait for it to be approved and pushed. (mdgray, 13:16:32)
    4. Genesis responsibility to work with installer providers. (tfherbert1, 13:19:59)
    5. ACTION: mdgray Make first draft of Genesis requirement (mdgray, 13:20:33)
    6. mdgray will send around first draft and wait for comments. (mdgray, 13:21:23)

  4. Fuel Deployment in a VM (mdgray, 13:22:30)
    1. Purpose to install full environment in virtual machines (mdgray, 13:26:15)
    2. https://www.opnfv.org/software/download (mdgray, 13:28:44)
    3. Instructions for deploying opnfv (mdgray, 13:29:31)
    4. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004484.html (mdgray, 13:30:27)
    5. Gabor may have time to look at this and will report any findings (mdgray, 13:30:47)
    6. Someone at Intel will also look at this in the coming weeks (mdgray, 13:31:02)

  5. RPM Build Status (mdgray, 13:34:27)
    1. The process for the userspace OVS rpm is in progress. Its available as an internal (RH) rpm. (mdgray, 13:35:24)
    2. This is going through QA (mdgray, 13:36:01)
    3. There are some out of tree patches part of this (mdgray, 13:36:18)
    4. There is a static and shared library build. (mdgray, 13:36:30)
    5. These are RHEL rpms. Some changes may need to be made for CentOS (mdgray, 13:38:05)
    6. SPEC file will become part of the OVS release (mdgray, 13:41:08)

  6. NSH status (mdgray, 13:41:48)
    1. This patch is being reworked in Intel for upstreaming. (mdgray, 13:42:33)
    2. Requirements format (mdgray, 13:44:07)
    3. https://etherpad.opnfv.org/p/opnfv-ovsnfv_Requirements (mdgray, 13:45:03)
    4. billyoma looked for standard requirements template within opnfv projects. There was no standard format. There was .rst (in git) , etherpads, ppts, etc (mdgray, 13:47:37)
    5. Link to nsh issues: https://docs.google.com/presentation/d/1y0A1DNA1bB6y-1hR-ZfvtW8cKL4psMvj8BdaEMC4n2I/edit?usp=sharing (tfherbert1, 13:48:14)
    6. nsh: These issues are on agenda for this week's opnfv sfc meeting. (tfherbert1, 13:48:38)
    7. In vsperf all documents had to be converted to .rst. This was an OPNFV directive. (mdgray, 13:49:21)
    8. This was for checked-in documents. (mdgray, 13:49:45)
    9. AGREED: Initially we will gather requirements into etherpad. However, we will eventually migrate these into .rst in a git repository. (mdgray, 13:54:33)

  7. Other Items? (mdgray, 13:55:00)
    1. Start of extensive discussion of NSH requirements in sfc group: http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-September/004762.html (tfherbert1, 13:55:40)


Meeting ended at 13:55:58 UTC (full logs).

Action items

  1. mdgray Make first draft of Genesis requirement


Action items, by person

  1. mdgray
    1. mdgray Make first draft of Genesis requirement


People present (lines said)

  1. mdgray (42)
  2. tfherbert1 (5)
  3. collabot (4)
  4. billyoma (1)


Generated by MeetBot 0.1.4.