#opnfv-ovsnfv: 2015 Design Summit Breakout Meeting

Meeting started by mdgray at 23:28:14 UTC (full logs).

Meeting summary

  1. agenda bashing (mdgray, 23:29:24)
    1. Strategy for dealing with out of tree patches (mdgray, 23:30:06)
    2. RDO (mdgray, 23:30:08)
    3. CI (mdgray, 23:30:11)
    4. Phase 2 (mdgray, 23:30:17)
    5. System Performance Tuning (mdgray, 23:31:23)

  2. Phase 2 (mdgray, 23:34:48)
    1. Can a feature be implemented just in userspace and not in kernel space? (mdgray, 23:39:12)
    2. Might be worth bringup up at the OVS summit (mdgray, 23:39:31)
    3. This introduces a dependency between kernel space and userspace datapath (mdgray, 23:40:58)
    4. How do we deal with new requirements. (mdgray, 23:44:07)
    5. i.e. What is the process? (mdgray, 23:44:46)
    6. What are the tools we should use? (mdgray, 23:46:00)
    7. Options: Jira, Git, Etherpad (mdgray, 23:49:58)
    8. Mark to look into process in order to promote Gabor as a committer (mdgray, 23:51:53)
    9. Suggested process is that we get requirements in various ways (for example via email), and then input them into git/gerrit for review and refinement followed by moving them to Jira when we are in the implementation phase. (mdgray, 23:54:54)
    10. ACTION: Mark to document this process on the wiki and to test the workflow (mdgray, 23:55:36)
    11. AGREED: To send out a request to opnfv community in order to get vswitch requirements (mdgray, 00:03:24)
    12. we will do this after the OVS summit (mdgray, 00:03:40)
    13. Gabor: We can get performance requirements from the VSPERF community. (mdgray, 00:06:33)

  3. Strategy for dealing with out of tree patches (mdgray, 00:10:08)
    1. Discussion about leveraging RHs rpms (mdgray, 00:12:13)
    2. What about ubuntu??? (mdgray, 00:12:40)
    3. they probably follow the same process (mdgray, 00:12:48)
    4. A lot of effort to maintain out of tree patches (mdgray, 00:17:48)
    5. Should we maintain an OVS repo for OPNFV so all opnfv projects can pull from this directly and merge their code into before it gets pushed upstream? (mdgray, 00:23:59)
    6. Openstack in OPNFV always uses upstream? (mdgray, 00:24:22)
    7. Thomas: We aren't resourced to maintain a fork, we are forced to always work upstream. (mdgray, 00:32:28)
    8. Lets work pure upstream for a while and see how it goes. (mdgray, 00:32:54)
    9. There is a risk that there will be duplication of effort across OPNFV projects (mdgray, 00:34:23)
    10. There is value to maintaining a list of requirements as it serves as a central database of work that needs to be done (mdgray, 00:40:09)
    11. AGREED: For the moment we will only work upstream and won't maintain any kind of OPNFV fork (mdgray, 00:41:23)
    12. We might revisit this in the future (mdgray, 00:41:33)
    13. We need to engage with Dan Radez in Apex in order to work with Apex (mdgray, 00:50:58)
    14. Question about can we run user and kernel datapath in same binary (mdgray, 00:55:06)


Meeting ended at 01:06:58 UTC (full logs).

Action items

  1. Mark to document this process on the wiki and to test the workflow


People present (lines said)

  1. mdgray (40)
  2. collabot (4)


Generated by MeetBot 0.1.4.