#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (November 30th 2015)

Meeting started by mdgray at 13:00:49 UTC (full logs).

Meeting summary

    1. Roll Call (mdgray, 13:00:57)
    2. mdgray (mdgray, 13:02:27)
    3. gdunne (gdunne, 13:03:45)
    4. Billy O'Mahony (billyoma, 13:04:05)
    5. Gabor Halasz (gabor_halasz, 13:04:34)
    6. Tom Herbert (mdgray, 13:04:37)

  1. Agenda Bashing (mdgray, 13:04:53)
    1. rpm artifact build (mdgray, 13:06:02)
    2. Fuel Plugin (mdgray, 13:06:18)
    3. Fuel - Sync with SFC project (mdgray, 13:06:41)
    4. CI (mdgray, 13:07:12)
    5. Jonas Bjurel ([1]JonasB, 13:07:19)

  2. Fuel Plugin (mdgray, 13:07:31)
    1. Still trying to find workable solution for Fuel Plugin (mdgray, 13:08:20)
    2. Daniel has offered a fuel server with latest build with one compute and one control. With this we can focus on the mechanics of installing a plugin. (mdgray, 13:09:20)
    3. Billy has hit some bugs in Fuel 6.1. (mdgray, 13:10:24)
    4. Not much return in fixing in 6.1. We will need to migrate to Fuel 7. (mdgray, 13:10:57)

  3. Fuel - Sync with SFC project (mdgray, 13:15:34)
    1. Daniel Smith (finally got in :P ) (lmcdasm, 13:16:02)
    2. Reaching out to Ruijing who is working on SFC project. Seems like there is some overlap. (mdgray, 13:16:40)
    3. They are doing something similar but we are not sure if they have enabled DPDK portion of code. (mdgray, 13:18:15)
    4. If they have enabled DPDK we should adopt and then modify, if they haven't then we should help them out. (mdgray, 13:18:52)
    5. Daniel is going to send around meeting invite so we can potentially talk to them directly in public. (mdgray, 13:22:17)
    6. https://review.openstack.org/#/c/250637/2/deployment_scripts/puppet/manifests/ovs-install-compute.pp (gdunne, 13:23:57)
    7. OVS-NSH: https://github.com/openstack/fuel-plugin-ovs/commits/master ([1]JonasB, 13:23:59)
    8. https://review.openstack.org/#/c/250637/2/deployment_scripts/puppet/manifests/ovs-install-compute.pp (lmcdasm_, 13:24:25)
    9. simonac (simonac_, 13:30:02)

  4. CI (mdgray, 13:31:00)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-October/006085.html (mdgray, 13:31:24)
    2. Jenkins is using "Jenkins Job Builder" (mdgray, 13:32:39)
    3. We should use the "releng" project (mdgray, 13:32:58)
    4. Jonas says that there should be a CI folder in our repo and a build.sh script. (mdgray, 13:37:42)
    5. This gets run nightly and the return code is checked for pass/failure (mdgray, 13:37:55)
    6. jonas; It also gets run when we commit code. (mdgray, 13:38:09)
    7. We need to be registered. (mdgray, 13:38:30)
    8. ACTION: Mark: Get registered with Fatih (mdgray, 13:38:47)
    9. https://build.opnfv.org/ci/ ([1]JonasB, 13:39:52)
    10. Our git repo is empty! (mdgray, 13:41:02)
    11. Tom wants to build an rpm nightly from here (mdgray, 13:41:30)
    12. Fuel plugin should be in the fuel repo (mdgray, 13:41:41)
    13. We can validate upstream code against opnfv tests. We will build ovs-dpdk nightly. (mdgray, 13:43:52)

  5. Committer Gabor (mdgray, 13:54:03)
    1. process ongoing (mdgray, 13:54:33)


Meeting ended at 13:55:18 UTC (full logs).

Action items

  1. Mark: Get registered with Fatih


People present (lines said)

  1. mdgray (39)
  2. collabot (5)
  3. [1]JonasB (3)
  4. gdunne (2)
  5. gabor_halasz (1)
  6. simonac_ (1)
  7. lmcdasm_ (1)
  8. lmcdasm (1)
  9. billyoma (1)


Generated by MeetBot 0.1.4.