#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (December 7th 2015)

Meeting started by mdgray at 13:02:51 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:03:06)
    1. mdgray (mdgray, 13:03:11)
    2. Ana Cunha (anac1, 13:03:15)
    3. gdunne (gdunne, 13:03:16)
    4. Peter Barabas (z0d, 13:03:22)
    5. Billy O'Mahony (billyoma, 13:03:23)

  2. Agenda Bashing (mdgray, 13:04:48)
    1. Do we want to enforce a policy JIRA tag on all commits? (mdgray, 13:04:59)
    2. Simona (Simona_, 13:04:59)
    3. Select someone to go to the functest meetings. (mdgray, 13:05:12)
    4. Gabor promoted to committer. Congratulations! (mdgray, 13:05:23)
    5. Development Update (mdgray, 13:05:34)
    6. Review of e-mail to be sent to list regarding requirements. (mdgray, 13:05:47)
    7. https://etherpad.opnfv.org/p/fuel@opnfv-meet etherpad for agenda. (billyoma, 13:07:36)
    8. https://etherpad.opnfv.org/p/fuel@opnfv-meet (mdgray, 13:07:53)

  3. Do we want to enforce a policy JIRA tag on all commits? (mdgray, 13:08:46)
    1. Some projects have this. Does this project need it? (mdgray, 13:09:02)
    2. AGREED: We will leave the flexibility that we have at the moment and revisit at a later date (mdgray, 13:10:57)

  4. Select someone to go to the functest meetings. (mdgray, 13:11:15)
    1. we have been registered with functest (mdgray, 13:11:39)
    2. It runs at Thursdays at 4pm GMT (mdgray, 13:11:54)
    3. Ana clarifies that this is the general testing meeting (mdgray, 13:12:32)
    4. We will treat functest as a regression test (mdgray, 13:12:58)
    5. Initially, we will not add any specific tests for this project. (mdgray, 13:13:23)
    6. This would just be Robot and Tempest (mdgray, 13:14:17)
    7. We will need to do additional testing with Yardstick and vsperf (mdgray, 13:15:03)
    8. Functest meeting is at an awkward time for most attendees (mdgray, 13:17:57)
    9. AGREED: Simona and/or Gillian can monitor offline and report any key issues on this call (mdgray, 13:18:15)
    10. There will be a discussion at the release meeting tomorrow in which testing will be discussed. We need an attendee at this call tomorrow. (mdgray, 13:22:02)

  5. Gabor promoted to committer. Congratulations! (mdgray, 13:23:04)
  6. Review of e-mail to be sent to list regarding requirements. (mdgray, 13:24:27)
    1. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:25:12)
    2. In above link (mdgray, 13:25:25)
    3. In section 5 (mdgray, 13:25:38)
    4. Billy suggests sending to all of opnfv-tech-discuss (mdgray, 13:27:44)
    5. ACTION: Mark to send out email with request to opnfv-tech-discuss (mdgray, 13:28:13)

  7. Development Update (mdgray, 13:28:21)
    1. 1. Fuel Plugin Development (mdgray, 13:28:49)
    2. support from Fuel team and Montreal Pod (mdgray, 13:29:01)
    3. Moved to Fuel 7 and now plugin is recognised by Fuel (mdgray, 13:29:25)
    4. https://github.com/billyom/fuel-plugin-billy (billyoma, 13:30:53)
    5. https://github.com/billyom/fuel-plugin-billy (mdgray, 13:31:28)
    6. Still some issues. "Nailgun" is dying. (mdgray, 13:31:28)
    7. Some issues with underlay network configuration (mdgray, 13:31:51)
    8. Long test, debug, deploy cycle (mdgray, 13:32:10)
    9. deploy is taking 1-1.5 hours (mdgray, 13:32:35)
    10. Gillian has got a virtual deployment of 7 up but it is not deploying Billy's plugin. (mdgray, 13:33:26)
    11. 2. DPDK packages (mdgray, 13:34:49)
    12. Billy synced with the SFC project (mdgray, 13:35:19)
    13. SFC has binary deb packages for Native OVS (kernel) for Ubuntu 14.04 (mdgray, 13:36:08)
    14. Source packages would be better to compile on the node to give better performance. However, at this stage anything would be great! :) (mdgray, 13:37:06)
    15. There was an email about project dependencies. (mdgray, 13:37:56)
    16. For OVSNFV, the following were highlighted (mdgray, 13:38:05)
    17. Qemu 2.1.0+ (mdgray, 13:38:13)
    18. Openstack - Kilo (mdgray, 13:38:32)
    19. ODL - Berryllium (mdgray, 13:38:52)
    20. The ODL dependency wont be met as it arrives after Brahmaputra (mdgray, 13:39:28)
    21. There *should* be no specific kernel dependency (mdgray, 13:39:47)
    22. We are tied to Ubuntu because Fuel is for Ubuntu only (mdgray, 13:40:20)
    23. ACTION: Mark to confirm what DPDK version is needed. (mdgray, 13:45:22)
    24. Should be possible to build a debian package using the "dist" Makefile target. Someone should check this. (mdgray, 13:46:36)
    25. https://github.com/openvswitch/ovs/tree/master/rhel (mdgray, 13:48:04)
    26. https://github.com/openvswitch/ovs/tree/master/debian (mdgray, 13:48:11)
    27. https://github.com/openvswitch/ovs/blob/master/INSTALL.Debian.md (mdgray, 13:48:52)
    28. The above link could be useful. (mdgray, 13:49:01)
    29. Fuel deploys Ubuntu 14.04 for Brahmaputra. This is an LTS release. (mdgray, 13:50:39)
    30. OVSNFV has a dependency on this version. (mdgray, 13:50:50)
    31. SFC can build a kernel space package but cant build userspace one (mdgray, 13:51:33)

  8. Others (mdgray, 13:53:52)
    1. qemu --enable-num required for huge-pages, is set on qemu for rel-B. (mdgray, 13:53:55)
    2. Is this a compile-time or run-time parameter? (mdgray, 13:55:35)
    3. effects of various opnfv major deployment options - KVM/QEMU, Neutron w. VLAN/Tunelling(VXLAN/GRE via Fuel CLI).The networking equipment must support VXLAN segmentation. This option supports millions of tenant data networks. (mdgray, 13:56:17)
    4. This is a comment on the test effort. The number of combinations and permutations is growing ... (mdgray, 13:56:58)
    5. This is a general issue across OPNFV (mdgray, 13:57:52)
    6. OVSNFV will need to be very specific about what versions we are compatible with to narrow the scope. (mdgray, 13:58:49)
    7. There may be a way to limit this in Fuel (mdgray, 13:59:28)


Meeting ended at 13:59:52 UTC (full logs).

Action items

  1. Mark to send out email with request to opnfv-tech-discuss
  2. Mark to confirm what DPDK version is needed.


People present (lines said)

  1. mdgray (77)
  2. collabot (6)
  3. billyoma (3)
  4. Simona_ (1)
  5. anac1 (1)
  6. gdunne (1)
  7. z0d (1)


Generated by MeetBot 0.1.4.