#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (December 14th 2015)

Meeting started by mdgray at 12:59:28 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:02:38)
    1. Mark Gray (mdgray, 13:02:43)
    2. gdunne (gdunne, 13:03:26)
    3. Tom Herbert (tfherbert, 13:03:29)
    4. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:04:41)

  2. Agenda (mdgray, 13:04:58)
    1. Agenda can be found at https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:05:08)
    2. Welcome New Contributers (mdgray, 13:05:42)
    3. Jira/Gerrit Policy (mdgray, 13:06:00)
    4. Dev Updates: Fuel (mdgray, 13:06:15)
    5. Dev updates: RPMs (mdgray, 13:06:21)
    6. Dev updates: Debs (mdgray, 13:06:29)
    7. Dev Updates: CI (mdgray, 13:06:36)
    8. Requirements (mdgray, 13:06:46)

  3. Welcome New Contributers (mdgray, 13:07:03)
    1. Paul Kangil Choi (ETRI, forerunner@etri.re.kr) Yuki Kasuya (KDDI R&D Laboratories, yu-kasuya@kddilabs.jp) (mdgray, 13:08:02)
    2. Welcome on board! (mdgray, 13:08:16)

  4. Jira/Gerrit Policy (mdgray, 13:08:30)
    1. Not necessary to have a Jira tag for every commit. (mdgray, 13:09:17)
    2. We need to update instructions for committing code to our repo. (mdgray, 13:10:49)
    3. ACTION: Mark has some instructions to show how to make git commits to our repo. (mdgray, 13:11:50)
    4. Gerrit allows us to review patches (mdgray, 13:16:42)
    5. https://gerrit.opnfv.org/gerrit/#/q/project:ovsnfv (mdgray, 13:17:00)
    6. These are the list of patches that have been submitted. (mdgray, 13:17:12)
    7. We need to decide on a policy as to when we can push changes to our repository (mdgray, 13:18:48)
    8. ACTION: Tom will see if it is possible to add a group of users for review (e.g. OVSNFV committers) (mdgray, 13:20:12)

  5. Dev Updates: Fuel (mdgray, 13:20:39)
    1. Deadline for Fuel code freeze 18th December (mdgray, 13:21:03)
    2. There might be leeway on that (middle of next week) (mdgray, 13:21:21)
    3. There is a similar Fuel plugin being developed by the SFC team (mdgray, 13:22:04)
    4. We are trying to align as much as possible with that. (mdgray, 13:22:25)
    5. Idea end state would be one plugin. This is a goal (mdgray, 13:25:46)
    6. OVSNFV plugin is working in Ericsson Montreal Pod (hardware environment) but not in a virtual environment (mdgray, 13:26:23)
    7. We have a daily meeting at 9am (Dublin Time) with Fuel@OVSNFV to work through these problems. They are giving great support! (mdgray, 13:28:13)
    8. If anyone wants to attend, let me know (mdgray, 13:28:29)

  6. Dev updates: RPMs (mdgray, 13:28:41)
    1. Goal is to build RPM from the master tree (native OVS). This will provide a framework to do this for userspace OVS (mdgray, 13:29:58)
    2. Next step is an analogous step for Apex. (mdgray, 13:30:39)
    3. Tom plans to get help from Tim and Dan to achieve this. (mdgray, 13:31:15)
    4. we currently are supporting fuel installer. (tfherbert, 13:32:27)
    5. Currently rpms are stored locally but plan is to put them into artifacts. (mdgray, 13:33:28)
    6. Plan would be that Apex would then pull that rpm (mdgray, 13:34:06)
    7. tfherbert is working on preparing rpms for apex installer for now. (tfherbert, 13:35:31)
    8. other installers will come later. (tfherbert, 13:35:38)
    9. 18th December deadline is that the fuel plugin is code complete (mdgray, 13:38:50)
    10. When we are doing an Apex and a Fuel build, we will probably need to use two servers as one will have centos and one will have ubuntu (mdgray, 13:41:52)
    11. We can use build.sh to be our entry point which calls other build scripts (mdgray, 13:47:02)

  7. Dev updates: Debs (mdgray, 13:47:39)
    1. We can build debian packages using upstream code (mdgray, 13:47:58)
    2. We still need to decide how we will do this. There are a few potential methodologies. (mdgray, 13:50:02)

  8. Dev Updates: CI (mdgray, 13:52:06)
    1. We have covered that in previous topics on this call (mdgray, 13:52:14)

  9. Requirements (mdgray, 13:52:34)
    1. Sent out e-mail polling for requirements (mdgray, 13:53:32)


Meeting ended at 13:56:34 UTC (full logs).

Action items

  1. Mark has some instructions to show how to make git commits to our repo.
  2. Tom will see if it is possible to add a group of users for review (e.g. OVSNFV committers)


People present (lines said)

  1. mdgray (57)
  2. collabot` (6)
  3. tfherbert (4)
  4. gdunne (1)


Generated by MeetBot 0.1.4.