#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (December 21st 2015)

Meeting started by mdgray at 13:03:26 UTC (full logs).

Meeting summary

    1. Mark Gray (mdgray, 13:03:34)

  1. Roll Call (mdgray, 13:04:05)
    1. Tom Herbert (tfherbert, 13:04:08)
    2. Mark Gray (mdgray, 13:04:09)
    3. gdunne (gdunne, 13:04:10)
    4. Larry Lamers (ljlamers_, 13:04:14)
    5. Tom Herbert (tfherbert, 13:04:21)
    6. Simona Coppola (Simonac, 13:04:23)
    7. yuki kasuya (yuki_, 13:04:25)

  2. Agenda (mdgray, 13:04:30)
    1. Billy O'Mahony (billyoma, 13:04:30)
    2. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:04:35)

  3. Christmas Schedule (mdgray, 13:05:32)
    1. ACTION: Billy to cancel 28th Meeting. Next meeting will be on the 4th of January (mdgray, 13:06:06)

  4. Dev Update - Fuel (mdgray, 13:06:30)
    1. "Hello world" plugin was deployed using Fuel. It deployed a Debian package. (mdgray, 13:07:10)
    2. Then it was decided to change plugin to deploy and compile on the node. (mdgray, 13:07:57)
    3. Tom: What was the reason for it? (mdgray, 13:08:06)
    4. Convenience was one reason. Opportunity to use puppet manifests that were already available. (mdgray, 13:08:39)
    5. Also, the performance will be better as we can turn on optimizations. (mdgray, 13:09:03)
    6. Perhaps in the future we could install a Debian. (mdgray, 13:10:15)
    7. https://github.com/mrmarkgray/fuel-plugin-ovsnfv (mdgray, 13:10:55)
    8. Current plugin is in this link (mdgray, 13:11:17)
    9. There is a "stable" branch (mdgray, 13:11:32)
    10. Fuel guys don't want to maintain the plugin. They will clone the plugin source. They will build it and then package it into the ISO. (mdgray, 13:12:22)
    11. Currently we need a final location for this plugin. (mdgray, 13:13:15)
    12. Probably put this in the ovsnfv repo. (mdgray, 13:13:28)
    13. We have made Fuel's WP2 but it is not fully functional. Openstack integration needs a bit of work. (mdgray, 13:17:51)
    14. Fuel is targeting Liberty for Brahmaputra. (mdgray, 13:18:45)
    15. Tom: How are you dealing with original goal of an alternate build? (mdgray, 13:20:01)
    16. There is a tickbox on the UI or a command line parameter to enable it. (mdgray, 13:21:24)
    17. We will need documentation and/or a video to show it. (mdgray, 13:21:38)

  5. Dev Update - RPM (mdgray, 13:21:53)
    1. First step is to build a native binary using upstream code. (mdgray, 13:23:12)
    2. There are some nuances to running in OVSNFV context. (mdgray, 13:23:31)
    3. Built and worked locally and then pushed upstream. (mdgray, 13:23:44)
    4. "releng" was not doing ovsnfv builds (mdgray, 13:24:10)
    5. Trying to get rpm pushed to the artifactory. (mdgray, 13:24:29)
    6. "releng" didn't like that we were producing artifacts as part of verify. (mdgray, 13:25:46)
    7. There are some rpms up there already "http://artifacts.opnfv.org/ovsnfv/opnfv-2015-12-18-openvswitch-2.5.90-1.x86_64.rpm" (mdgray, 13:26:53)
    8. Artifacts should be part of merge and daily jobs and placed together for others to consume. (mdgray, 13:31:34)
    9. Tom will work with Fatih on this. (mdgray, 13:31:55)
    10. http://artifacts.opnfv.org/ovsnfv/opnfv-2015-12-18-openvswitch-2.5.90-1.x86_64.rpm (tfherbert, 13:42:53)
    11. https://gerrit.opnfv.org/gerrit/#/c/4907/ (tfherbert, 13:44:00)
    12. Discussion about forking again :) (mdgray, 13:45:54)
    13. SFC is an example (mdgray, 13:46:02)
    14. One suggestion is that we don't fork but we make sure our packaging and testing has the option to apply patches sometime before deploy. (mdgray, 13:47:12)

  6. Requirements (mdgray, 13:53:58)
    1. Two requirements so far: (mdgray, 13:54:57)
    2. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/007268.html (mdgray, 13:55:00)
    3. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/007266.html (mdgray, 13:55:24)
    4. , I understand what you are saying about vsperf. But does vsperf test against specific perf requirements? (tfherbert, 13:56:39)
    5. I don't think it has any requirements yet. It just measures and reports. (mdgray, 14:02:57)


Meeting ended at 14:03:21 UTC (full logs).

Action items

  1. Billy to cancel 28th Meeting. Next meeting will be on the 4th of January


People present (lines said)

  1. mdgray (53)
  2. fdegir (6)
  3. collabot` (6)
  4. tfherbert (5)
  5. gdunne (1)
  6. yuki_ (1)
  7. billyoma (1)
  8. Simonac (1)
  9. ljlamers_ (1)


Generated by MeetBot 0.1.4.