#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (February 8th 2015)

Meeting started by mdgray at 13:04:24 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray, 13:04:29)
    1. Mark Gray (mdgray, 13:04:33)
    2. Tom Herbert (tfherbert, 13:05:18)

  2. Agenda (mdgray, 13:05:33)
    1. simona coppola (Simona, 13:05:35)
    2. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray, 13:05:46)

  3. RPMs (mdgray, 13:07:10)
    1. Currently working on patch #6 for integrating accelerated OVS. patch #5 only had kernel-based OVS (mdgray, 13:08:07)
    2. Can now build from top of master (mdgray, 13:08:24)
    3. ACTION: Mark/Billy/Gabor will review. Tom wants two people to +1 before pushing. (mdgray, 13:11:16)
    4. Al Morton (acm_, 13:11:43)
    5. Tom is looking for feedback on naming conventions and how many releases we want. (mdgray, 13:12:26)
    6. Apex will pull these RPMs from the artifactory (mdgray, 13:13:03)
    7. Patch will remain in 'master' for the moment. (mdgray, 13:13:30)
    8. This is sufficient for a daily and a merge build to produce artifactory (mdgray, 13:13:52)
    9. The intention of this is to test the software accelerated OVS with the Apex installer (mdgray, 13:15:02)

  4. Fuel (mdgray, 13:15:21)
    1. We have a Fuel 8/Liberty plugin that deploys accelerated open vswitch in a brahmaputra deployment (mdgray, 13:16:25)
    2. This is in master and stable/brahmaputra (mdgray, 13:16:38)
    3. There are still a few non-blocking issues (mdgray, 13:18:14)
    4. Virtual deploy doesnt work. Further testing is needed (mdgray, 13:18:30)
    5. Larry Lamers (ljlamers, 13:19:21)
    6. Some issues related to bypassing the kernel network stack (mdgray, 13:19:44)
    7. Some issues related to debian packages have been found. A patch has been posted and awaiting review (mdgray, 13:21:48)
    8. https://gerrit.opnfv.org/gerrit/#/c/9389/ (mdgray, 13:21:50)
    9. CI is running. Success on CI build. Build has successfully completed. Dont know results of the different tests (Functest, Yardstick) (mdgray, 13:22:57)
    10. In general for Fuel, we seem to be in a good state for B-release (mdgray, 13:23:39)

  5. Documentation (mdgray, 13:23:50)
    1. Fuel documentation will need to be started (mdgray, 13:24:01)
    2. Template is available in OVSNFV repo (mdgray, 13:24:11)
    3. There may be documentation required for Apex. (mdgray, 13:24:27)

  6. Other (mdgray, 13:25:20)
    1. We need look at our builds (releng). Are they sufficient? This needs to be looked at .. (mdgray, 13:26:11)
    2. This is abother work item for the C-release (mdgray, 13:26:24)
    3. Simona is going to help drive a roadmap for the C-rrelease. (mdgray, 13:28:21)
    4. Simona did something similar for Vsperf (mdgray, 13:28:34)
    5. vsperf developed a list and then did a vote (mdgray, 13:29:05)
    6. Simona is going to kick this off next week. (mdgray, 13:29:19)
    7. ACTION: Everyone: Think about key work items and we will discuss in the next meeting (mdgray, 13:29:41)
    8. Agenda item added for this. (mdgray, 13:31:58)


Meeting ended at 13:32:40 UTC (full logs).

Action items

  1. Mark/Billy/Gabor will review. Tom wants two people to +1 before pushing.
  2. Everyone: Think about key work items and we will discuss in the next meeting


People present (lines said)

  1. mdgray (42)
  2. collabot (5)
  3. ljlamers (1)
  4. Simona (1)
  5. tfherbert (1)
  6. acm_ (1)


Generated by MeetBot 0.1.4.