#opnfv-ovsnfv: opnfv hackfest breakout

Meeting started by billyoma at 16:19:59 UTC (full logs).

Meeting summary

    1. Billy, Al, Tom, Larry (billyoma, 16:20:14)
    2. Al mentions new OF feature - auxilarry controllers. Want to know about directing priorit packets to auxillary controllers. (billyoma, 16:49:50)
    3. Al points out that we need to prioritize important traffic both when we know how to deal iwth it (emc...OF hit) and when we do not - packet_out req to controller. (billyoma, 16:56:43)

  1. REview of Rel C priority list (billyoma, 17:41:03)
    1. https://wiki.opnfv.org/release_c_planning/priority_list (billyoma, 17:41:06)
    2. https://wiki.opnfv.org/release_c_planning/priority_list (billyoma, 17:55:11)

  2. Apex Feature List (billyoma, 18:13:25)
    1. NSH VxLAN based on Pritesh patches (billyoma, 18:14:14)
    2. Waiting for kernel patches to upstream: Linux VxLAN and LWT (light weight tunnels) (billyoma, 18:22:04)
    3. pritesh patches to OVS are now abandoned and to be replaced by same functionality in the pending kernel patches. (billyoma, 18:36:42)

  3. MPLS over GRE (billyoma, 18:39:44)
    1. Simon Hormon is working on this. Again there are two sets of patches for this. Kernel and OVS. (billyoma, 18:41:20)
    2. It's not certain that it will make it in time for Rel -C. (billyoma, 18:41:50)
    3. Latest info from Simon Horman regarding MPLSoGRE: “At this stage I'm trying to shake out how the vport support for the datapath will look[1] as that will effect both the kernel and user-space implementation of L3 GRE. I would wait for that to be resolved before exercising the code. (billyoma, 18:42:11)
    4. https://www.mail-archive.com/dev@openvswitch.org/msg56967.html (billyoma, 18:42:24)

  4. 100G, Virtio Container requirement (billyoma, 18:47:38)
    1. no details on page for these requirements (billyoma, 18:47:55)

  5. port placement on cores (billyoma, 18:48:06)
    1. no details on page for this req - but some work in ongoing for NUMA aware pmd and VM placement (billyoma, 18:48:35)

  6. JOID features (billyoma, 18:48:44)
    1. very little detail or discussion on these items. (billyoma, 18:51:00)
    2. Some updates to the wiki have been made during this discussion. (billyoma, 18:52:11)
    3. ACTION: Billy to forward flipchart photos. (billyoma, 18:52:22)


Meeting ended at 18:52:40 UTC (full logs).

Action items

  1. Billy to forward flipchart photos.


People present (lines said)

  1. billyoma (41)
  2. collabot` (5)


Generated by MeetBot 0.1.4.