#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (11th July 2016)

Meeting started by mdgray_ at 14:03:24 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray_, 14:03:33)
    1. Mark Gray (mdgray_, 14:03:41)

  2. Agenda (mdgray_, 14:04:31)
    1. Billy O'Mahony (billyo, 14:04:32)
    2. https://etherpad.opnfv.org/p/ovsnfv-meet (mdgray_, 14:04:35)

  3. Fuel Demo (mdgray_, 14:06:08)
    1. Billy presents demo slides (mdgray_, 14:07:27)
    2. outlines goal of brahmaputra release (mdgray_, 14:07:40)
    3. Billy ran tests using two versions of OPNFV. One with the Fuel plugin for OVS/DPDK and one without OVS/DPDK (mdgray_, 14:09:15)
    4. Some benchmarks have been done with OVS in an isolated manner. These tests are more "realistic" as they are run in a real deployment. (mdgray_, 14:10:03)
    5. Demo results show the difference bettwen the two (mdgray_, 14:11:04)
    6. Initial results are good: Throughput x 3 and latency / 5 (mdgray_, 14:11:59)
    7. Tests are netperf UDP tests (mdgray_, 14:12:10)
    8. OVS/DPDK latency is very smooth but there are latency spikes in longer time intervals (mdgray_, 14:13:51)
    9. Tom Herbert (tfherbert, 14:14:21)
    10. Sorry I am late. Are tests published? (tfherbert, 14:14:44)
    11. In Rel-B test there are about 10-15 tests in the CI (mdgray_, 14:15:16)
    12. There are about 40 tests in Yardstick (mdgray_, 14:15:25)
    13. Don't know if that will change for Colorado (mdgray_, 14:15:36)
    14. Billy has run all tests but the results are not published yet (mdgray_, 14:16:36)
    15. He will do a more formal analysis this week and aim to present results next week. (mdgray_, 14:18:23)
    16. For Brahmaputra all tests seem to pass (mdgray_, 14:18:45)
    17. For Colorado goal, all tests should pass. (mdgray_, 14:19:05)
    18. Need to enable tests for CI-pipeline. (mdgray_, 14:19:29)
    19. Functest tests seem to pass but need to confirm. This could be a future readout at this forum. (mdgray_, 14:20:49)
    20. x3 wrt what? (tfherbert, 14:20:52)
    21. Yardstick tests uses ubunto cloud image that is modified for yardstick (mdgray_, 14:22:28)
    22. image uploaded to glance (mdgray_, 14:22:58)
    23. heat used to run tests (mdgray_, 14:23:06)
    24. Grafana to display the results. (mdgray_, 14:23:13)
    25. Same methodology should work with Apex (mdgray_, 14:23:33)
    26. Billy showing live output from montreal pod (mdgray_, 14:23:58)
    27. Billy presents possible demo and yardstick next steps (mdgray_, 14:27:02)
    28. Chunghan asks if there is any background traffic (mdgray_, 14:29:45)
    29. There isnt, this is sending traffic between VMs on the same host. It is one the Yardstick testcases (mdgray_, 14:30:33)
    30. These tests are UDP tests (mdgray_, 14:32:03)

  4. Fuel Update (mdgray_, 14:32:23)
    1. Yardstick and Functest tests will be run and the results will be documented to determine gaps (mdgray_, 14:33:01)
    2. Focus on Brahmaputra for performance as we have confidence that Brahmputra works correctly (mdgray_, 14:33:54)
    3. Same for functest (mdgray_, 14:34:09)
    4. ACTION: Billy: Check if our scenario will be run nightly against C-release (mdgray_, 14:35:54)
    5. Colorado will need to be setup and tested to ensure it still functions correctly (mdgray_, 14:37:29)
    6. Manual test would be more efficient to do this before CI is set up. This will help expose any gotchas such as cabling, issues with installing the fuel iso (mdgray_, 14:38:51)

  5. Documentation (mdgray_, 14:39:06)
    1. General OPNFV installation document could have been better. For colorado, each scenario would have its own installation guide. (mdgray_, 14:40:54)
    2. This would be based off a template installation guide for the os-nosdn-nofeature-ha scenario (mdgray_, 14:41:23)
    3. We are waiting on this template from the documentation project. (mdgray_, 14:41:39)

  6. Project Milestones update (mdgray_, 14:42:13)
    1. David Mc Bride is looking for project milestone updates (mdgray_, 14:42:28)
    2. https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects (mdgray_, 14:42:43)
    3. ACTION: Mark to update project milestones (mdgray_, 14:43:14)
    4. ACTION: Mark to check the scenario dependencies to ensure that our scenario is dependent on the ovs-nsh plugin with a particular configuration (instead of the deprecated ovs plugin) (mdgray_, 14:44:41)
    5. Billy will also highlight this to the fuel team but we might need to inform Fatih (mdgray_, 14:45:05)
    6. Apex updates (mdgray_, 14:45:50)
    7. Tom will provide updates offline. (mdgray_, 14:46:17)
    8. We are passed feature freeze. Has it been deployed/ (mdgray_, 14:46:35)
    9. It would be nice to get a demo. (mdgray_, 14:46:42)

  7. Feature development (mdgray_, 14:47:12)
    1. Thanks for the comments (mdgray_, 14:47:17)
    2. Mark needs to update based on the comments. (mdgray_, 14:47:24)
    3. Mark got some other comments in private via email so I will update based on them aswell (mdgray_, 14:47:57)

  8. Other topics (mdgray_, 14:48:49)
    1. Is there a link for good general OPNFV documentation (mdgray_, 14:49:10)
    2. https://www.opnfv.org/opnfv-brahmaputra-fuel-users (billyo, 14:49:50)
    3. Full installation required a lot of infrastructure for bare metal (mdgray_, 14:52:08)
    4. Virtual install needs to be tested for OVSNFV with colorado release. (mdgray_, 14:52:33)


Meeting ended at 14:52:45 UTC (full logs).

Action items

  1. Billy: Check if our scenario will be run nightly against C-release
  2. Mark to update project milestones
  3. Mark to check the scenario dependencies to ensure that our scenario is dependent on the ovs-nsh plugin with a particular configuration (instead of the deprecated ovs plugin)


People present (lines said)

  1. mdgray_ (79)
  2. collabot (9)
  3. tfherbert (4)
  4. billyo (3)
  5. lch (1)


Generated by MeetBot 0.1.4.