#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (18th July 2016)

Meeting started by mdgray_ at 14:02:59 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray_, 14:03:08)
    1. Mark Gray (mdgray_, 14:03:12)
    2. Tom Herbert (tfherbert1, 14:03:18)
    3. Chunghan Lee (lch, 14:03:22)
    4. Billy O'Mahony (billyo, 14:04:37)
    5. Yardstick Results for OVSNFV with Fuel (mdgray_, 14:05:19)
    6. Fuel Update (mdgray_, 14:05:24)
    7. Apex Update (mdgray_, 14:05:31)
    8. Spec review (mdgray_, 14:05:51)

  2. Yardstick Results for OVSNFV with Fuel (mdgray_, 14:06:02)
    1. Billy has tested Fuel with and without OVSNFV plugin against yardstick and functest (mdgray_, 14:08:11)
    2. This is for Rel B (mdgray_, 14:08:20)
    3. Functest passes (mdgray_, 14:08:27)
    4. There at least 37 testcases but only 7 were enabled for CI in Brahmaputra (mdgray_, 14:09:52)
    5. ACTION: Billy will follow-up with Yardstick team to understand what tests will be enabled for Colorado. (mdgray_, 14:10:43)
    6. TC002 ping test shows 4-times lower latency for ovsnfv plugin (mdgray_, 14:12:32)
    7. TC005 File IO test shows broadly similar results. (mdgray_, 14:14:48)
    8. TC010 memory latency test shows broadly similar results. (mdgray_, 14:15:19)
    9. TC011 Packet delay variation test shows eerily similar results. (mdgray_, 14:15:56)
    10. TC012 Mem r/w show better throughput. Unsure why this would be the case? (mdgray_, 14:19:56)
    11. TC014 CPU Speed test shows better result for OVS over OVSNFV. (mdgray_, 14:21:17)
    12. Many of the tests are run several times and the results don't change considerably between test runs. (mdgray_, 14:24:38)
    13. TC037 Pktgen test is showing x10 (2 flows) and x55 (1M flows) improvement for OVSNFV (mdgray_, 14:25:52)
    14. This test runs "standard" (i.e. non-dpdk) pktgen in the guest and sends traffic VM-VM using standard linux networking interface. (mdgray_, 14:29:20)
    15. General consensus is that the result look good. Better performance for the networking tests. Other tests show drops which may be due to differences in Qemu version and configuration. (mdgray_, 14:35:45)

  3. Fuel Update (mdgray_, 14:36:08)
    1. We are a little behind with our CI (mdgray_, 14:36:25)
    2. Virtual deployment is work in progress (mdgray_, 14:37:19)
    3. Migration to Intel POD has started today. (mdgray_, 14:37:30)
    4. Fuel plugin feature has been delivered but not tested. (mdgray_, 14:38:15)
    5. No documentation so far. (mdgray_, 14:38:29)

  4. Apex update (mdgray_, 14:40:15)
    1. Request from SFC project for ovsnfv to provide Apex plugin with ovs with NSH (interim patch - not merged upstream) (mdgray_, 14:42:53)
    2. RPM will be built by CI and placed in artifacts (mdgray_, 14:43:13)
    3. Will not have DPDK support and labelled clearly (no dpdk and experimental) (mdgray_, 14:43:34)
    4. When do we merge master branch to experimental branch? (mdgray_, 14:44:37)
    5. Suggestion is August 22nd - not sure on this. (mdgray_, 14:45:03)
    6. After dates, bug fixes can be cherry-picked after that point. CI will then swap to the stable branch. (mdgray_, 14:46:09)
    7. Fuel plugin will also support NSH patches. (mdgray_, 14:47:03)
    8. Clarification, Apex will install OVS with DPDK aswell (but not with NSH) (mdgray_, 14:48:16)
    9. Should work with virtual and bare-metal deployments. (mdgray_, 14:48:34)
    10. Yardstick should run but no results yet. (mdgray_, 14:49:10)
    11. ACTION: Tom: If results are available for Yardstick, it would be god to compare with the Fuel results. (mdgray_, 14:49:42)
    12. Tom asks where are the results stored. (mdgray_, 14:49:59)
    13. Billy clarifies that he achieved his results manually. (mdgray_, 14:50:14)
    14. Comparable results will give us a good feeling that things are running correctly. (mdgray_, 14:51:34)


Meeting ended at 14:57:37 UTC (full logs).

Action items

  1. Billy will follow-up with Yardstick team to understand what tests will be enabled for Colorado.
  2. Tom: If results are available for Yardstick, it would be god to compare with the Fuel results.


People present (lines said)

  1. mdgray_ (48)
  2. collabot (4)
  3. billyo (1)
  4. lch (1)
  5. tfherbert1 (1)


Generated by MeetBot 0.1.4.