#opnfv-ovsnfv: Weekly Open vSwitch for NFV meeting (February 13th 2017)

Meeting started by mdgray_ at 14:01:36 UTC (full logs).

Meeting summary

  1. Roll Call (mdgray_, 14:01:44)
    1. Mark Gray (mdgray_, 14:01:47)
    2. Tom Herbert (tfherbert, 14:01:57)
    3. Billy O'Mahony (billyo_, 14:03:33)
    4. Chunghan Lee (lch, 14:03:48)

  2. Agenda (mdgray_, 14:04:09)
    1. Danube release update (mdgray_, 14:04:14)
    2. Priority Path (mdgray_, 14:04:22)

  3. Danube release update (mdgray_, 14:04:29)
    1. https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description (mdgray_, 14:05:11)
    2. Currently at MS5 since Friday (mdgray_, 14:06:26)
    3. MS7 is when stable Danube branch is formed (mdgray_, 14:06:47)
    4. Original release plan was documented in October at https://wiki.opnfv.org/display/SWREL/OVSNFV+Release+Plan+for+OPNFV+Danube (mdgray_, 14:07:27)
    5. Another relevant page is the scenario page at https://wiki.opnfv.org/display/SWREL/Danube+Scenario+Status (mdgray_, 14:08:19)
    6. This is the location of all the scenarios for Danube. (mdgray_, 14:08:50)
    7. Four scenarios for Fuel: nosdn-ovs-ha, nosdn-ovs-noha, s-nosdn-kvm_ovs_dpdk-ha, s-nosdn-kvm_ovs_dpdk-noha (mdgray_, 14:14:04)
    8. The two without kvm do not have owners (mdgray_, 14:14:44)
    9. the kvm are owned by kvm4nfv (mdgray_, 14:14:53)
    10. all of these have Jenkins jobs (mdgray_, 14:15:13)
    11. For Apex an artifact is required for the deploy jobs. This is run as part of an ovsnfv Jenkins job. (mdgray_, 14:18:57)
    12. There are six apex scenarios: os-nosdn-ovs-noha, os-odl-ovs-noha, os-odl-ovs-ha, os-odl-l3-ovs-noha, os-nosdn-kvm_ovs-dpdk-ha, os-nosdn-kvm_ovs_dpdk-noha (mdgray_, 14:22:01)
    13. 4 of these scenarios are dependent on the ovsnfv Jenkins job (mdgray_, 14:23:12)
    14. The apex kvm+ovs scenario does not have associated Jenkins jobs. The odl scenarios should be available. Tom will chase this up (mdgray_, 14:24:01)
    15. ACTION: Tom will find out the location of the ODL Jenkins jobs for Apex with OVS-DPDK (mdgray_, 14:24:17)
    16. Tom said that the verify job does not create an artifact, the daily job does but he is not certain about the merge job. We will find out tonight if there is an artifact created. (mdgray_, 14:29:00)
    17. MS6 is this week on Friday. (mdgray_, 14:29:28)
    18. Test case implementation and documentation. (mdgray_, 14:29:57)
    19. https://wiki.opnfv.org/display/DOC/Documentation+Guide (dmcbride, 14:32:14)
    20. ^^ documentation guide (dmcbride, 14:32:35)
    21. Tom will check Apex documentation and Mark/Billy will check for Fuel. (mdgray_, 14:32:57)

  4. Priority Data Path (mdgray_, 14:34:51)
    1. In Billy's last update, there was not a huge improvement when using a strict priority scheme on NIC priority queues (mdgray_, 14:36:23)
    2. However, logging issues caused test discrepancies. This has been resolved (mdgray_, 14:37:05)
    3. Current results show 50x latency improvement for hi priority traffic (mdgray_, 14:37:33)
    4. There is still a long tail probably cause by other sources of latency. (mdgray_, 14:37:51)
    5. Next step will be to split traffic by priority between 2 pmd threads (mdgray_, 14:40:44)

  5. Others (mdgray_, 14:51:58)
    1. 2.5 is needed for multiqueue vhost in Qemu (mdgray_, 14:52:12)
    2. Fuel uses 2.5 (mdgray_, 14:52:24)
    3. ACTION: Tom to check if multiqueue is supported in Apex (mdgray_, 14:53:48)


Meeting ended at 14:54:49 UTC (full logs).

Action items

  1. Tom will find out the location of the ODL Jenkins jobs for Apex with OVS-DPDK
  2. Tom to check if multiqueue is supported in Apex


People present (lines said)

  1. mdgray_ (41)
  2. collabot` (5)
  3. dmcbride (2)
  4. billyo_ (1)
  5. tfherbert (1)
  6. lch (1)


Generated by MeetBot 0.1.4.