#opnfv-pharos: OpenStack 3rd Party CI

Meeting started by fdegir at 14:06:42 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 14:06:58)
    1. Jack Morgan (jmorgan1, 14:07:02)
    2. Julien (Julien-zte, 14:07:08)
    3. qiliang (qiliang, 14:07:13)
    4. Fatih Degirmenci (fdegir, 14:07:14)

  2. Status Update (fdegir, 14:08:15)
    1. OpenSuSe patches have been submitted to openstack/bifrost. They are fine. (fdegir, 14:09:50)
    2. Couple of other patches are pending reviews. (fdegir, 14:10:05)
    3. Once the pending patches are submitted, we will be able to use SuSe hosts (fdegir, 14:10:52)
    4. Some fixes need to go to opensuse repos to fix rabbitmq-server stuff for OpenSuSe Leap (fdegir, 14:11:16)
    5. Work with puppet-infracloud for SuSe is pending (fdegir, 14:12:40)
    6. Both bifrost and puppet-infracloud work fine on Centos using VMs (fdegir, 14:13:57)
    7. Problems with bridges and glean on systemd have been fixed (fdegir, 14:14:12)
    8. test-bifrost-deployment script and the playbook have been fixed to make it more flexible and accept env vars, to define distros, elements (fdegir, 14:14:32)
    9. Work on baremetal will start soon (fdegir, 14:14:52)
    10. ACTION: fdegir to create centos jobs on opnfv jenkins (fdegir, 14:15:51)
    11. ACTION: fdegir and jmorgan1 to have chat regarding resource availability (fdegir, 14:17:57)
    12. jmorgan1 will add a new intel-pod10 for bifrost (Julien-zte, 14:21:20)
    13. We enabled 3rd party CI by hooking OPNFV Jenkins to OpenStack Gerrit (fdegir, 14:21:51)
    14. OPNFV Jenkins is now subscribed to OpenStack Gerrit event stream (fdegir, 14:22:21)
    15. https://wiki.openstack.org/wiki/ThirdPartySystems/OPNFV_CI (fdegir, 14:22:40)
    16. A job has been created to watch changes coming to openstack/bifrost to verify if proposed upstream changes cause issues for OPNFV (fdegir, 14:23:07)
    17. https://build.opnfv.org/ci/view/3rd%20Party%20CI/job/openstack-bifrost-verify-trusty-master/ (fdegir, 14:23:31)
    18. Thanks to aricg and bramwelt for fixing OPNFV side of things (fdegir, 14:23:44)
    19. This will help us gain some experience operating 3rd party ci even though it's not voting (fdegir, 14:24:15)
    20. Similar setup will be done for openstack/puppet-infracloud repo as well once that part is automated (fdegir, 14:24:57)
    21. In the end, we should be able to verify upstream patches locally (fdegir, 14:25:08)
    22. Jobs for centos and suse will be enabled as well and any remaining issues need to be fixed as trusty job failed last time (fdegir, 14:25:51)
    23. Julien-zte is working on setting up CI in ZTE lab. There have been issues due to use of non-root user. Patches will be send. (fdegir, 14:26:59)


Meeting ended at 14:38:34 UTC (full logs).

Action items

  1. fdegir to create centos jobs on opnfv jenkins
  2. fdegir and jmorgan1 to have chat regarding resource availability


Action items, by person

  1. fdegir
    1. fdegir to create centos jobs on opnfv jenkins
    2. fdegir and jmorgan1 to have chat regarding resource availability
  2. jmorgan1
    1. fdegir and jmorgan1 to have chat regarding resource availability


People present (lines said)

  1. fdegir (88)
  2. Julien-zte (23)
  3. jmorgan1 (19)
  4. qiliang (16)
  5. yolanda (13)
  6. hwoarang (10)
  7. collabot (5)


Generated by MeetBot 0.1.4.