#opnfv-pharos: OPNFV Hackfest Infra Day1

Meeting started by fdegir at 09:36:07 UTC (full logs).

Meeting summary

  1. Infra Roadmap (fdegir, 09:36:20)
    1. We need to create JIRA tickets for creating PDFs for PODs located in Intel, Ericsson, Huawei, LF (fdegir, 09:36:50)
    2. ACTION: fdegir to create Jira tickets for LF and Ericsson labs (fdegir, 09:37:06)
    3. ACTION: jmorgan1 to create Jira tickets for Intel and Huawei labs (fdegir, 09:37:25)
    4. ACTION: fdegir to create Jira tickets for POD converter, 1 per installer (fdegir, 09:38:19)
    5. ACTION: jmorgan1 to commit the patch for network settings to gerrit/pharos for review (fdegir, 10:04:31)

  2. Moving installers to VMs on Jumphost (fdegir, 11:23:27)
    1. We will need jumphost cleanup and setup scripts in order to remove/create bridges, vms (fdegir, 11:23:51)
    2. There can be multiple network setting files that would work with a POD. (uli-k, 11:49:33)
    3. the PDF contains a list of NSF (network setting files) that can be used with the POD. (uli-k, 11:50:19)
    4. PDF and NSF are stored in secured lab repo (uli-k, 11:51:01)
    5. multiple PODs can use the same network setting file(s). (uli-k, 12:09:42)
    6. Releng will parse SDF, PDF, NSF to find the right resource for a scenario. (uli-k, 12:15:19)
    7. the translator tool might be not necessary (if the installers directly move to parsing PDF) (uli-k, 12:17:08)
    8. we will define new requirement for OPNFV Community Labs: Provide PDF, Can be booked via Pharos dashboard, Document on wiki. (uli-k, 12:27:48)
    9. Labs that don't provide that will be deleted from the list. (uli-k, 12:28:04)
    10. The directory structure will be (fdegir, 12:33:21)
    11. securedlab/<lab_name>/<podX>.yaml, for example (fdegir, 12:33:48)
    12. securedlab/zte/pod1.yaml, securedlab/lf/pod3.yaml (fdegir, 12:34:07)
    13. securedlab/zte/nsf.yaml, securedlab/zte/nsfdpdk.yaml (uli-k, 12:38:50)
    14. In order to make it possible to run installers on any OS, it is important to pick the right machine type in libvirt VM xml file and link the qemu executable in right place (fdegir, 12:39:57)
    15. Align how the OSes are statated in SDF and PDF (fdegir, 12:40:09)
    16. Decide how to state the OSes (trusy/xenial or 14.04/16.04) (fdegir, 12:40:33)
    17. releng will write analyser scripts (uli-k, 12:41:18)
    18. Apex creates VMs using virsh which use prebuilt images from Triple-O and then starts the installer VM (fdegir, 12:44:48)
    19. Joid can pull down ubuntu cloud images and applies metadata (fdegir, 12:45:03)
    20. Fuel installs centos from scratch (fdegir, 12:45:13)
    21. Compass and Daisy need to be checked (fdegir, 12:45:22)
    22. XCI uses diskimage builder to build VM images (fdegir, 12:45:31)
    23. https://hastebin.com/qiposovusi.hs (fdegir, 13:24:07)
    24. SDF should be available at MS2 and finalized at MS5 (starting with F release) (uli-k, 13:53:58)
    25. Octopus will plan creation of SDF converter (uli-k, 13:57:24)
    26. testcase selection is impacted. All test information is in test db, not in SDF. But test team is affected since the scenario naming scheme changes. (uli-k, 13:59:59)
    27. #info need a jira task for adjustments for jenkins jobs tosupport dynamic allocation (uli-k, 14:05:51)
    28. Test projects use below script to fetch openstack credentials (fdegir, 14:11:23)
    29. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=utils/fetch_os_creds.sh (fdegir, 14:11:25)


Meeting ended at 07:28:03 UTC (full logs).

Action items

  1. fdegir to create Jira tickets for LF and Ericsson labs
  2. jmorgan1 to create Jira tickets for Intel and Huawei labs
  3. fdegir to create Jira tickets for POD converter, 1 per installer
  4. jmorgan1 to commit the patch for network settings to gerrit/pharos for review


Action items, by person

  1. fdegir
    1. fdegir to create Jira tickets for LF and Ericsson labs
    2. fdegir to create Jira tickets for POD converter, 1 per installer
  2. UNASSIGNED
    1. jmorgan1 to create Jira tickets for Intel and Huawei labs
    2. jmorgan1 to commit the patch for network settings to gerrit/pharos for review


People present (lines said)

  1. fdegir (27)
  2. uli-k (14)
  3. collabot (4)


Generated by MeetBot 0.1.4.