#opnfv-pharos: OPNFV Hackfest Infra Day2

Meeting started by fdegir at 07:28:18 UTC (full logs).

Meeting summary

  1. POD and Scenario Descriptor Files, Scenario Lifecycle (fdegir, 07:32:40)
    1. https://gerrit.opnfv.org/gerrit/#/c/30677/5/scenarios/templates/sdf-template.yaml (fdegir, 07:36:58)
    2. ACTION: uli-k to update step 1 in workflow to ensure the pool is not an installer pool but CI POD pool (fdegir, 08:54:29)
    3. ACTION: uli-k to update Add CI POD slide to reflect the process clearly (fdegir, 09:04:36)

  2. Security Gate Scanning (fdegir, 11:06:50)
    1. As part of C-release, 12 security related issues were identified and fixed (fdegir, 11:24:33)
    2. The idea is to automate security scanning and run it against new patches proposed to OPNFV repos (fdegir, 11:25:16)
    3. cosmetic checks, shell executions, etc will be done (fdegir, 11:26:56)
    4. For python, bandit will be used (fdegir, 11:27:25)
    5. binary file check will be done (fdegir, 11:27:36)
    6. During E-release development work, 2 jobs will be created doing (fdegir, 11:32:45)
    7. scanning for each and every new patch proposed to opnfv projects but this will not vote/block changes from getting submitted (fdegir, 11:33:13)
    8. scanning nightly for all the projects to report the backlog (fdegir, 11:33:26)
    9. The gating/voting will be enabled by F-release development phase (fdegir, 11:33:43)

  3. SDF and Scenario Lifecycle (fdegir, 12:32:28)


Meeting ended at 08:18:55 UTC (full logs).

Action items

  1. uli-k to update step 1 in workflow to ensure the pool is not an installer pool but CI POD pool
  2. uli-k to update Add CI POD slide to reflect the process clearly


Action items, by person

  1. uli-k
    1. uli-k to update step 1 in workflow to ensure the pool is not an installer pool but CI POD pool
    2. uli-k to update Add CI POD slide to reflect the process clearly


People present (lines said)

  1. fdegir (21)
  2. collabot (4)
  3. yolanda (1)
  4. hwoarang (1)
  5. uli-k (0)
  6. jmorgan1 (0)


Generated by MeetBot 0.1.4.