#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:00:27 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 13:00:33)
    1. David Blaisonneau (David_Orange, 13:01:10)
    2. Yolanda (yolanda, 13:01:17)
    3. Tianwei (hw_wutianwei, 13:01:18)
    4. Manuel Buil (mbuil, 13:01:24)
    5. Georg Kunz (georgk, 13:01:29)
    6. epalper Peri (epalper, 13:01:54)
    7. Thaj (thaj, 13:02:08)

  2. General XCI Framework status (fdegir, 13:02:20)
    1. Dimitris Markou (mardim, 13:03:08)
    2. The patch to generate and use self signed certificates for OSA is open (fdegir, 13:03:39)
    3. https://gerrit.opnfv.org/gerrit/#/c/39435/ (fdegir, 13:03:45)
    4. OS_INSECURE=true should be set in openrc while using self signed certificates (fdegir, 13:05:05)
    5. Next step could be to use certs from an external provider we trust, or build our own CA and trust it but what we have is good enough now (fdegir, 13:05:26)
    6. Uli (uli-k, 13:05:48)
    7. ACTION: mbuil to report findings on the patch and update README.rst with necessary information (fdegir, 13:08:11)
    8. The PDF for lf-pod4 has been merged (fdegir, 13:08:35)
    9. https://gerrit.opnfv.org/gerrit/#/c/38283/ (fdegir, 13:09:02)
    10. Baremetal install is still under debug: i have an issue linking openstack router to extnet (David_Orange, 13:09:06)
    11. VM to VM is OK, VM to router is OK, but router to ext gateway is failing (David_Orange, 13:09:32)
    12. i am checking topology and hosts config, but i can not found where it is failing (David_Orange, 13:10:02)
    13. as i am on an interface with multi vlan and multi bridge, i am deploying with a new network topology with a single vlan for br-vlan (David_Orange, 13:10:48)
    14. yes, i can share it, maybe after the meeting (David_Orange, 13:11:54)
    15. thanks hw_wutianwei (David_Orange, 13:12:25)
    16. working in parallel on pdf, and moving actual j2 files to this new config source (David_Orange, 13:12:47)
    17. After bumping to pike dated august 15th, keepalived playbook started failing (fdegir, 13:15:51)
    18. https://hastebin.com/oyigeqoqax.md (fdegir, 13:15:56)
    19. i will check with mbuil and hw_wutianwei, thanks to them, feel free to send me your ssh keys if you want access (David_Orange, 13:16:02)
    20. hw_wutianwei reported the issue to osa and they fixed it (fdegir, 13:16:14)
    21. keepalived issue is caused by the python version (fdegir, 13:16:50)
    22. because of this, ha flavor is disabled at the moment (fdegir, 13:17:00)
    23. We finalized migration to releng-xci repo and settling the structure there (fdegir, 13:18:55)

  3. Scenario/Feature status (fdegir, 13:19:10)
    1. os-nosdn-nofeature works (fdegir, 13:19:24)
    2. Patches for odl are under review (fdegir, 13:20:04)
    3. https://gerrit.opnfv.org/gerrit/#/c/39239/ (fdegir, 13:20:11)
    4. https://gerrit.opnfv.org/gerrit/#/c/496583/ (fdegir, 13:20:18)
    5. Testing is in progress (fdegir, 13:20:27)
    6. yes (epalper, 13:20:58)
    7. The work with odl is done against master (fdegir, 13:21:08)
    8. SFC patches are waiting for reviews (fdegir, 13:22:50)
    9. https://gerrit.opnfv.org/gerrit/#/c/39517/ (fdegir, 13:22:56)
    10. https://gerrit.opnfv.org/gerrit/#/c/39511/ (fdegir, 13:23:02)
    11. The patches complete the os-odl-sfc scenario (fdegir, 13:23:19)
    12. The patch to functest is also open (fdegir, 13:23:43)
    13. https://gerrit.opnfv.org/gerrit/#/c/40595/ (fdegir, 13:23:49)
    14. https://github.com/manuelbuil/releng-xci/tree/integration-test-certificates (mbuil, 13:24:33)
    15. we also need to get this review to be merged for ODL clustering to work: https://git.opendaylight.org/gerrit/#/c/61945/ (epalper, 13:25:14)
    16. For odl role to work with nitrogen, the patch needs to go in https://git.opendaylight.org/gerrit/#/c/62323/ (fdegir, 13:26:27)
    17. mbuild integrated the private role for ovs nsh to neutron (fdegir, 13:30:22)
    18. https://jira.opnfv.org/browse/RELENG-228 (mardim, 13:33:07)
    19. https://jira.opnfv.org/browse/SFC-96 (mardim, 13:33:18)

  4. Testing (fdegir, 13:33:57)
    1. Trials with functest alpine based containers started (fdegir, 13:34:11)
    2. It will be integrated to osa-periodic jobs as first step (fdegir, 13:34:23)
    3. snaps enabled patches verification for their patches against a pre-deployed pike based system (fdegir, 13:35:21)
    4. We have a real user and we have to take good care of them (fdegir, 13:35:41)
    5. See the job https://build.opnfv.org/ci/view/snaps/job/snaps-verify-master/ (fdegir, 13:36:00)
    6. The information about this is available on https://wiki.opnfv.org/display/INF/Improving+CI+for+Test+Projects#ImprovingCIforTestProjects-SNAPSPoC (fdegir, 13:36:22)
    7. the task about stress test support is on David_Orange and it depends on/related to what he is already doing with baremetal (fdegir, 13:37:34)

  5. Distro Support (fdegir, 13:38:05)
    1. The last I heard from hwoarang was that he was thinking of finishing SUSE support by last friday (fdegir, 13:38:29)
    2. He started publishing patches for XCI multi-distro support so things are progressing there as well (fdegir, 13:38:52)
    3. https://review.openstack.org/#/c/497814/ (fdegir, 13:40:05)
    4. We are still hitting issues with centos jobs for bifrost and this is related to selinux (fdegir, 13:40:45)
    5. There seems to be a problem with serving images via nginx, because they don't have the right selinux type (fdegir, 13:41:06)
    6. We switched to centos-minimal for bifrost-verify jobs (fdegir, 13:47:32)
    7. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/xci/bifrost-verify-jobs.yml;h=ef604fcfc7c0e550ac199e5d6d3385effbdd7e31;hb=HEAD#l29 (fdegir, 13:47:35)
    8. ttallgren is having trouble with rebooting the opnfv VM (fdegir, 13:47:45)

  6. Extending CI (fdegir, 13:48:09)
    1. We started setting up periodic jobs (fdegir, 13:50:04)
    2. We will have jobs for bifrost and osa to test master to find a working version to pin (fdegir, 13:50:23)
    3. Skeleton for osa-periodic job is merged and execute shell part is in progress (fdegir, 13:50:45)

  7. AoB (fdegir, 13:51:07)
    1. We presented the progress and short term plans to TSC yesterday (fdegir, 13:51:26)
    2. Presentation is available on https://wiki.opnfv.org/download/attachments/8687635/XCI_TSC_Report_August2017.pdf?api=v2 (fdegir, 13:51:45)
    3. Next step is to clarify the impacts on release model and have a proposal regarding how it can be adjusted (fdegir, 13:54:23)
    4. We also need to document guides regarding how projects can be onboarded to XCI and get feedback from it (fdegir, 13:55:01)
    5. Documentation for XCI also started and will be on docs.opnfv.org under infrastructure (fdegir, 13:55:26)
    6. Linux Foundation published XCI Solution Brief as well: https://www.opnfv.org/wp-content/uploads/sites/12/2017/08/OPNFV_SolutionBrief_XCI_080617.pdf (fdegir, 13:55:54)


Meeting ended at 13:58:04 UTC (full logs).

Action items

  1. mbuil to report findings on the patch and update README.rst with necessary information


Action items, by person

  1. mbuil
    1. mbuil to report findings on the patch and update README.rst with necessary information


People present (lines said)

  1. fdegir (142)
  2. yolanda (23)
  3. mardim (21)
  4. mbuil (19)
  5. David_Orange (17)
  6. hw_wutianwei (12)
  7. ttallgren (7)
  8. epalper (6)
  9. collabot (3)
  10. dfarrell07 (2)
  11. uli-k (1)
  12. georgk (1)
  13. thaj (1)


Generated by MeetBot 0.1.4.