#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:00:16 UTC (full logs).

Meeting summary

    1. Al Morton (acm, 13:00:34)
    2. qiliang (liangqi, 13:00:56)
    3. David Blaisonneau (David_Orange, 13:00:58)
    4. Tapio Tallgren (ttallgren, 13:01:01)
    5. Tianwei Wu (hw_wutianwei, 13:01:04)
    6. Jack Morgan (jmorgan1, 13:01:04)
    7. https://etherpad.opnfv.org/p/xci-meetings (fdegir, 13:01:11)

  1. Issues with diskimage-builder (fdegir, 13:02:18)
    1. Markos Chandras (hwoarang, 13:03:31)
    2. Stephen Wong (s3wong, 13:04:12)
    3. root=LABEL=foobar doesn't work anymore on ubuntu for unknown reason (fdegir, 13:04:12)
    4. the reason might be that the dib doesn't inject an initrd on the ubuntu image (fdegir, 13:04:29)
    5. https://bugs.launchpad.net/diskimage-builder/+bug/1718415 (hwoarang, 13:05:57)
    6. ACTION: hwoarang to fix dib issues on ubuntu (fdegir, 13:07:08)

  2. Multi-distro support (fdegir, 13:07:22)
    1. SUSE support has been merged but the work is put on hold while troubleshooting dib issues on ubuntu (fdegir, 13:08:35)
    2. If something goes wrong with SUSE, it is probably due to OSA which needs to be fixed as well (fdegir, 13:09:02)
    3. Few more patches are pending to be sent but we need CI before doing that (fdegir, 13:09:24)
    4. The virtual deployment with noha flavor runs on Centos (fdegir, 13:10:39)

  3. Testing (fdegir, 13:13:16)
    1. The work to enable functest for xci-verify and osa-periodic is progressing slowly (fdegir, 13:13:36)
    2. https://gerrit.opnfv.org/gerrit/#/c/42069/ (fdegir, 13:14:04)
    3. Once the healthcheck is enabled and confirmed working, we can enable testing for sfc scenario once the scenario gets merged (fdegir, 13:14:39)

  4. Release Readiness (fdegir, 13:15:02)
    1. the CI parts is progressing and the documentation will soon be moved to docs.opnfv.org (fdegir, 13:16:00)

  5. Scenario/Feature Status: os-odl-nofeature (fdegir, 13:17:29)
    1. https://gerrit.opnfv.org/gerrit/#/c/40329/ (fdegir, 13:18:48)
    2. https://gerrit.opnfv.org/gerrit/#/c/40533/ (fdegir, 13:18:53)
    3. epalper's patch for os-odl-nofeature is under review (fdegir, 13:20:01)
    4. https://gerrit.opnfv.org/gerrit/#/c/39239/ (fdegir, 13:20:03)
    5. But we need to decide how to move forward with handling scenarios first before merging that patch (fdegir, 13:20:20)
    6. Which will happen soon (fdegir, 13:20:27)

  6. Scenario/Feature Status: os-odl-sfc (fdegir, 13:21:01)
    1. The agreed way forward with scenarios need to be applied to sfc (fdegir, 13:22:16)
    2. The sfc scenario needs to be moved to sfc repo (fdegir, 13:22:27)
    3. https://gerrit.opnfv.org/gerrit/#/c/39517/ (fdegir, 13:22:44)
    4. https://gerrit.opnfv.org/gerrit/#/c/39511/ (fdegir, 13:23:18)
    5. https://gerrit.opnfv.org/gerrit/#/c/39511/ (mbuil, 13:23:18)
    6. https://wiki.opnfv.org/pages/viewpage.action?pageId=12390152 (fdegir, 13:24:33)

  7. Kubernetes in XCI (fdegir, 13:25:24)
    1. s3wong is looking into kubespray for the existing playbooks (fdegir, 13:27:52)
    2. For networking, either Calico and Canal for CNI plugin will be looked into (fdegir, 13:29:50)
    3. First try will be on ubuntu with the flavor aio (fdegir, 13:30:42)
    4. https://etherpad.opnfv.org/p/xci-k8s (fdegir, 13:32:59)
    5. With k8s, we have similar approach as openstack (fdegir, 13:33:43)
    6. multi-distro support; ubuntu, suse, centos (fdegir, 13:33:52)
    7. consume k8s from master - probably using the weekly releases done by k8s community (fdegir, 13:34:08)
    8. bring up a prototype which is what s3wong has been working on (fdegir, 13:34:26)
    9. reach out to k8s community and present what we are trying to achieve based on real stuff (fdegir, 13:34:48)

  8. Congress in XCI (fdegir, 13:35:34)
    1. https://review.openstack.org/#/c/499066/ (Taseer, 13:36:17)
    2. Blueprint for congress has been accepted & merged by the OSA community (fdegir, 13:36:53)
    3. https://github.com/Taseer94/os_congress/ (Taseer, 13:36:59)
    4. Taseer is creating the role for congress from scratch since it doesn't exist in the upstream (fdegir, 13:37:46)
    5. https://review.openstack.org/#/c/503971/ (Taseer, 13:38:07)
    6. Integrating the role to osa is in progress as well (fdegir, 13:38:31)

  9. Extending CI (fdegir, 13:39:17)
    1. osa-periodic jobs will be enabled soon and they will have the usual mini deployment together with functest healthcheck to chase the osa master (fdegir, 13:40:28)
    2. Apart from having the basic jobs, we will enable CI for all the distros we support; ubuntu, centos, and suse (fdegir, 13:40:48)
    3. Once the basic jobs are in place, jobs for the scenarios will be created following what is explained in CI Evolution (fdegir, 13:41:49)
    4. No more (re)running things if things don't change and instead take them to more extensive testing (fdegir, 13:42:11)

  10. XCI on Baremetal (fdegir, 13:42:45)
    1. i just pushed my baremetal proto (David_Orange, 13:43:12)
    2. https://gerrit.opnfv.org/gerrit/#/c/42267/ (David_Orange, 13:43:53)
    3. as previous version, the idea is only to have the upstream bifrost+osa installation (David_Orange, 13:44:29)
    4. this version is based on PDF and its actual evolutions (David_Orange, 13:44:45)

  11. AoB (fdegir, 13:48:11)
    1. XCI has been presented to ETSI last week and I think it was good (fdegir, 13:48:30)
    2. We also had conversations with OpenStack QA thanks to yolanda and talked about what we aim to achieve with XCI (fdegir, 13:49:19)
    3. I think we have lots of (new) opportunities to collaborate further with OpenStack community around XCI (fdegir, 13:49:48)
    4. hw_wutianwei is working on integrating ceph (fdegir, 13:50:55)
    5. https://gerrit.opnfv.org/gerrit/#/c/42503/ (fdegir, 13:51:26)
    6. A fix has been issued for the bug in xci configuration (fdegir, 13:52:32)
    7. https://gerrit.opnfv.org/gerrit/#/c/41517/ (fdegir, 13:52:37)
    8. XCI meetings will be held on a weekly basis from now on (fdegir, 13:57:56)


Meeting ended at 13:58:45 UTC (full logs).

Action items

  1. hwoarang to fix dib issues on ubuntu


Action items, by person

  1. hwoarang
    1. hwoarang to fix dib issues on ubuntu


People present (lines said)

  1. fdegir (169)
  2. jmorgan1 (20)
  3. hwoarang (19)
  4. David_Orange (19)
  5. durschatz (18)
  6. s3wong (15)
  7. Taseer (10)
  8. mbuil (7)
  9. hw_wutianwei (6)
  10. ttallgren (5)
  11. collabot (3)
  12. Guest88084 (1)
  13. epalper (1)
  14. acm (1)
  15. yolanda (1)
  16. liangqi (1)


Generated by MeetBot 0.1.4.