#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:00:04 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 13:00:26)
    1. Jack Morgan (jmorgan1, 13:00:33)
    2. Stephen Wong (s3wong, 13:00:39)
    3. Tianwei Wu (hw_wutianwei1, 13:00:53)
    4. qiliang (liangqi, 13:01:46)

  2. Multi-distro Support (fdegir, 13:02:02)
    1. Ubuntu has been working fine already (fdegir, 13:02:25)
    2. Markos Chandras (hwoarang, 13:02:42)
    3. Support for OpenSUSE has been introduced recently (fdegir, 13:02:46)
    4. David Blaisonneau (David_Orange, 13:03:15)
    5. Tapio is looking into Centos (fdegir, 13:03:59)
    6. mbuil (mbuil, 13:04:51)
    7. It would be good to get what Tapio did for Centos to Gerrit so we get CI feedback (fdegir, 13:04:57)
    8. Apart from general distro support, we also introduced xci-verify jobs for all 3 distros (like 5 minutes ago..) (fdegir, 13:05:21)
    9. https://build.opnfv.org/ci/view/OPNFV%20XCI/ (fdegir, 13:05:29)
    10. See section xci verify master (fdegir, 13:05:48)
    11. On top of enabling jobs, we now run verification in clean VMs to ensure leftovers of previous runs don't cause issues (fdegir, 13:06:39)
    12. Whenever a new patch comes in, a new VM gets created for each 3 distros (fdegir, 13:06:58)
    13. verify jobs use mini flavor (fdegir, 13:08:12)
    14. We run 2 verify jobs on single slave so VM stuff helped us with resource shortage as well (fdegir, 13:08:33)
    15. One final note about verify jobs is that, only xci-verify-ubuntu votes. Voting for other distro jobs will be enabled once we are sure we fixed the framework/jobs themselves (fdegir, 13:09:25)
    16. We need similar jobs for osa-periodic and the new way of running stuff will make things much easier for osa-periodic jobs as well (fdegir, 13:11:01)
    17. These jobs will be created soon once the basics with verify jobs/VM stuff is settled (fdegir, 13:11:19)

  3. Testing (fdegir, 13:11:38)
    1. The change that prepares the deployment for functest has been merged (fdegir, 13:11:50)
    2. https://gerrit.opnfv.org/gerrit/#/c/42069/ (fdegir, 13:12:04)
    3. Next step is to integrate healthcheck into xci-verify/osa-periodic - it will start its life as none-voting for verify jobs (fdegir, 13:12:28)

  4. Documentation (fdegir, 13:13:45)
    1. We are getting closer to release date and we must have documentation ready no matter what we get working (fdegir, 13:14:07)
    2. Reviews will be coming to your way and please read them as they will be used by our users and they must be clear (fdegir, 13:14:36)
    3. I appreciate if anyone wants to help out (fdegir, 13:15:02)

  5. Release Readiness (fdegir, 13:15:23)
  6. Scenario/Feature Status: os-nosdn-nofeature (fdegir, 13:22:16)
    1. This is the scenario we are running everywhere and no need to talk about it in detail (fdegir, 13:22:33)
    2. It simply works - if upstream doesn't mess something up... (fdegir, 13:22:53)

  7. Scenario/Feature Status: os-odl-nofeature (fdegir, 13:23:07)
    1. No update for os-odl-nofeature (fdegir, 13:24:00)

  8. Scenario/Feature Status: os-odl-sfc (fdegir, 13:24:02)
    1. mbuil started moving sfc scenario to sfc repo (fdegir, 13:24:28)
    2. https://gerrit.opnfv.org/gerrit/#/c/43165/ (fdegir, 13:24:38)
    3. mbuil identified an issue with functest-prepare role with env.j2 (having quotes in ip) - he will send a patch for it (fdegir, 13:25:55)
    4. Manuel testing of SFC in xci works - it needs to be automated asap (fdegir, 13:26:52)
    5. Testing is done using alpine based containers for functest (fdegir, 13:27:42)
    6. There are few things that need to be automated as well (fdegir, 13:27:52)

  9. Scenario/Feature Status: k8s-nosdn-nofeature (fdegir, 13:31:33)
    1. s3wong tried to make the kubespray + kubeadm support working in my setup as reference (fdegir, 13:32:44)
    2. The kubeadm support was merged about two weeks ago: https://github.com/kubernetes-incubator/kubespray/commit/6744726089245c724b6927d419064a84551931e2 (fdegir, 13:32:54)

  10. Scenario/Feature Status: Congress (fdegir, 13:36:07)
    1. No update for congress (fdegir, 13:37:07)

  11. Scenario/Feature Status: Ceph (fdegir, 13:37:18)
    1. hw_wutianwei's patch works manually but failed on CI (fdegir, 13:38:30)
    2. https://gerrit.opnfv.org/gerrit/#/c/42503/ (fdegir, 13:38:37)
    3. ACTION: Taseer to put the links to blueprint and any other patches to https://jira.opnfv.org/browse/RELENG-247 for better visibility (fdegir, 13:40:39)

  12. Baremetal Status (fdegir, 13:41:17)
    1. All yaml files, playbooks and config are updated after a yamllint check (fdegir, 13:43:28)
    2. It is now being tested in ONAP Orange OpenLab (fdegir, 13:43:37)

  13. AoB (fdegir, 13:45:39)
    1. epalper is working introducing ovs into osa (fdegir, 13:47:45)
    2. ovs 2.6 will be integrated at first phase (fdegir, 13:53:19)
    3. a second POD will be provided ready this week in the Intel Pharos lab (jmorgan1, 13:54:41)
    4. Intel Pharos lab has a firewall issue blocking jenkins so wil be unusable until fixed (jmorgan1, 13:55:21)
    5. The plan for the pod20 is that it will continue to serve as development pod (fdegir, 13:55:52)
    6. The machines in new pod will become jenkins slaves, running all kinds of virtual deployments (bifrost-verify, bifrost-periodic, osa-verify, osa-periodic, xci-verify) (fdegir, 13:56:41)
    7. Intel PODs 19-24 will be refreshed in coming months - we need to prepare when the time appraoches (fdegir, 13:57:13)
    8. Intel team is interested in bringing kolla support to XCI (fdegir, 13:59:00)
    9. They are currently evaluating how to do it and understanding XCI more (fdegir, 13:59:19)
    10. ACTION: fdegir to coordinate with jmorgan1 to have a GTM meeting b/w XCI and Intel Kolla team (fdegir, 14:00:58)


Meeting ended at 14:01:08 UTC (full logs).

Action items

  1. Taseer to put the links to blueprint and any other patches to https://jira.opnfv.org/browse/RELENG-247 for better visibility
  2. fdegir to coordinate with jmorgan1 to have a GTM meeting b/w XCI and Intel Kolla team


Action items, by person

  1. fdegir
    1. fdegir to coordinate with jmorgan1 to have a GTM meeting b/w XCI and Intel Kolla team
  2. jmorgan1
    1. fdegir to coordinate with jmorgan1 to have a GTM meeting b/w XCI and Intel Kolla team
  3. Taseer
    1. Taseer to put the links to blueprint and any other patches to https://jira.opnfv.org/browse/RELENG-247 for better visibility


People present (lines said)

  1. fdegir (158)
  2. jmorgan1 (20)
  3. mbuil (18)
  4. hwoarang (13)
  5. ttallgren (11)
  6. David_Orange (11)
  7. epalper (10)
  8. s3wong (7)
  9. hw_wutianwei (6)
  10. mardim (3)
  11. collabot` (3)
  12. hw_wutianwei1 (2)
  13. Taseer (1)
  14. OPNFV-Gerrit-Bot (1)
  15. liangqi (1)


Generated by MeetBot 0.1.4.