#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:30:52 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 13:30:56)
    1. Tianwei Wu (hw_wutianwei, 13:31:36)
    2. Stephen Wong (s3wong, 13:31:46)
    3. https://etherpad.opnfv.org/p/xci-meetings (fdegir, 13:32:49)

  2. Scenario/Feature Status: k8-nosdn-nofeature (fdegir, 13:33:19)
    1. qiliang (liangqi, 13:33:45)
    2. s3wong sent the first patch for k8s integration (fdegir, 13:34:17)
    3. https://gerrit.opnfv.org/gerrit/#/c/46153/ (fdegir, 13:34:20)
    4. Victor Morales (electrocucaracha, 13:34:28)

  3. ceph in xci (fdegir, 13:40:34)
    1. xci ceph integration has been completed and the change is waiting for more review (fdegir, 13:41:04)
    2. https://gerrit.opnfv.org/gerrit/#/c/42503/ (fdegir, 13:41:25)
    3. the change will be submitted by the end of week so it is your chance to look at it and provide comments (fdegir, 13:41:50)

  4. ovs in xci (fdegir, 13:43:45)
    1. epalper has a patch for review for ovs integration (fdegir, 13:43:55)
    2. https://gerrit.opnfv.org/gerrit/#/c/43447/ (fdegir, 13:44:25)
    3. This type of features require us to adjust the xci itself which is what hwoarang also mentioned (fdegir, 13:45:02)

  5. congress in xci (fdegir, 13:48:29)
    1. Dimitrios Markou (mardim, 13:49:27)
    2. The congress integration is close to completion (fdegir, 13:50:17)
    3. https://review.openstack.org/#/c/503971/ (fdegir, 13:50:19)

  6. os-odl-sfc (fdegir, 13:52:39)
    1. sfc scenario is committed in sfc repo but it needs 2 things before we get it finalized (fdegir, 13:53:58)
    2. first thing is similar to ovs itself, we need the groundwork finalized - the overall structure of things and scenario support (fdegir, 13:54:23)
    3. the external/child scenario support has been merged recently (fdegir, 13:54:36)
    4. https://gerrit.opnfv.org/gerrit/#/q/topic:add-role-hooks+(status:open+OR+status:merged) (fdegir, 13:55:15)
    5. And the second issue was about mbuil needing to have a later version of osa for a certain bugfix (if I am not mistaken) (fdegir, 13:55:40)

  7. ovs-nsh (fdegir, 13:56:00)
    1. https://review.openstack.org/#/c/476121/ (mardim, 13:56:32)
    2. Blueprint for ovs-nsh has been merged (fdegir, 13:56:54)
    3. https://review.openstack.org/#/c/476121/ (fdegir, 13:57:05)
    4. ovs-nsh changes will be done in upstream (fdegir, 13:57:42)
    5. Packages for suse and redhat will be made available (fdegir, 13:57:56)

  8. Baremetal status (fdegir, 14:00:57)
    1. David Blaisonneau already got it working on Orange POD and it will be done on Nokia POD for long duration testing (fdegir, 14:01:44)
    2. But his approach is a bit different from how we are thinking of doing things (to be more precise, how I was envisioning) (fdegir, 14:02:13)
    3. This is also related to how to structure things (fdegir, 14:02:52)
    4. https://etherpad.opnfv.org/p/xci-structure (fdegir, 14:02:54)
    5. The discussion is going on and we will continue once David is back from his vacation (fdegir, 14:03:15)
    6. Dave Urschatz (durschatz, 14:03:22)
    7. Tapio Tallgren (ttallgren, 14:03:42)

  9. Centos support (fdegir, 14:04:38)
    1. The installation fails during one of the osa modules (fdegir, 14:06:27)
    2. The failing role is repobuild-prepare (or something like that) (fdegir, 14:08:34)
    3. ACTION: fdegir to check status of centos support upstream with hwoarang (fdegir, 14:11:46)
    4. Bifrost on Centos looks good (fdegir, 14:12:42)

  10. Improving stability (fdegir, 14:13:16)
    1. We have got some reports from users about the issues they are experiencing (fdegir, 14:13:32)
    2. The issues are mainly related to not using a clean installation (fdegir, 14:13:59)
    3. We need to ensure that we isolate ourselves as much as possible from the machine so we don't require users to reinstall their machines (fdegir, 14:14:24)
    4. This will be achieved by pushing everything into opnfv vm; bifrost installation, node provisioning/deployment, scenario installation and so on so the only requirement we will have on the host machine will be default ansible and libvirt stuff (fdegir, 14:15:14)
    5. This is also related to Dynamic CI and LaaS so what will be done has more uses (fdegir, 14:15:50)
    6. PDF for vPOD is under review (fdegir, 14:18:02)
    7. https://gerrit.opnfv.org/gerrit/#/c/46493/ (fdegir, 14:18:15)
    8. Once that change gets merged, PDFs for other flavors will be created (fdegir, 14:18:40)

  11. Bumping OSA SHA (fdegir, 14:19:12)
    1. hwoarang is working on moving us to a newer SHA which will have pre-queens (fdegir, 14:20:19)
    2. https://gerrit.opnfv.org/gerrit/#/c/46431/ (fdegir, 14:20:47)

  12. AoB (fdegir, 14:21:02)
    1. https://gist.github.com/electrocucaracha/3b83004b0233b99c480546d895939839 (electrocucaracha, 14:26:34)
    2. Next week's the meeting will be at 15:00CET and the invitation will be switched to UTC once all this time changes are over (fdegir, 14:33:51)


Meeting ended at 14:34:05 UTC (full logs).

Action items

  1. fdegir to check status of centos support upstream with hwoarang


Action items, by person

  1. fdegir
    1. fdegir to check status of centos support upstream with hwoarang


People present (lines said)

  1. fdegir (163)
  2. mardim (27)
  3. electrocucaracha (14)
  4. durschatz (14)
  5. s3wong (11)
  6. ttallgren (11)
  7. hw_wutianwei (11)
  8. Taseer (6)
  9. collabot (4)
  10. liangqi (1)


Generated by MeetBot 0.1.4.