#opnfv-pharos: Cross Community CI
Meeting started by fdegir at 14:00:54 UTC
(full logs).
Meeting summary
- Rollcall (fdegir, 14:01:01)
  - Tapio Tallgren (ttallgren,
    14:01:08)
- Tianwei Wu (hw_wutianwei,
    14:01:19)
- Dimitrios Markou (mardim,
    14:01:21)
- Victor Morales (electrocucaracha,
    14:01:23)
- Jack Morgan (jmorgan1,
    14:01:24)
- Fabien Andrieux (fandrieu,
    14:01:38)
- Periyasamy Palanisamy (epalper,
    14:01:44)
- Joe Kidder (joekidder,
    14:01:53)
- David Blaisonneau - Orange (david_Orange,
    14:01:58)
- Manuel Buil (mbuil,
    14:02:03)
 
 
- Scenario/Feature Status: os-nosdn-nofeature (fdegir, 14:02:34)
  - ovs pieces have been moved into
    os-nosdn-nofeature (fdegir,
    14:02:49)
- Functest healthcheck 100% passrate (fdegir,
    14:03:03)
- https://paste.ubuntu.com/26220997/
    (fdegir,
    14:03:10)
- Smoke tier is running now and will send all the
    logs to you and functest experts to see how serious the failures
    are (fdegir,
    14:03:30)
- But it looks good given that we are pretty
    close to the tip of master (fdegir,
    14:03:44)
- ceph will be moved into this as well
    (fdegir,
    14:03:54)
- https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/opnfv-scenario-requirements.yml
    (fdegir,
    14:06:58)
- https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/playbooks/bootstrap-scenarios.yml
    (fdegir,
    14:07:10)
- https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/playbooks/get-opnfv-scenario-requirements.yml
    (fdegir,
    14:07:17)
 
 
- Scenario/Feature Status: os-odl-sfc (fdegir, 14:08:18)
  - There is one missing patch in os_neutron which
    should be now ready (mbuil,
    14:09:37)
- https://review.openstack.org/#/c/510909/
    (mbuil,
    14:09:42)
- Post-merge job for SFC is up for review
    (fdegir,
    14:10:46)
- https://gerrit.opnfv.org/gerrit/#/c/49291/
    (fdegir,
    14:10:54)
- This job is crucial for promotion; whever
    something changes/gets submitted for os-odl-sfc scenario in sfc
    repo, it will be promoted to daily baremetal (fdegir,
    14:11:42)
- If it fails, the latest known/verified one will
    stay as working version/will not be replaced by the latest merged
    one (fdegir,
    14:12:22)
- More info/documentation will be created once
    the basics are in place (fdegir,
    14:12:43)
 
 
- Scenario/Feature Status: os-odl-bgpvpn (fdegir, 14:13:12)
  - Blueprint is up for review  (fdegir,
    14:13:44)
- https://review.openstack.org/#/c/523171/
    (fdegir,
    14:13:50)
- The patch for ml2 config for networking bgpvpn
    is also up for review. Works fine in XCI. Able to attach router/vm
    into bgpvpn instance and get datapath working among tenant
    VMs (fdegir,
    14:14:57)
- https://review.openstack.org/#/c/522598/
    (fdegir,
    14:15:04)
- Quagga integration is pending for external
    DC-GW connectivity. Not yet tested. (fdegir,
    14:15:29)
- https://review.openstack.org/#/c/523907/
    (fdegir,
    14:15:35)
 
 
- Scenario/Feature Status: Kubernetes (fdegir, 14:16:54)
  - The patch
    https://gerrit.opnfv.org/gerrit/#/c/46153/ will be updated, which
    use master kubespray to deploy the kubernetes, and make k8s as a
    NFVI in XCI, according the
    https://gerrit.opnfv.org/gerrit/#/c/48711/ (fdegir,
    14:18:00)
- hw_wutianwei attempted deploying k8s from
    kubespray master and there are some issues (fdegir,
    14:19:18)
 
 
- Scenario/Feature Status: Congress (fdegir, 14:23:02)
  - Congress is pretty close to completion. There
    is one change left, introducing os_congress role. (fdegir,
    14:23:45)
- https://review.openstack.org/#/c/522491/
    (fdegir,
    14:23:47)
 
 
- Scenario/Feature Status: Promise/Blazar (fdegir, 14:24:14)
  - The blueprint is under review with the help
    from OPNFV Promise and OpenStack Blazar projects (fdegir,
    14:24:41)
- https://review.openstack.org/#/c/528567/
    (fdegir,
    14:24:43)
 
 
- Scenario/Feature Status: HA/Masakari (fdegir, 14:25:18)
  - We met with HA team during plugfest and
    continuing conversations around how we can support them (fdegir,
    14:25:37)
- Few questions will be sent to Masakari team for
    further clarification (fdegir,
    14:25:52)
 
 
- General Framework Updates: CentOS Support (fdegir, 14:26:37)
 
- General Framework Updates: Stability Improvements (fdegir, 14:31:36)
  - patches are sent (david_Orange,
    14:32:00)
- https://gerrit.opnfv.org/gerrit/#/q/status:open+project:releng-xci+branch:master+topic:stabilization
    (david_Orange,
    14:32:11)
- i corrected XCI integration one (never patch a
    friday evening) (david_Orange,
    14:32:47)
- jenkins failed 2 last times, one on bifrost not
    deploying one node, and the other before starting the script
    (david_Orange,
    14:33:33)
 
 
- General Framework Updates: Multiple NFVi deployer support (fdegir, 14:37:06)
  - hwoarang did this change, pushing osa
    separately to enable bringing in new NFVi stuff in, such as k8s and
    possibly kolla (fdegir,
    14:37:37)
- https://gerrit.opnfv.org/gerrit/#/c/48711/
    (fdegir,
    14:37:43)
 
 
- General Framework Updates: Enabling additional CI loops (fdegir, 14:41:13)
  - Work has started to create periodic jobs
    against upstream osa (fdegir,
    14:41:26)
- https://gerrit.opnfv.org/gerrit/#/c/49271/
    (fdegir,
    14:41:36)
- This will help us to integrate functest
    healthcheck without disturbing xci-verify jobs (fdegir,
    14:41:53)
- Once it is done, those functest pieces will be
    pulled into xci-verify and sfc post merge jobs (fdegir,
    14:42:22)
- The purpose of this job is to find working
    version of upstream automatically but sha bump still needs to be
    done manually to keep ourselves sane (fdegir,
    14:42:59)
 
 
- Upcoming OSA SHA Bump (fdegir, 14:44:10)
  - We might bump osa sha soon but it is unknown
    when (fdegir,
    14:44:25)
- We might need to keep current one until
    functest is integrated (fdegir,
    14:44:36)
- https://review.openstack.org/#/c/529163/
    (fdegir,
    14:45:04)
 
 
- Hardware Resources (fdegir, 14:45:26)
  - Intel POD16 is dedicated to CI and all the
    nodes except node5 is operational on Jenkins (fdegir,
    14:45:42)
- Intel POD21 is for development purposes and we
    currently have 3 people signed up for resources - electrocucaracha,
    Taseer, and fandrieu (fdegir,
    14:46:46)
 
 
- Intel OPNFV lab maintenance (fdegir, 14:47:17)
  - no power in the building again from Friday Jan.
    12th - Tuesday Jan. 16th (fdegir,
    14:47:42)
 
 
- Meetings during holiday period (fdegir, 14:48:52)
  - AGREED: Next meeting
    is on January 10th, 2018. New meeting series will be sent.
    (fdegir,
    14:50:26)
 
Meeting ended at 14:52:44 UTC
(full logs).
Action items
  - (none)
People present (lines said)
  - fdegir (144)
- ttallgren (35)
- hwoarang (21)
- david_Orange (14)
- hw_wutianwei (13)
- mbuil (8)
- epalper (6)
- jmorgan1 (6)
- mardim (5)
- collabot (4)
- electrocucaracha (3)
- fandrieu (2)
- joekidder (1)
Generated by MeetBot 0.1.4.