#opnfv-pharos: Cross Community CI
Meeting started by fdegir at 13:00:24 UTC
(full logs).
Meeting summary
- Rollcall (fdegir, 13:00:29)
  - Tapio (ttallgren,
    13:00:38)
- Victor Morales (electrocucaracha,
    13:00:53)
- Tianwei Wu (hw_wutianwei_,
    13:01:20)
 
 
- OpenCI Updates: Event Driven/Federated CI/CD (fdegir, 13:02:02)
  - We are working on bringing the prototype up
    based on what is proposed on the docs shared last week (fdegir,
    13:02:29)
- https://docs.google.com/document/d/1WyjD6Wz4p7jVnEtRfwhsKltrtHxDiJZGaj5Nn0U-psE/edit#
    (fdegir,
    13:02:42)
- yolanda_ is also helping out with it by writing
    a utility to publish events to activemq message broker (fdegir,
    13:03:03)
- I hope to have it up and running before OpenDev
    which we can hopefully have a demo to OPNFV before that (fdegir,
    13:03:41)
- Manuel Buil (mbuil,
    13:04:39)
 
 
- OpenCI Updates: Zuul Prototype (fdegir, 13:04:51)
  - Zuul is up and running on my VM and I'll move
    it to OPNFV machine during the rest of the week (fdegir,
    13:05:19)
- Markos Chandras (hwoarang,
    13:05:25)
- A sample change is (fdegir,
    13:05:44)
- https://gerrit.opnfv.org/gerrit/#/c/56399/
    (fdegir,
    13:05:46)
- Periyasamy Palanisamy (epalper,
    13:08:46)
 
 
- Baremetal Status (fdegir, 13:11:08)
  - mbuil started looking into introducing
    baremetal for XCI (fdegir,
    13:11:22)
- ACTION: fdegir to
    request access for hwoarang for lf-pod4 & ericsson-pod2
    (fdegir,
    13:13:45)
- ACTION: mbuil to
    share his spec regarding pdf/idf introduction and baremetal
    support (fdegir,
    13:15:03)
 
 
- Promotion criterias/test scope for CI Loops used by XCI (fdegir, 13:16:20)
  - The changes talking about the terminology, CI
    loops and criterias are up for review (fdegir,
    13:16:41)
- https://gerrit.opnfv.org/gerrit/#/q/status:open+project:releng-xci+branch:master+topic:set-promotion-criterias
    (fdegir,
    13:16:50)
- It didn't get much love from scenario owners so
    I'll ping them again (fdegir,
    13:17:05)
 
 
- Tagging repos/Pinning scenarios (fdegir, 13:20:14)
  - sdnvpn repo has been tagged with 6.0.0 project
    internal tag and the scenario is pinned in xci (fdegir,
    13:20:30)
- sfc repo is waiting to be tagged so we can pin
    the scenario (fdegir,
    13:21:47)
- Tagging/pinning generic scenarios requires us
    to move them to their own repo since tagging and pinning can't be
    done while they're in same repo (fdegir,
    13:22:24)
- So the folder releng-xci/xci/scenarios will be
    moved to its own repo releng-xci-scenarios as is and the history
    will be preserved (fdegir,
    13:23:16)
- ACTION: fdegir to
    submit a ticket to helpdesk for the move (fdegir,
    13:23:36)
- ACTION: fdegir
    hwoarang to look at possible impacts of this move (fdegir,
    13:23:50)
 
 
- Long Duration Testing Support (fdegir, 13:26:09)
  - We will not be able to support LDT near
    term (fdegir,
    13:26:25)
 
 
- Scenario Status Check (fdegir, 13:31:45)
  - All k8s scenarios are now supported on
    openSUSE (fdegir,
    13:33:29)
- ACTION: hw_wutianwei_
    electrocucaracha epalper to start talking about onap scenario in xci
    on k8s (fdegir,
    13:38:06)
 
 
- Scenario Consolidation and SDF (fdegir, 13:44:17)
  - Thanks to hw_wutianwei_, Taseer, and hwoarang,
    we now have 4 k8s scenarios that are crucial for scenario
    consolidation and SDF work (fdegir,
    13:44:48)
- We are supporting that work with prototyping
    and if anyone is interested in it and have ideas, please provide
    them on the etherpad (fdegir,
    13:45:19)
- https://etherpad.opnfv.org/p/scenario-consolidation
    (fdegir,
    13:45:31)
 
 
- AoB (fdegir, 13:46:35)
  - Some of you might be aware of this that David
    decided to stop working in XCI and stepping from committer
    role (fdegir,
    13:47:08)
- I want to thank David for all the contributions
    he made (fdegir,
    13:47:39)
- https://gerrit.opnfv.org/gerrit/#/c/56471/
    (fdegir,
    13:48:07)
- The change adding proxy support for k8s
    scenarios needs reviews (fdegir,
    13:51:45)
- https://gerrit.opnfv.org/gerrit/#/c/56159/
    (fdegir,
    13:51:52)
 
Meeting ended at 13:59:07 UTC
(full logs).
Action items
  - fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
- mbuil to share his spec regarding pdf/idf introduction and baremetal support
- fdegir to submit a ticket to helpdesk for the move
- fdegir hwoarang to look at possible impacts of this move
- hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
Action items, by person
  -  electrocucaracha 
    - hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
 
-  epalper 
    - hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
 
-  fdegir 
    - fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
- fdegir to submit a ticket to helpdesk for the move
- fdegir hwoarang to look at possible impacts of this move
 
-  hw_wutianwei_ 
    - hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
 
-  hwoarang 
    - fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
- fdegir hwoarang to look at possible impacts of this move
 
-  mbuil 
    - mbuil to share his spec regarding pdf/idf introduction and baremetal support
 
People present (lines said)
  - fdegir (171)
- hwoarang (25)
- ttallgren (22)
- electrocucaracha (17)
- mbuil (17)
- hw_wutianwei_ (11)
- epalper (8)
- collabot` (3)
- jmorgan1 (2)
Generated by MeetBot 0.1.4.