#opnfv-promise: Promise
Meeting started by GeraldK at 14:03:06 UTC
(full logs).
Meeting summary
- 
  - Bryan Sullivan (bryan_att,
    14:04:12)
 
  - Ryota Mibu (r-mibu,
    14:04:22)
 
  - Bertrand Souville (bertys,
    14:04:27)
 
  - Gerald Kunzmann (GeraldK,
    14:04:32)
 
  - Peter Lee (corenova,
    14:04:32)
 
 
- Report from ETSI NFV TST and OPNFV hackfest (GeraldK, 14:06:29)
  - ClearPath participated in ETSI NFV TST session
    to report on YANGFORGE tool (GeraldK,
    14:07:21)
 
  - see slideset ETSI_NFV_11_yangforge.pptx
    (GeraldK,
    14:09:55)
 
  - update on Promise OPNFV hackfest (corenova,
    14:17:37)
 
  - due to 5 parallel sessions and only few persons
    joining the Promise session, there had not been progress on Promise
    during the hackfest. (GeraldK,
    14:18:15)
 
  - deadline for OPNFV hackfest session at
    OpenStack Summit is this Wednesday. promise should propose a
    session. (GeraldK,
    14:19:09)
 
  - Peter had met with Intent project and thinks
    this is another important topic (GeraldK,
    14:20:44)
 
  - raised point on flavor framework and how it
    will align better with other domains beyond compute, such as
    network/quantum (corenova,
    14:22:53)
 
  - https://wiki.openstack.org/wiki/Neutron/FlavorFramework
    (bertys,
    14:27:09)
 
  - Bryan_att: what we look at is reservation for
    future usage at higher granularity (GeraldK,
    14:29:54)
 
  - Peter: resource reservation is not about a
    contract, but more like a dialogue: I want to reserve some resources
    in the future and get informed if somehting happens and the
    reservation cannot be fulfilled (GeraldK,
    14:33:06)
 
  - Bryan_att mentions this can be seen as a kind
    of contract (GeraldK,
    14:33:31)
 
  - "reservation/allocation priority" vs. "higher
    tier resources" (GeraldK,
    14:35:03)
 
  - we need to look into policies, e.g. which
    resources to terminate to allow for reserved resources to be
    allocated. (GeraldK,
    14:36:21)
 
  - first step is to describe logic around
    reservation. those "error cases/policies" are second step
    (GeraldK,
    14:37:40)
 
  - Bryan_att: discussed with YANG experts in his
    company. can people directly contribute on github? (GeraldK,
    14:39:52)
 
  - Peter: not yet. (GeraldK,
    14:41:32)
 
  - Peter suggests that YANGFORGE could become its
    own OPNFV project and be used as OPFNV cross-project (GeraldK,
    14:43:50)
 
  - GeraldK asks Peter to share title and abstract
    for OPNFV Summit by today, such that team can review before
    submitting it on Wednesday (GeraldK,
    14:45:43)
 
  - Bryan_att also proposed some presentation for
    the Summit, maybe parts can be merged. (GeraldK,
    14:47:21)
 
 
- YANGFORGE demo (bertys, 14:47:47)
  - https://github.com/clearpath-networks/yangforge
    (bertys,
    14:48:48)
 
  - Peter is giving tool walk-through using yukebox
    example (GeraldK,
    14:54:31)
 
  - as example, adding a new API in ODL is a very
    long workflow compared to yangforge (GeraldK,
    14:58:42)
 
  - Peter plans to create a second project for
    Promise, but some changes are needed (planned for this week)
    (GeraldK,
    15:09:48)
 
  - Bryan_att: coffee script is used to describe
    server-side processing. can other expressions also be used? yes, JS
    is also possible. (GeraldK,
    15:11:01)
 
  - coffee script gets compiled into JS
    (GeraldK,
    15:11:18)
 
  - ClearPath plans to do an "app store" where
    developers can share their modules. (GeraldK,
    15:16:59)
 
 
- AOB (GeraldK, 15:17:52)
  - Ryota: can you build authentification /
    access-control in yangforge? not yet. (GeraldK,
    15:18:27)
 
  - ACTION: Peter to
    share title and abstract for OPNFV Summit by today (GeraldK,
    15:21:42)
 
  - Peter looking for volunteers to address the
    open action items from last weeks. some of them could be expressed
    as Jira tickets. (GeraldK,
    15:26:12)
 
 
Meeting ended at 15:27:20 UTC
(full logs).
Action items
  - Peter to share title and abstract for OPNFV Summit by today
 
People present (lines said)
  - GeraldK (34)
 
  - corenova (8)
 
  - collabot (6)
 
  - r-mibu (5)
 
  - bertys (5)
 
  - bryan_att (1)
 
Generated by MeetBot 0.1.4.