#opnfv-promise: promise

Meeting started by r-mibu at 14:01:31 UTC (full logs).

Meeting summary

  1. roll call (r-mibu, 14:01:44)
    1. Ildiko Vancsa (ildikov, 14:01:57)
    2. Bertrand Souville (bertys, 14:02:02)
    3. Bryan Sullivan (bryan_att, 14:02:14)
    4. Ryota Mibu (r-mibu, 14:02:42)
    5. Gerald (GeraldK, 14:09:41)
    6. Way of working: there are Jira tickets, but the way forward is not clear. should we organize into short/mid/long-term issues? (GeraldK, 14:14:55)
    7. proposal to better utilize features of Jira to do so (GeraldK, 14:15:43)
    8. inviting people from other projects to weekly meetings is of general interest and should be kept (GeraldK, 14:18:30)
    9. requirements track should stay a couple of month ahead of the implementation track (GeraldK, 14:21:14)

  2. Lab sharing with IPv6 project (GeraldK, 14:21:56)
    1. Peter Lee (corenova, 14:24:21)
    2. Bin: VM is used as IPv6 router; integration efforts with ODL trying to solve gaps (GeraldK, 14:24:46)
    3. Bin: after this has been addressed, infrastructure could be used for Promise (GeraldK, 14:25:39)
    4. IPv6 project is using Spirent community lab (bertys, 14:26:53)
    5. Peter: would be great if Promise could send our requirements (ODL version, number of nodes, ...) to Infra-Team and they set it up (without Promise getting "empty" hardware (GeraldK, 14:27:25)

  3. JIRA PROMISE-6 (r-mibu, 14:40:06)
    1. ACTION: Peter to update Promise-6 with additional contributors (corenova, 14:40:55)
    2. team should review and provide +1/+2 to the gerrit commit (corenova, 14:41:57)
    3. https://gerrit.opnfv.org/gerrit/#/c/1345/ (r-mibu, 14:42:04)

  4. JIRA PROMISE-19 (r-mibu, 14:42:37)
    1. Mirantis would be interested to re-open Blazar (GeraldK, 14:43:12)
    2. related to Promise long term architecture (GeraldK, 14:44:42)
    3. there is long-term effort to extract Nova scheduler. we can start utilizing the latest status of this project and update Blazar accordingly (GeraldK, 14:45:49)
    4. this extracting is *in the best case* done in Mitaka-release, but most likely in later release (GeraldK, 14:46:49)
    5. shim-layer approach seems the only way we can achieve our goals in few months. we should give high prio to solve southbound I/F gaps. but long-term architecture should not be neglected. (GeraldK, 14:51:57)
    6. Peter will make initial draft (GeraldK, 14:53:31)
    7. allocation part might be difficult. Peter is assuming all allocation request go via shim layer to make this work. we need to write down this big picture. (GeraldK, 14:54:06)

  5. promise software architecture diagram (shim layer) (GeraldK, 14:55:34)
    1. this is not part of weekly Promise meeting, but additional technical meeting (GeraldK, 14:56:06)
    2. https://jira.opnfv.org/secure/attachment/10501/opnfv-promise.png (GeraldK, 14:56:54)
    3. top-left: package "yan/opnfv-promise" has dependency on other packages and schema files (GeraldK, 15:00:11)
    4. "yangforge" provides several internal types (GeraldK, 15:01:11)
    5. ComputeElement, VMImage, etc are instances of ResourceElement; ServerInstance is instance of ResourceInstance (GeraldK, 15:03:20)
    6. Promise instance needs to be tied to OpenStack. two ways to implement this: 1) tight integration between OpenStack and Promise by direct mapping logic and 2) a new layer encapsulating OpenStack (GeraldK, 15:05:35)
    7. OpenStack package can even capture different versions of OpenStack, e.g. different API versions (GeraldK, 15:06:54)
    8. the OpenStack package can also be (re-)used for other (OPNFV) projects (GeraldK, 15:08:31)
    9. there is not yet a basic demo for the OpenStack package (GeraldK, 15:11:15)
    10. this is planned for this week (GeraldK, 15:12:20)
    11. i.e. initial transaction to add a ResourceProvider and populate it with all related data (GeraldK, 15:13:09)
    12. idea is to capture all details, except things done via API extensions. (GeraldK, 15:13:42)
    13. Ildiko: who stores the reservations? Peter: idea is that Promise shim-layer stores all this information required, encapsulating a lot of existing information available downstream. (GeraldK, 15:15:05)
    14. Ildiko: are you planning to include "quotas"? Peter: quota system would be "query"-based, but in the first step not allow to change the quotas in OpenStack. (GeraldK, 15:16:33)
    15. shim-layer is kind of emulating OpenStack thus allowing to implement Promise features in the shim-layer (GeraldK, 15:17:27)
    16. this requires a feedback-loop to keep states synchronized (best in real-time). some delay might be acceptable for Promise (this has to be analyzed/discussed in more detail) (GeraldK, 15:20:31)
    17. Gerald: Promise might be okay with a more coarse-grained information. (GeraldK, 15:21:03)
    18. Peter: this also depends on the usage of the reservation system, whether you do reservations/changes on a per minute or per day frequency (GeraldK, 15:21:52)
    19. Peter could need help to model missing things in the yangforge schemas; also the code logic for reservation is missing. (GeraldK, 15:28:41)
    20. Ildiko: do we need all those models to evaluate the approach as such? No, not all the models, but the basic ones, e.g. storage/network could be done later. (GeraldK, 15:29:54)
    21. Ildiko: are the flows etc already captured, e.g. in the requirement document? (GeraldK, 15:30:56)
    22. No, we don't have these explicit flows. (GeraldK, 15:32:00)
    23. Peter is quite confident that this shim-layer will allow for the basic reservation features among different resource types; but if there are specific behaviours, we may not be able to sufficiently model this (at least in the initial version). (GeraldK, 15:36:05)
    24. Peter will prepare and share sequence diagrams around the reservation flows (GeraldK, 15:40:41)
    25. team should then support Peter to continue from these baseline diagrams to extend to other flows/logic (GeraldK, 15:43:14)
    26. discussion on documentation priorities/needs. (GeraldK, 15:55:20)


Meeting ended at 15:55:56 UTC (full logs).

Action items

  1. Peter to update Promise-6 with additional contributors


People present (lines said)

  1. GeraldK (51)
  2. r-mibu (12)
  3. collabot (11)
  4. corenova (4)
  5. bryan_att (2)
  6. bertys (2)
  7. ildikov (1)


Generated by MeetBot 0.1.4.