#opnfv-promise: promise

Meeting started by ildikov at 06:36:15 UTC (full logs).

Meeting summary

    1. Gerald Kunzmann (GeraldK, 06:39:02)

  1. Brahmaputra update (GeraldK, 06:39:35)
    1. Peter has completed scripting all defined Promise test cases (GeraldK, 06:40:48)
    2. https://github.com/opnfv/promise/tree/master/test/promise-intents.coffee (GeraldK, 06:40:56)
    3. test suite is grouped into 7 test scenarios, which executes 15 distinct intent test cases and comprises of 33 overall test verification conditions (GeraldK, 06:41:11)
    4. not all test cases are passing (intentionally left this way) (GeraldK, 06:43:59)
    5. key issue here at the moment is that "create-instance" related test cases require the image ID and flavor ID in order to successfully execute (GeraldK, 06:44:13)
    6. for execution with functest Peter has contacted Morgan (GeraldK, 06:45:10)
    7. Gerald will update cases.json file and share with Morgan (GeraldK, 06:47:51)
    8. Arturo: test cases are now more adapted with the shim-layer compared to what Arturo had drafted earlier. Question on "capacity managemet": (GeraldK, 06:49:19)
    9. Capacity managent as referred in the tests is shim-layer capacity management (but not linked to OpenStack capacity). You can set artifical values here. Explanation see patch for requirement document. (GeraldK, 06:50:36)
    10. OpenStack "quota" is used for allocation, but shim-layer "capacity" is used for reservations (GeraldK, 06:51:15)
    11. https://gerrit.opnfv.org/gerrit/#/c/6509/ Update shim-layer work flows (GeraldK, 06:51:45)
    12. Promise integration with installers (GeraldK, 06:52:45)
    13. https://jira.opnfv.org/browse/FUEL-52 Jonas commented this is coming really late, but will write Plugin installer (GeraldK, 06:53:02)
    14. https://jira.opnfv.org/browse/JOID-43 request for JOID created (GeraldK, 06:53:18)
    15. https://jira.opnfv.org/browse/GENESIS-55 projects can only become part of Genesis if supported by ALL installers; this will not be met for B-release (GeraldK, 06:54:21)
    16. Note: this does not mean Promise will not be part of Brahmaputra, where support from at least one installer is required. (GeraldK, 06:54:35)

  2. Integrated architecture (GeraldK, 07:00:31)
    1. Blazar is "old" code and has to be updated to the latest version of OpenStack (GeraldK, 07:04:12)
    2. most of the old Blazar core team is not available anymore, we need to find supporters (GeraldK, 07:06:16)

  3. New meeting time slot(s) (GeraldK, 07:10:33)
    1. we will have alternating meeting slots on Thursdays: (GeraldK, 07:15:28)
    2. first slot 10-11 UTC (GeraldK, 07:15:38)
    3. the other week decision is 17-18 UTC slot (GeraldK, 07:16:59)
    4. ACTION: Gerald to update Wiki. Peter to update meeting (GTM) invitation (GeraldK, 07:18:09)
    5. we will start with late slot (17-18) next week (GeraldK, 07:19:51)


Meeting ended at 07:20:53 UTC (full logs).

Action items

  1. Gerald to update Wiki. Peter to update meeting (GTM) invitation


People present (lines said)

  1. GeraldK (28)
  2. collabot` (4)
  3. ildikov (2)
  4. r-mibu (1)


Generated by MeetBot 0.1.4.