#opnfv-promise: Promise

Meeting started by GeraldK at 15:54:56 UTC (full logs).

Meeting summary

  1. Roll call (GeraldK, 15:55:04)
    1. Gerald Kunzmann (GeraldK, 15:59:57)
    2. Bertrand Souville (bertys, 16:01:09)
    3. Ildiko Vancsa (ildikov, 16:03:14)
    4. https://wiki.opnfv.org/display/meetings/Promise (bertys, 16:04:05)
    5. Peter will not be able to join. we will not show a demo during the Summit (GeraldK, 16:08:26)

  2. Blazar (GeraldK, 16:08:36)
    1. ildikov: no progress due to resource issue and not ready Nova scheduler issues (GeraldK, 16:09:05)

  3. YangForge (GeraldK, 16:09:56)
    1. https://github.com/corenova/yang-forge (GeraldK, 16:10:16)
    2. current Promise (Brahamputra) is based on December release of YangForge. (GeraldK, 16:10:32)
    3. Peter's new company is focusing on ability to more effectively model things. (GeraldK, 16:11:23)
    4. for Promise this is to model the resource reservation feature towards OpenStack in a shim-layer architecture (GeraldK, 16:12:01)
    5. YF allows to have a stand-alone abstraction layer for OpenStack. this will allow for better usage of -no only- Promise (GeraldK, 16:13:10)
    6. updates to make YF more flexible with goal to address synchronization issues between OpenStack and the shim-layer; being able to be more reactive to events in OpenStack (GeraldK, 16:14:05)
    7. has not looked into updating the Promise related code yet; Peter plans to do this as part of Colorado (GeraldK, 16:15:03)
    8. Prakash: is this model-based? (GeraldK, 16:16:34)
    9. Peter: yes. working also on ONOS side to support Yang in ONOS (GeraldK, 16:16:57)
    10. Prakash: is it a peer-to-peer template? (GeraldK, 16:18:59)
    11. Peter: basically you can even write a schema that is writing to another schema (GeraldK, 16:19:58)
    12. Prakash: this is interesting for the Domino project. you have a use case here to exchange templates incl translations (GeraldK, 16:21:03)
    13. Peter: for Promise want to break down the models and decouple the OpenStack from the Promise model (GeraldK, 16:22:37)
    14. this will allow different experts can work on different aspects independently (GeraldK, 16:23:59)

  4. Open action points (GeraldK, 16:24:25)
    1. https://wiki.opnfv.org/download/attachments/6819702/colorado%20r6.pdf?version=1&modificationDate=1463782894000&api=v2 (GeraldK, 16:24:37)
    2. feature freeze is currently targeting July 1st (GeraldK, 16:25:53)
    3. https://wiki.opnfv.org/display/promise/Promise+Colorado+planning (GeraldK, 16:26:27)
    4. Peter to update the Yang-related tasks in JIRA (GeraldK, 16:28:36)
    5. ACTION: Gerald to update all "due dates" in Jira (GeraldK, 16:32:22)
    6. https://wiki.opnfv.org/display/SWREL/Colorado+scenario+inventory+and+dependencies (GeraldK, 16:32:42)
    7. ACTION: Peter to update (GeraldK, 16:33:37)
    8. https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects (GeraldK, 16:33:52)
    9. ACTION: Peter to update Promise Colorado intent in the above link (GeraldK, 16:35:46)
    10. ACTION: Peter to update the JIRA Sprints; maybe even completely remove it (GeraldK, 16:36:53)
    11. ACTION: Peter to update JIRA version fields (see email David) (GeraldK, 16:38:44)

  5. Relation to OPNFV-MANO (GeraldK, 16:39:33)
    1. question came up in OPNFV technical discussion meeting today (GeraldK, 16:40:12)
    2. Promise team can support OPNFV-MANO to see what is already there for the resource reservation I/F (GeraldK, 16:45:12)
    3. both Promise and Doctor try to align as much as possible to ETSI NFV specs (GeraldK, 16:45:56)
    4. Prakash asks for contributors from Promise to OPNFV-MANO (GeraldK, 16:47:58)
    5. first step could be to point OPNFV-MANO team to the Promise interface specification in the Promise documentation (GeraldK, 16:48:41)
    6. upcoming meetings: go back to regular schedule next week, i.e. 6pm CET, 9am PST (GeraldK, 16:52:21)


Meeting ended at 16:52:44 UTC (full logs).

Action items

  1. Gerald to update all "due dates" in Jira
  2. Peter to update
  3. Peter to update Promise Colorado intent in the above link
  4. Peter to update the JIRA Sprints; maybe even completely remove it
  5. Peter to update JIRA version fields (see email David)


People present (lines said)

  1. GeraldK (43)
  2. collabot` (5)
  3. bertys (3)
  4. ildikov (1)


Generated by MeetBot 0.1.4.