#opnfv-release: Colorado Release

Meeting started by dmcbride at 14:50:35 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 14:52:37)
    1. David McBride (dmcbride, 14:53:13)
    2. Chris Price (ChrisPriceAB, 14:53:29)
    3. Sofia Wallin (sofiawallin, 15:00:24)
    4. Bin Hu (bin_, 15:00:51)
    5. Jose Lausuch (jose_lausuch, 15:02:19)
    6. Bryan Sullivan (bryan_att, 15:03:17)
    7. Ryota Mibu (r-mibu, 15:03:54)
    8. Morgan Richomme (morgan_orange, 15:04:09)
    9. Frank Brockners (frankbrockners, 15:07:22)
    10. https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (jose_lausuch, 15:09:22)
    11. Billy O'Mahony (billyo, 15:09:37)
    12. Jack Morgan (jmorgan1, 15:10:56)
    13. Trevor Cooper (trevor_intel_, 15:11:21)
    14. Mark Beierl (mbeierl, 15:11:31)

  2. test release criteria (ChrisPriceAB, 15:14:38)
    1. https://wiki.opnfv.org/display/SWREL/Colorado+Testing+-+Discussion+and+Proposals (mbeierl, 15:18:27)
    2. page listed above is for the test projects is to help us get to a common understanding of release criteria (mbeierl, 15:19:56)
    3. release criteria maps to test projects, which execute which test cases (mbeierl, 15:20:21)
    4. need clear demarcation to state when C is ready to go out (mbeierl, 15:20:49)
    5. what scenarios are required and what hardware resources are required to fulfill the release testing (mbeierl, 15:21:50)
    6. experience in B was that the time was getting out of realistic range, so this criteria is needed to help control the scope and duration of the test runs (mbeierl, 15:23:43)
    7. this discussion is to continue in the next test projects meeting (mbeierl, 15:24:45)
    8. about 40 projects have indicated C participation (mbeierl, 15:25:55)
    9. should the test group have release go/no go authority? (mbeierl, 15:28:58)
    10. Right now it is with TSC (mbeierl, 15:29:17)
    11. test projects have input into the process (mbeierl, 15:29:39)
    12. due to B release experience, David is calling for more discussion from the installer PTLs (mbeierl, 15:31:10)
    13. What exactly is the release criteria has yet to be determined (mbeierl, 15:40:33)
    14. intent was to have install, functest, yardstick, but this was not always possible (mbeierl, 15:41:27)
    15. test case definition and implementation should be separate from test execution (mbeierl, 15:42:53)
    16. David's intent is to go towards a JIRA scrub for C (mbeierl, 15:44:22)
    17. can project leads create the Version "Colorado 1.0" in their respective JIRA projects? (mbeierl, 15:49:51)
    18. tracking upstream projects is manual and a fair amount of replication (mbeierl, 15:50:27)
    19. can JIRA be federated within Linux Foundation? (mbeierl, 15:50:45)
    20. Pharos uses Components for sub-caterogizing (mbeierl, 15:51:47)
    21. This does not help the replication problem though (mbeierl, 15:52:10)
    22. Frank offering to collect info from other projects to see how to improve this (mbeierl, 15:52:31)
    23. HTTP link is still not visible enough within JIRA (mbeierl, 15:53:03)
    24. The copy/paste worked in B with the wiki, can it work for JIRA? (mbeierl, 15:54:30)
    25. Federating our JIRA instances within LF will provide a way of resucing the copy/paste (mbeierl, 15:55:25)
    26. Frank has offered to help drive improvements in this area, but if there is no interest, the existing methods will suffice for C (mbeierl, 15:56:11)
    27. ACTION: Installer PTLs - Jose L indicates that FuncTest installer smoke tests have been fixed. Please integrate these tests with your CI and report on results. (dmcbride, 16:06:33)


Meeting ended at 16:07:25 UTC (full logs).

Action items

  1. Installer PTLs - Jose L indicates that FuncTest installer smoke tests have been fixed. Please integrate these tests with your CI and report on results.


People present (lines said)

  1. mbeierl (31)
  2. jose_lausuch (13)
  3. collabot` (8)
  4. ChrisPriceAB (7)
  5. dmcbride (6)
  6. trozet (2)
  7. frankbrockners (1)
  8. trevor_intel_ (1)
  9. bryan_att (1)
  10. r-mibu (1)
  11. jmorgan1 (1)
  12. bin_ (1)
  13. sofiawallin (1)
  14. billyo (1)
  15. morgan_orange (1)


Generated by MeetBot 0.1.4.