#opnfv-release: OPNFV release

Meeting started by dmcbride at 15:02:37 UTC (full logs).

Meeting summary

  1. roll call (dmcbride, 15:02:45)
    1. David McBride (dmcbride, 15:02:49)
    2. Jose Lausuch (jose_lausuch, 15:06:54)
    3. Greg Elkinbard (Greg_E_, 15:06:58)
    4. Tapio Tallgren (tallgren, 15:07:05)
    5. Stuart Mackie (StuartMackie, 15:07:07)
    6. Ray Paik (rpaik, 15:07:43)
    7. Sofia Wallin (sofiawallin, 15:08:33)
    8. https://www.gotomeeting.com/join/775124285 (Greg_E_, 15:09:05)

  2. Milestone 1 - release planning (tallgren, 15:10:51)
    1. still lacking a release template (dmcbride, 15:11:28)
    2. dmcbride notes that release plan template maybe something that is needed (rpaik, 15:11:36)
    3. HKirksey asks whether we need a release template (dmcbride, 15:11:48)
    4. perhaps a template is useful for new projects, but less necessary for more experienced projects (dmcbride, 15:12:22)
    5. dneary asks whether joining the release is a worthwhile goals for many projects (tallgren, 15:14:14)
    6. frankbrockners notes that template would be helpful for those that are new to the community and would be good to factor in project types (e.g. testing, development, etc.) (rpaik, 15:16:10)
    7. Trevor Cooper (trevor_intel_, 15:17:45)
    8. jmorgan1 notes that it would be helpful to have Jira tickets associates with items in the release plan (rpaik, 15:18:43)
    9. bryan_att cautions against putting too much effort into creating a template (dmcbride, 15:19:34)
    10. fdegir points out that the release needs must be followed during the release cycle (tallgren, 15:23:01)
    11. fdegir points out the need to refresh CI resource req throughout the release cycle (dmcbride, 15:23:53)

  3. Milestone 2 - Communicate test requirements (tallgren, 15:24:39)
    1. dmcbride notes that he plans to simplify questions for MS2 (test case requirements) (rpaik, 15:26:16)
    2. There were problems in testing Kubernetes but jose_lausuch points out that the test frameworks are being extended to include it (tallgren, 15:34:10)
    3. Bryan Sullivan (bryan_att, 15:34:25)
    4. re the last point we should add or strengthen project plan checks in which the project clarifies how their scope is covered by feature tests (e.g. Tempest or other), and if that coverage is incomplete (we're not bored yet) they include plans to make progress toward better coverage in the release. (bryan_att, 15:36:57)
    5. we should get the installer projects to give a little more detail as to what the issue was with Danube/Newton late readiness, so we can know whether the issue is likely to continue and what if anything we can do to improve the situation and de-risk future readiness for feature project development/testing. (bryan_att, 15:40:10)
    6. e.g. the issue may be resources, upstream dependency/cadence issues, issues not expected to repeat (e.g. major lab move), ... (bryan_att, 15:41:06)
    7. radez asks if MS3 & MS4 could be collapsed (rpaik, 15:41:13)
    8. Discussion about whether installer milestone should be earlier than the test framework milestone (tallgren, 15:41:41)
    9. bryan_att asks whether installer projects could do a retrospective on openstack integration experience in Danube (dmcbride, 15:42:45)
    10. in general the approach we (AT&T) recommend and will pursue is to focus development effort on trunk for the current upstream release at all times, so we are not impeded; and to focus development effort on generic upstream environments that are not impacted by the installer integration schedule. (bryan_att, 15:43:01)
    11. as we are also proposing a new installer project (Armada), we will be a test subject for that (somewhat) ambitious (but ultimately crucial IMO) goal. (bryan_att, 15:44:18)
    12. ACTION: dmcbride to schedule a session on installer integration during the Plugfest in a few weeks (rpaik, 15:44:46)

  4. Milestone 4 - Infrastructure Updates Completed (tallgren, 15:45:58)
    1. dmbride proposes including "Test framework ready" to milestone 4 (tallgren, 15:48:43)
    2. MS4 is when installers need to pass smoke test with nosdn scenarios (rpaik, 15:50:08)

  5. Milestone 5 - Scenario integration and Feature Freeze (tallgren, 15:50:44)
  6. Milestone 6 - Test Case Implementation (tallgren, 15:53:53)
    1. Discussion between bryan_att and dmcbride about hiring an intern to automate the Milestone 6 compliance check (tallgren, 15:59:03)
    2. discussion on utilizing test dashboard information for MS6 compliance verification (rpaik, 16:00:00)
    3. the verification that something is happening (e.g. feature project integration and successful test executions) is mine-able, so PTLs should not have to provide this information directly. (bryan_att, 16:00:52)
    4. we ran out of time at slide 10. We will resume the retrospective at next week's release meeting. (dmcbride, 16:02:27)


Meeting ended at 16:02:33 UTC (full logs).

Action items

  1. dmcbride to schedule a session on installer integration during the Plugfest in a few weeks


Action items, by person

  1. dmcbride
    1. dmcbride to schedule a session on installer integration during the Plugfest in a few weeks


People present (lines said)

  1. tallgren (15)
  2. dmcbride (13)
  3. rpaik (11)
  4. bryan_att (7)
  5. collabot` (6)
  6. Greg_E_ (2)
  7. StuartMackie (1)
  8. sofiawallin (1)
  9. trevor_intel_ (1)
  10. jose_lausuch (1)


Generated by MeetBot 0.1.4.