#opnfv-release: OPNFV release

Meeting started by dmcbride at 15:01:01 UTC (full logs).

Meeting summary

  1. roll call (dmcbride, 15:01:09)
    1. David McBride (dmcbride, 15:01:20)
    2. Yifei Xue (Proxy for Justin) (yifei, 15:02:01)
    3. Cédric OLLIVIER (ollivier, 15:02:17)
    4. Manuel Buil (mbuil, 15:02:33)
    5. Cristina Pauna (CristinaPauna, 15:02:44)
    6. Tim Rozet (trozet, 15:04:17)

  2. schedule review (dmcbride, 15:06:56)
    1. Maryam Tahhan (mtahhan_, 15:07:43)
    2. release plan review continues today at 11 a.m. PT (dmcbride, 15:08:50)
    3. MS3.0 - Dec 15 (dmcbride, 15:09:59)
    4. JOID, Daisy, Fuel (x86) have completed integration of OS Pike (dmcbride, 15:11:29)
    5. Compass will complete integration this week (dmcbride, 15:12:17)
    6. Apex will execute baremetal run beginning today (dmcbride, 15:13:01)
    7. Fuel (aarch64) expects to begin integration next week and be done in time for MS3.0 (dmcbride, 15:13:36)
    8. https://build.opnfv.org/ci/job/functest-apex-baremetal-daily-master/598/console (ollivier, 15:16:18)
    9. https://build.opnfv.org/ci/view/functest/job/functest-daisy-baremetal-daily-master/183/console (ollivier, 15:17:22)
    10. health check enabled can be confirmed by the string "Running Functest tier 'healthcheck'" for each installer (dmcbride, 15:21:23)
    11. this string may be found by examining the functest jenkins job console output for a particular scenario (dmcbride, 15:22:09)
    12. timirnich asks about monitoring installer status once MS3 requirements met (dmcbride, 15:33:16)
    13. short term plan is for release manager to manually check status of nosdn-nofeature scenario for each installer and report results to team on a weekly basis (dmcbride, 15:34:10)
    14. reporting by email or IRC (dmcbride, 15:34:17)
    15. ACTION: dmcbride to add requirement to MS3 that installers maintain a one run per week minimum for nosdn-nofeature scenarios (dmcbride, 15:35:03)
    16. Euphrates 5.1 scheduled for Dec 15 (dmcbride, 15:35:55)
    17. all scenarios that had regressed post-5.0 release are now passing the deploy step (dmcbride, 15:39:41)
    18. timirnich points out that we also need to examine current test results as compared to results at 5.0 release (dmcbride, 15:40:09)

  3. MS4 definition (dmcbride, 15:42:04)
    1. mtahhan_ suggests that test projects submit last jenkins run for a particular date (dmcbride, 15:50:51)
    2. https://build.opnfv.org/ci/view/vswitchperf/job/vswitchperf-daily-master/lastSuccessfulBuild/ for example (dmcbride, 15:51:09)
    3. test projects run unit tests but not functional tests against a reference platform. No infra support currently. (dmcbride, 15:56:44)
    4. which projects does MS4 apply to? Functest, Yardstick, VSPerf, StorPerf. (dmcbride, 16:02:46)
    5. mtahhan_ says any project that belongs to the test working group (dmcbride, 16:03:15)
    6. what about projects that depend on test frameworks. For example, HA depends on Yardstick. (dmcbride, 16:04:42)


Meeting ended at 16:04:48 UTC (full logs).

Action items

  1. dmcbride to add requirement to MS3 that installers maintain a one run per week minimum for nosdn-nofeature scenarios


Action items, by person

  1. dmcbride
    1. dmcbride to add requirement to MS3 that installers maintain a one run per week minimum for nosdn-nofeature scenarios


People present (lines said)

  1. dmcbride (27)
  2. ollivier (3)
  3. collabot (3)
  4. yifei (1)
  5. trozet (1)
  6. mtahhan_ (1)
  7. CristinaPauna (1)
  8. mbuil (1)


Generated by MeetBot 0.1.4.