#opnfv-release: OPNFV Release Process Working Group

Meeting started by dmcbride_ at 13:01:54 UTC (full logs).

Meeting summary

  1. roll call (dmcbride_, 13:02:03)
    1. Trevor Bramwell (bramwelt, 13:02:09)
    2. David McBride (dmcbride_, 13:02:33)
    3. Emma Foley (efoley, 13:03:09)
    4. Rama (dmcbride_, 13:05:53)
    5. We will still have a twice yearly release, to help with project promotion and marketing (efoley, 13:12:50)
    6. The CD release model will server as meta releases throughout the cycle (efoley, 13:13:16)
    7. Mark Beierl (mbeierl, 13:13:16)
    8. Release process should be lightweight for "official" and "intermediate" releases, as the current process is considered burdensome for some (efoley, 13:14:00)
    9. https://jenkins.io/download/lts/ (bramwelt, 13:18:36)
    10. every 6 months take the "best" release and make that part of an OPNFV release (dmcbride_, 13:18:38)
    11. bramwelt describes Jenkins release cycle - every 2 weeks plus major release every 12 weeks (dmcbride_, 13:19:29)
    12. Trevor suggested that there should be two separate independant for CD and traditional release. Every 6 months, pick a previous CD release and "upgrade" it to LTS (efoley, 13:21:29)
    13. for the traditional release, choose a CD release, and promote that as the "big" release; Some additional testing/validation/collatoral may be needed to package this big release. (efoley, 13:25:03)
    14. How does a CD release get chose as the "big"/official release? We need to define criteria for choosing an official release from the set of CD releases (efoley, 13:26:16)
    15. bramwelt suggests two levels of process: 1) individual project releases; and 2) OPNFV major releases (dmcbride_, 13:44:09)
    16. bramwelt says define requirements first, then determine process (dmcbride_, 13:48:18)
    17. https://wiki.opnfv.org/display/SWREL/Continuous+Delivery+Release+Planning (efoley, 13:50:46)
    18. ACTION: dmcbride to locate CD process documentation from the last plugfest (dmcbride_, 13:52:33)
    19. Release requirements need to be defined per type of project (efoley, 13:53:05)
    20. test projects need to be validated separately, so that the validation they provide is credible (efoley, 13:55:18)

  2. do we need release artifacts? (dmcbride_, 13:56:32)


Meeting ended at 14:05:39 UTC (full logs).

Action items

  1. dmcbride to locate CD process documentation from the last plugfest


People present (lines said)

  1. efoley (11)
  2. dmcbride_ (11)
  3. collabot` (3)
  4. mbeierl (2)
  5. bramwelt (2)


Generated by MeetBot 0.1.4.