#opnfv-sfc: weekly opnfv sfc meeting, August 5, 2015

Meeting started by ebrjohn at 14:01:43 UTC (full logs).

Meeting summary

    1. ebrjohn Brady Johnson (ebrjohn, 14:01:55)
    2. Bryan Sullivan (bryan_att, 14:03:20)
    3. Tim Rozet (trozet, 14:03:55)
    4. Flavio Leitner (fbl, 14:03:57)
    5. Paul Quinn (paulq, 14:05:24)
    6. Keith Burns (alagalah) (alagalah, 14:05:39)
    7. https://wiki.opnfv.org/policytest/policytest_project_proposal new GBP in OPNFV testing project (ebrjohn, 14:07:30)
    8. alagalah: discussing PolicyTests proposal using GBP, SFC, and other OPNFV project focuses (bryan_att, 14:09:47)
    9. ...work in ODL on tests for various frameworks will be integrated for use in OPNFV (bryan_att, 14:11:24)
    10. ... will be discussed tomorrow on the tech call (bryan_att, 14:12:19)
    11. bryan_att: suggests that we start looking at the tools referenced in the interim while the project is bring considered (bryan_att, 14:14:12)
    12. alagalah: will update the proposal with links to the existing content (bryan_att, 14:14:46)

  1. ODL Summit takeaways (bryan_att, 14:15:07)
    1. ebrjohn I have some feedback based on the conversations on Fri at the OPNFV Hackfest (alagalah, 14:15:57)
    2. ebrjohn: lots of interest in SFC at the summit; I've been invited to speak at OpenStack Tokyo on this (bryan_att, 14:16:18)
    3. ... for the Nov OPNFV Summit also planning sessions and encourage all to be there (bryan_att, 14:17:09)
    4. http://events.linuxfoundation.org/events/opnfv-summit (paulq, 14:17:39)

  2. VNF Manager (bryan_att, 14:18:16)
    1. bryan_att: looked into tacker and other projects, we definitely need to look there and at other projects to assess where OPNFV puts its cards (bryan_att, 14:21:36)
    2. trozet: looked at tacker code and is currently modifying it to call out the SFC APIs, overall looks pretty good (bryan_att, 14:22:19)
    3. ebrjohn: agrees that we need to look to reuse existing code as our base; how extensible is it? (bryan_att, 14:22:57)
    4. trozet: you can write an extension to avoid touching the core code; that's what I'm doing now (bryan_att, 14:23:41)
    5. ebrjohn: when can we have a POC on tacker? (bryan_att, 14:24:11)
    6. drozet: may not be ready by next meeting (bryan_att, 14:25:51)
    7. ACTION: trozet to head up an initial PoC using tacker as a VNF mgr (ebrjohn, 14:26:22)
    8. bryan_att: we may also need murano based upon the evolving function split between these projects, per the tacker IRC logs (bryan_att, 14:26:32)
    9. alagalah: been working on a state machine in slide 11 of the arch draft; knowing when a NF is active is a key concern (bryan_att, 14:27:34)
    10. ... also how/when the classifier gets assigned to the chain is addressed (bryan_att, 14:29:37)
    11. bryan_att: we will look at the other VNFM options and offer a comparison; could be there is some more developed functionality that we could shift between VNFM projects to better flesh out the projects in one place or another (bryan_att, 14:30:38)
    12. ebrjohn: what drives tacker, e.g. conf file or REST etc? (bryan_att, 14:30:59)
    13. trozet: it's REST based; working on adding an ODL driver to complete the chain via SFC (bryan_att, 14:31:44)
    14. ebrjohn: the model should be extensible for our own calls? (bryan_att, 14:32:03)
    15. trozet: yes, currently adding a REST call for SFC functions (bryan_att, 14:32:25)
    16. ... documentation is not so great; currently hacking in prep for a demo; tacker service can be conf'd to turn on additional plugins (bryan_att, 14:33:26)
    17. ... will add links so the rest can come up to speed on hacking tacker (bryan_att, 14:33:49)

  3. State-Machine for SFC Orchestration (bryan_att, 14:34:19)
    1. alagalah: (looking at slide 11 in the OPNFV_SFC_InitialSetup file) (bryan_att, 14:35:21)
    2. https://github.com/trozet/tacker-horizon/tree/SFC (trozet, 14:35:30)
    3. https://github.com/trozet/python-tackerclient/tree/SFC (trozet, 14:35:37)
    4. https://github.com/trozet/tacker/tree/SFC (trozet, 14:35:53)
    5. ... this is showing the ins/outs of the ODL SFC implementation, with the addition of "state" which isn't currently there (bryan_att, 14:36:13)
    6. I have only pushed my changes to tacker-horizon, will push the client and service changes when I get it working (trozet, 14:36:13)
    7. bryan_att: is this the first time that SFC has a notion of state, thus needs clustering to ensure that state knowledge isn't lost? (bryan_att, 14:36:56)
    8. alagalah: conf and operational data stores provide the HA; my team is working on clustering as part of CI testing (CSIT) (bryan_att, 14:38:54)
    9. ... state is managed in the ODL datastore holistically; work in tacker would feed into this to indicate when the SF is really ready (bryan_att, 14:39:31)
    10. git clone ssh://<username>@gerrit.opnfv.org:29418/sfc (ebrjohn, 14:39:58)
    11. ... classifier requests an RSP, has a key role in the flow (bryan_att, 14:40:42)
    12. ... the SFP requests the type of instances needed; if the resources already exist it can down further; otherwise spin up the SFs and go into a pending state until the SFs are ready, and all the SFFs for the SFs are ready (bryan_att, 14:42:12)
    13. ... parallel actions can take place until the SF and SFF are ready, then transition to active; folllowed by the formation of the RSP which is handed back to the classifier and eventualy back to the orchestrator (bryan_att, 14:43:35)
    14. ... introducing dynamics into the mapping is important for reliability, e.g. as SFs go up/down and get added/replaced in the chain (bryan_att, 14:44:48)
    15. ebrjohn: if time, can bring this up in the ODL SFC session tomorrow; some housekeeping to do on ODL project planning but maybe in the last half hour (bryan_att, 14:46:10)
    16. alagalah: have added this to the release plan proposal, along with other things for the release (bryan_att, 14:46:38)
    17. Prakash_: are each of the state diagram actors described somewhere? (bryan_att, 14:47:19)
    18. alagalah: these are existing actors defined in the draft standards, trying to stay true to the concepts in the drafts (bryan_att, 14:48:40)
    19. https://datatracker.ietf.org/wg/sfc/documents/ (bryan_att, 14:49:19)
    20. paulq: involved in the ietf work on this, don't see any conflict (bryan_att, 14:49:54)

  4. Testing (bryan_att, 14:50:37)
    1. trozet: will help (bryan_att, 14:50:49)
    2. bryan_att: will also be supporting this, through the new proposed project and the functest project (bryan_att, 14:52:04)

  5. AOB (bryan_att, 14:52:17)
    1. (none) (bryan_att, 14:52:28)


Meeting ended at 14:52:46 UTC (full logs).

Action items

  1. trozet to head up an initial PoC using tacker as a VNF mgr


Action items, by person

  1. trozet
    1. trozet to head up an initial PoC using tacker as a VNF mgr


People present (lines said)

  1. bryan_att (48)
  2. ebrjohn (9)
  3. trozet (7)
  4. alagalah (5)
  5. collabot (4)
  6. paulq (3)
  7. fbl (1)


Generated by MeetBot 0.1.4.