#opnfv-sfc: weekly opnfv sfc meeting

Meeting started by ebrjohn at 14:59:35 UTC (full logs).

Meeting summary

    1. Brady Johnson (ebrjohn, 15:00:03)
    2. George Paraskevopoulos (geopar, 15:00:09)
    3. Juan Vidal (jvidal, 15:00:09)
    4. Vijayendra Radhakrishna (Vijayendra, 15:00:14)
    5. Madhukesh (Madhukesh, 15:00:14)
    6. Mohankumar (mohankumar, 15:01:00)
    7. Priya (priya_, 15:01:35)
    8. Manuel Buil (mbuil, 15:02:15)

  1. CI stability (ebrjohn, 15:03:51)
    1. in CI tests, the "tackerc" file is not available in the controller (ebrjohn, 15:05:24)
    2. but in normal deployments, the file is indeed there (ebrjohn, 15:05:47)
    3. this is a new "feature" AKA bug (ebrjohn, 15:06:03)
    4. https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/1206/console (geopar, 15:07:10)
    5. in general we are in good shape stability-wise, but there is still room for improvement (ebrjohn, 15:09:41)

  2. symmetric_chain testcase problems, and way forward (Juan) (ebrjohn, 15:09:51)
    1. the problem is in Classifier creation in Tacker, since Tacker classifiers refer to an SFP, not an RSP (ebrjohn, 15:11:34)
    2. the test is working now, since there is only 1 SF, and there is no difference between upstream and downstream (ebrjohn, 15:12:59)
    3. ACTION: ebrjohn Talk to Tim Rozet about implementing a symmetric classifier fix in Master and see how complicated it would be to merge to our version (ebrjohn, 15:17:46)

  3. Milestone 7 preparations (ebrjohn, 15:20:32)
    1. ACTION: jvidal to open a JIRA and put a comment in the code (jvidal, 15:20:36)
    2. https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions (ebrjohn, 15:20:51)
    3. https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 OPNFV Danube schedule (PDF) (ebrjohn, 15:20:53)
    4. OPNFV Danube MS 7 scheduled for March 10 (next Friday) (ebrjohn, 15:21:31)
    5. OPNFV Danube MS 7 motto: Stable branch window closed (AKA code freeze) (ebrjohn, 15:21:32)
    6. OPNFV Danube MS 7 description: Projects are branched from main (ebrjohn, 15:22:09)
    7. OPNFV Danube MS 7 description: Commits are limited to critical issues documented in JIRA (ebrjohn, 15:22:11)
    8. OPNFV Danube MS 7 description: Commits must be cherry-picked to branch from master (ebrjohn, 15:22:12)
    9. I will look into creating the stable branch either this Friday or Monday (ebrjohn, 15:24:20)
    10. jvidal suggests even waiting until Wednesday next week (ebrjohn, 15:24:53)
    11. We have the rest of this week, and next week to finish feature work. (ebrjohn, 15:25:42)
    12. ACTION: mbuil to look into marking the symmetric test case as possibly not working for the release (ebrjohn, 15:33:27)

  4. Overview of current tasks/status (ebrjohn, 15:36:47)
  5. Upcoming OPNFV PlugFest in Paris (ebrjohn, 15:41:01)
    1. https://www.opnfv.org/event/opnfv-plugfest/ OPNFV PlugFest in Paris (ebrjohn, 15:41:11)
    2. The PlugFest will be in Paris April 24 - April 28 (ebrjohn, 15:41:12)
    3. ACTION: ebrjohn to reach out to F5 to see if they will be at the PlugFest and try to schedule an integration with their VNF (ebrjohn, 15:43:12)

  6. Any Other Business (ebrjohn, 15:45:19)
    1. ODL SFC has an API freeze tomorrow, March 2, 2017 (ebrjohn, 15:45:32)
    2. https://wiki.opendaylight.org/view/Service_Function_Chaining:Carbon_Release_Plan ODL SFC Release Plan (ebrjohn, 15:45:51)
    3. I submit a patch in ODL SFC master (Carbon) for Eth+NSH between SFF and SF. (ebrjohn, 15:46:08)
    4. Yi Yang has completed most of the work for SFC to work with VPP, including an VPP-based NSH-Aware SF Proxy (ebrjohn, 15:47:28)
    5. We are working on an ODL Netvirt blueprint for the SFC classifier in the new Netvirt and should start implementation soon (ebrjohn, 15:48:09)


Meeting ended at 15:53:39 UTC (full logs).

Action items

  1. ebrjohn Talk to Tim Rozet about implementing a symmetric classifier fix in Master and see how complicated it would be to merge to our version
  2. jvidal to open a JIRA and put a comment in the code
  3. mbuil to look into marking the symmetric test case as possibly not working for the release
  4. ebrjohn to reach out to F5 to see if they will be at the PlugFest and try to schedule an integration with their VNF


Action items, by person

  1. ebrjohn
    1. ebrjohn Talk to Tim Rozet about implementing a symmetric classifier fix in Master and see how complicated it would be to merge to our version
    2. ebrjohn to reach out to F5 to see if they will be at the PlugFest and try to schedule an integration with their VNF
  2. jvidal
    1. jvidal to open a JIRA and put a comment in the code
  3. mbuil
    1. mbuil to look into marking the symmetric test case as possibly not working for the release


People present (lines said)

  1. ebrjohn (36)
  2. geopar (4)
  3. collabot` (3)
  4. jvidal (2)
  5. Madhukesh (2)
  6. priya_ (2)
  7. Vijayendra (1)
  8. mohankumar (1)
  9. mbuil (1)


Generated by MeetBot 0.1.4.