#opnfv-sfc: Weekly OPNFV SFC meeting

Meeting started by ebrjohn at 14:58:40 UTC (full logs).

Meeting summary

    1. Brady Johnson (ebrjohn, 14:59:01)
    2. Juan Vidal (jvidal, 14:59:04)
    3. Manuel Buil (mbuil, 14:59:29)
    4. priya (priya, 15:00:11)
    5. George Paraskevopoulos (geopar, 15:03:00)
    6. Tim Rozet (trozet, 15:03:00)

  1. Previous action items (ebrjohn, 15:04:38)
    1. ebrjohn Talk to Tim Rozet about implementing a symmetric classifier fix in Master and see how complicated it would be to merge to our version (ebrjohn, 15:04:57)
    2. it should be implemented separately in each branch, since upstream tacker is quite different (ebrjohn, 15:06:33)
    3. AP done (ebrjohn, 15:06:45)
    4. jvidal to open a JIRA and put a comment in the code for symmetric test test case (ebrjohn, 15:07:26)
    5. https://jira.opnfv.org/browse/SFC-86 (jvidal, 15:07:45)
    6. AP done (ebrjohn, 15:07:58)
    7. https://gerrit.opnfv.org/gerrit/#/c/29633/ (jvidal, 15:08:05)
    8. mbuil to look into marking the symmetric test case as possibly not working for the release (ebrjohn, 15:08:28)
    9. AP ongoing (ebrjohn, 15:08:51)
    10. ebrjohn to reach out to F5 to see if they will be at the PlugFest and try to schedule an integration with their VNF (ebrjohn, 15:09:21)
    11. AP done (ebrjohn, 15:09:50)

  2. Solutions found for CI issues (ebrjohn, 15:10:11)
    1. mbuil the solution came from an email from trozet (ebrjohn, 15:11:00)
    2. there is a healthcheck when VMs come up, checking they have an IP, etc. This was not working (ebrjohn, 15:11:25)
    3. OVS was connecting to ODL before ODL was ready (ebrjohn, 15:11:39)
    4. the solution: there's a puppet script that connects OVS to ODL, so add a dependency to the puppet script, so it doesnt execute until after ODL is ready (ebrjohn, 15:14:56)
    5. the solution is in the Fuel ODL plugin (ebrjohn, 15:15:52)
    6. the patch has been merged in Fuel now (ebrjohn, 15:16:36)

  3. Tacker authorization issue solved (ebrjohn, 15:16:48)
    1. the problem authorization was not compatable with V2 keystone (ebrjohn, 15:17:18)
    2. when tacker was changed to use V3 keystone, it wasnt correct (ebrjohn, 15:17:40)
    3. a patch has been submit for this (ebrjohn, 15:17:56)
    4. geopar to check to which Tacker branch to submit the fix (ebrjohn, 15:20:44)
    5. we should be using the Tacker Colorado branch, not the Tacker refactor branch (ebrjohn, 15:21:08)
    6. http://pastebin.com/MmxmZPca (geopar, 15:22:24)
    7. http://pastebin.com/MmxmZPca (geopar, 15:22:41)

  4. Status of the test cases being developed - need to be completed and working by this Friday (ebrjohn, 15:26:58)
    1. geopar is finished with multiple topos test, and the case is working (ebrjohn, 15:28:36)
    2. mbuil is finished with the test case... he wants to first verify the tacker issue (ebrjohn, 15:29:39)
    3. jvidal is finished with the test case - but its only working because everything is on the same compute (ebrjohn, 15:30:14)
    4. a jira has been created for the tacker bug (ebrjohn, 15:30:44)
    5. https://jira.opnfv.org/browse/SFC-86 reports problem with the test (ebrjohn, 15:31:32)
    6. in general we are in good shape with the test cases (ebrjohn, 15:32:31)

  5. Preparations for MS7 this Friday (March 10) (ebrjohn, 15:33:37)
    1. https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions (ebrjohn, 15:33:51)
    2. https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 OPNFV Danube schedule (PDF) (ebrjohn, 15:33:53)
    3. OPNFV Danube MS 7 description: Projects are branched from main (ebrjohn, 15:33:54)
    4. OPNFV Danube MS 7 description: Commits are limited to critical issues documented in JIRA (ebrjohn, 15:33:56)
    5. OPNFV Danube MS 7 description: Commits must be cherry-picked to branch from master (ebrjohn, 15:33:57)
    6. https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions (ebrjohn, 15:34:19)
    7. https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 OPNFV Danube schedule (PDF) (ebrjohn, 15:34:21)
    8. AGREED: There is no rush to create the OPNFV SFC stable Danube branch, so we'll create it on Friday (ebrjohn, 15:37:43)
    9. ACTION: mbuil to tell ebrjohn when he will be ready for the branch to be created, on Friday sometime (ebrjohn, 15:38:23)
    10. ACTION: ebrjohn to create the stable branch on Friday (ebrjohn, 15:38:44)
    11. The stable branch window for Danube opened on February 17 (MS6). The window will close one week from Friday, on March 10 at 12 p.m. (PST). Please plan to branch your project by that date. (jvidal, 15:38:46)
    12. the window for creating the branch is 21:00 GMT+1 (ebrjohn, 15:39:32)
    13. I will most likely create the branch by around lunch time on Friday (ebrjohn, 15:40:13)

  6. AOB (ebrjohn, 15:40:49)
    1. We should be able to start working on the New Netvirt SFC classifier soon. (ebrjohn, 15:41:02)
    2. We'll continue discussing it in today's ODL SFC meeting (ebrjohn, 15:41:04)

  7. problem reported by johscheuer (ebrjohn, 15:48:51)
    1. johscheuer is having problems with tacker keystone authentication (ebrjohn, 15:50:07)
    2. johscheuer cant create a service function chain (ebrjohn, 15:50:22)
    3. there is an error message that it cant find the neutron port (ebrjohn, 15:51:03)


Meeting ended at 15:54:47 UTC (full logs).

Action items

  1. mbuil to tell ebrjohn when he will be ready for the branch to be created, on Friday sometime
  2. ebrjohn to create the stable branch on Friday


Action items, by person

  1. ebrjohn
    1. mbuil to tell ebrjohn when he will be ready for the branch to be created, on Friday sometime
    2. ebrjohn to create the stable branch on Friday
  2. mbuil
    1. mbuil to tell ebrjohn when he will be ready for the branch to be created, on Friday sometime


People present (lines said)

  1. ebrjohn (60)
  2. jvidal (7)
  3. geopar (6)
  4. collabot` (5)
  5. johscheuer (3)
  6. priya (3)
  7. trozet (1)
  8. mbuil (1)


Generated by MeetBot 0.1.4.