#opnfv-sfc: weekly OPNFV SFC meeting, March 22, 2017

Meeting started by ebrjohn at 15:01:40 UTC (full logs).

Meeting summary

    1. Brady Johnson (ebrjohn, 15:01:47)
    2. Juan Vidal (jvidal, 15:01:59)
    3. Manuel Buil (mbuil, 15:02:05)
    4. George Paraskevopoulos (geopar, 15:03:13)

  1. Status of Danube release as discussed yesterday in the TSC and Release meetings (ebrjohn, 15:06:41)
    1. According to David McBride yesterday: "the status of the scenarios is changing hourly" (ebrjohn, 15:08:08)
    2. Morgan Richomme said its way too early to know when the release will be ready (ebrjohn, 15:09:02)
    3. Morgan Richomme said the OPNFV scenarios must complete successfully 4 times consecutively to be accepted (ebrjohn, 15:09:10)
    4. Morgan Richomme also said that currently no (or very few) have completed twice successfully (ebrjohn, 15:09:50)
    5. the TSC and Release responsible will evaluate the status again on Thursday (Tomorrow) (ebrjohn, 15:10:01)
    6. They all agreed that there will most likely be a 1 or 2 week delay (ebrjohn, 15:10:12)
    7. In the release meeting there were complaints that the installers were not ready until this past Thursday (ebrjohn, 15:10:33)
    8. I copmlained that that doesnt give the feature projects enough time to react, and that the projects should have offset milestones (ebrjohn, 15:11:25)
    9. David McBride said the installers are supposed to be ready by MS3, so there are problems with the installers sticking to the milestones (ebrjohn, 15:11:35)

  2. Latest fixes made by the team to stabilize the release (ebrjohn, 15:16:39)
    1. mbuil made fixes to the run_test script since it always returned an error code, and it never returned pass even though the test worked (ebrjohn, 15:17:58)
    2. mbuil figured out that there were alot of Security Groups already created called Default, which affected our tests since they were using a random security group (ebrjohn, 15:18:36)
    3. mbuil says the ARP tables were not being flushed between tests, so subsequent tests used wrong MAC addresses (ebrjohn, 15:19:03)
    4. there should be a cleanup in FuncTest between tests to cleanup existing Security Groups (ebrjohn, 15:20:04)
    5. ACTION: mbuil to create JIRA against FuncTest to cleanup existing Security Groups between tests (ebrjohn, 15:20:53)
    6. https://wiki.opnfv.org/display/sfc/Service+Function+Chaining+Home (jvidal, 15:22:51)
    7. This link is broken: Danube Release Schedule (PDF) (ebrjohn, 15:23:48)
    8. https://wiki.opnfv.org/display/sfc/OPNFV-SFC+Release+Information (ebrjohn, 15:24:06)
    9. geopar has added changes to cleanup the SFC entities after each test (ebrjohn, 15:26:09)

  3. Status of Fuel in CI (ebrjohn, 15:27:33)
    1. Fuel failed today in CI while deploying in stable/danube (ebrjohn, 15:28:29)
    2. this has been fixed in Master, but not in Danube, so there will be no Danube test today (ebrjohn, 15:28:54)
    3. we wont have a Fuel CI job in Danube until tomorrow (ebrjohn, 15:30:17)

  4. Upcoming Milestones (ebrjohn, 15:30:54)
    1. https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions (ebrjohn, 15:31:09)
    2. https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 Danube Milestone planning (PDF) (ebrjohn, 15:31:11)
    3. Milestone 9 is today (March 22) (ebrjohn, 15:31:38)
    4. Milestone 9 description: All JIRA issues assigned to the current release are: Closed --OR-- Deferred to a future release (i.e. update to "fix-version" field) (ebrjohn, 15:31:40)
    5. The question is, does this milestone still apply today?? (ebrjohn, 15:32:13)
    6. ACTION: Everybody update JIRA (ebrjohn, 15:32:28)
    7. lets at least try to keep the JIRAs as updated as possible (ebrjohn, 15:33:14)
    8. Milestone 10 is Friday (March 24) (ebrjohn, 15:35:02)
    9. Milestone 10 description: All project and scenario documentation committed to repo. (ebrjohn, 15:35:03)
    10. Milestone 11 (Danube 1.0) originally planned for Monday (March 27) but it will be delayed (ebrjohn, 15:35:41)

  5. Status of ODL Boron SR3 testing and plans to use this distro. (ebrjohn, 15:36:20)
    1. geopar performed this testing (ebrjohn, 15:36:38)
    2. geopar says SR3 looks better than SR2 since it cleans things better up afterwords (ebrjohn, 15:37:00)
    3. We should move to SR3 in Danube 2.0 (ebrjohn, 15:38:08)

  6. Any other business (ebrjohn, 15:38:45)
    1. plans to start using bifrost installer instead of existing installers (ebrjohn, 15:38:54)
    2. its not really an installer, it just creates a deployment created from bifrost and OpenStack Ansible (ebrjohn, 15:39:44)
    3. When we start getting closer to Euphrates, lets look into switching over to using this instead of the installers (ebrjohn, 15:43:02)
    4. I have closed issues in my name. (Vijayendra, 15:43:44)


Meeting ended at 15:54:50 UTC (full logs).

Action items

  1. mbuil to create JIRA against FuncTest to cleanup existing Security Groups between tests
  2. Everybody update JIRA


Action items, by person

  1. mbuil
    1. mbuil to create JIRA against FuncTest to cleanup existing Security Groups between tests


People present (lines said)

  1. ebrjohn (54)
  2. collabot` (8)
  3. geopar (3)
  4. jvidal (2)
  5. mbuil (2)
  6. OPNFV-Gerrit-Bot (1)
  7. Vijayendra (1)


Generated by MeetBot 0.1.4.