#opnfv-sfc: SFC-week-32

Meeting started by mbuil at 14:01:02 UTC (full logs).

Meeting summary

    1. https://global.gotomeeting.com/join/819733085 (mbuil, 14:01:20)
    2. Brady Johnson (ebrjohn, 14:01:37)
    3. Juan Vidal (jvidal, 14:01:43)
    4. Dimitrios Markou (mardim, 14:02:56)
    5. Manuel Buil (mbuil, 14:04:43)
    6. Bernard Cafarelli (bcafarel, 14:05:03)
    7. Yifei Xue (yifei, 14:07:12)

  1. Euphrates MS5 (mbuil, 14:07:41)
    1. I informed Ray/David that we will not need a exception request for MS5 as apex and compass will have a jenkins job running (mbuil, 14:08:33)
    2. Release Manager wants to see our scenarios created and in CI/CD for MS5 (ebrjohn, 14:10:38)
    3. the scenarios can be failing, but they need to be created in CI (ebrjohn, 14:10:54)
    4. : Euphrates schedule ==> https://wiki.opnfv.org/display/SWREL/Euphrates?preview=/8689511/12388304/OPNFV%20Release%20%2522Euphrates%2522%20r9.pdf (mbuil, 14:11:34)
    5. MS6 is scheduled for August 25th (ebrjohn, 14:12:21)
    6. MS6 : We need to have the test cases implemented (ebrjohn, 14:12:37)

  2. ODL/networking-sfc integration bugs (mbuil, 14:13:31)
    1. Netvirt classifier error is fixed in latest code ==> https://bugs.opendaylight.org/show_bug.cgi?id=8914 (e.g. Nitrogen) (mbuil, 14:13:49)
    2. we are hitting a race condition which is fixed by ==> https://git.opendaylight.org/gerrit/60770 (mbuil, 14:14:49)
    3. ODL Carbon SR2 should be available August 17 (ebrjohn, 14:14:55)
    4. with these 2 bug fixes, Manuel was able to run SFC end-2-end (ebrjohn, 14:16:27)
    5. networking-sfc not working. The translator must be updated to use logical SFF (mbuil, 14:16:46)
    6. ACTION: mbuil creates a bug to fix it (mbuil, 14:17:32)
    7. networking-sfc is extending the API to be more IETF friendly ==> http://docs-draft.openstack.org/68/478668/8/check/gate-networking-sfc-docs-ubuntu-xenial/54800e1//doc/build/html/contributor/ietf_sfc_encapsulation.html (mbuil, 14:18:46)
    8. it will come in OpenStack Queens (mbuil, 14:20:13)

  3. jvidal leaving :( (mbuil, 14:21:13)
    1. jvidal moves to an internal Ericsson project starting next week (mbuil, 14:22:02)
    2. Pending tasks ==> 1 - push for the ODL patch in OSA; 2 - Provide flexibility in OSA to specify the ODL build; 3 - Add specific test for ODL in OSA role (mbuil, 14:24:53)
    3. ACTION: Juan will create the pending tasks in Jira (mbuil, 14:26:02)

  4. NSH will make it into OVS2.8 (mbuil, 14:27:58)
    1. NSH will be supported in OVS 2.8 for DPDK datapath (mbuil, 14:28:22)
    2. Yi Yang is working in ODL Nitrogen to support it. Brady thinks it might be too late because openflow project already hit code freeze. So we will probably have it in ODL oxygen (mbuil, 14:29:33)
    3. NSH support in kernel data path patch: https://patchwork.ozlabs.org/patch/799013/ (bcafarel, 14:32:28)

  5. VPP integration (mbuil, 14:33:32)
    1. Sudden problem appeared while trying to run the SFC demo with VPP (mbuil, 14:33:56)
    2. https://jira.fd.io/browse/HC2VPP-214 (mbuil, 14:34:03)
    3. Dimitris found a bug integrating SFC and GBP. Brady comments that it should be fixed in Nitrogen but Dimitris could not test it yet (mbuil, 14:35:29)

  6. aob (mbuil, 14:36:06)


Meeting ended at 14:43:14 UTC (full logs).

Action items

  1. mbuil creates a bug to fix it
  2. Juan will create the pending tasks in Jira


Action items, by person

  1. mbuil
    1. mbuil creates a bug to fix it


People present (lines said)

  1. mbuil (28)
  2. ebrjohn (11)
  3. collabot (5)
  4. yifei (4)
  5. mardim (2)
  6. bcafarel (2)
  7. jvidal (1)


Generated by MeetBot 0.1.4.