#opnfv-sfc: SFC-week-37

Meeting started by mbuil at 14:01:01 UTC (full logs).

Meeting summary

    1. Brady Johnson (bjohnson, 14:01:28)
    2. Manuel Buil (mbuil, 14:01:37)
    3. Bernard Cafarelli (bcafarel, 14:01:38)
    4. https://global.gotomeeting.com/join/819733085 (mbuil, 14:02:31)
    5. https://global.gotomeeting.com/join/819733085 meeting link (bjohnson, 14:02:31)
    6. Yifei Xue (yifei, 14:03:00)
    7. Vijayendra Radhakrishna (Vijayendra, 14:03:12)

  1. Euphrates MS7 (mbuil, 14:03:35)
    1. This Friday is the MS7. The requirements to comply with it are: 1 - Projects are branched from main; 2 - Commits are limited to critical issues documented in JIRA; 3- Commits must be cherry-picked to branch from master (mbuil, 14:03:48)
    2. Euphrates MS7 Friday, September 15, 2017 (bjohnson, 14:04:08)
    3. We need to contact Aric to create a the stable branch in the next days (mbuil, 14:04:55)
    4. Aric Gardner the Linux Foundation OPNFV Sys Admin will create the Project branches (bjohnson, 14:05:19)
    5. Euphrates MS8 is October 3, 2017 (bjohnson, 14:06:20)
    6. effectively, MS7 is code freeze, so only bug fix changes can go in once we hit MS7 (bjohnson, 14:07:45)

  2. e2e integration issues (mbuil, 14:08:02)
    1. Several bugs in ODL were fixed during last week (mbuil, 14:08:35)
    2. https://git.opendaylight.org/gerrit/#/c/62550/ (mbuil, 14:08:36)
    3. https://git.opendaylight.org/gerrit/#/c/62561/ (mbuil, 14:08:36)
    4. https://git.opendaylight.org/gerrit/#/c/62552/ (mbuil, 14:08:36)
    5. one of these fixes is in sfc, and 2 are in netvirt (bjohnson, 14:09:58)
    6. warning! Those patches are not yet included in RC3. We need to wait for the official release (mbuil, 14:10:09)
    7. We have so far 6 issues (mbuil, 14:13:31)
    8. issue #1 tacker cannot create chains and classifiers separately. That's why we must modify the second test (mbuil, 14:14:47)
    9. the workaround is to create two chains and two classifiers adding a second client and a second server (mbuil, 14:15:12)
    10. there is a current problem in networking-sfc when creating two classifiers because there is a conflict even if they use different neutron ports (mbuil, 14:15:27)
    11. According to the IETF SFC spec, the classifier should not be tightly coupled with the Service Chains, but it seems like the new Tacker has made them tightly coupled. (bjohnson, 14:16:36)
    12. According to the IETF SFC spec, it should be possible to change the classification on-the-fly (bjohnson, 14:17:05)
    13. to fix the networking-sfc ==> https://review.openstack.org/#/c/419525/ but it was abandoned :( (mbuil, 14:19:53)
    14. : This is the related bug ==> https://bugs.launchpad.net/networking-sfc/+bug/1655618 (mbuil, 14:27:25)
    15. https://docs.google.com/presentation/d/1RfoUwL8wzYBRBh1UWR4iZbN_iXaPeD6YwvGoNFH-uLA/edit#slide=id.p13 OPNFV SFC Target Test Case, slide 10 (bjohnson, 14:27:36)
    16. We should be able to have several pre-configured chains, and change the classification on-the-fly (bjohnson, 14:31:48)
    17. ACTION: bcafarel will test if the classification can be updated on the fly in networking-sfc (mbuil, 14:36:07)
    18. Proposed way forward 1) bcafarel to test dynamic classifier changes. If it doesnt work, create a bug on networking SFC in OpenStack (bjohnson, 14:38:23)
    19. if it does work, 2) then we need to focus on getting Tacker fixed. If this takes too long, 3) then we should consider using the VnfMgrSim python tool in the OPNFV SFC repo (bjohnson, 14:39:46)


Meeting ended at 14:42:33 UTC (full logs).

Action items

  1. bcafarel will test if the classification can be updated on the fly in networking-sfc


Action items, by person

  1. bcafarel
    1. bcafarel will test if the classification can be updated on the fly in networking-sfc


People present (lines said)

  1. mbuil (23)
  2. bjohnson (18)
  3. collabot (6)
  4. yifei (3)
  5. Vijayendra (3)
  6. bcafarel (2)


Generated by MeetBot 0.1.4.