#opnfv-testperf: OPNFV Functest

Meeting started by trevor_intel at 12:52:14 UTC (full logs).

Meeting summary

    1. Trevor Cooper (Intel) (trevor_intel, 12:53:05)
    2. morgan (morgan_orange, 12:55:39)
    3. Iben (iben, 12:55:52)
    4. vlaza Victor Laza - from Cloudbase Solutions - will be helping with documentation (iben, 12:56:47)
    5. Peter Bandzi (pbandzi, 13:01:13)
    6. Bryan Sullivan (bryan_att, 13:02:33)

  1. Agenda runthru (bryan_att, 13:05:02)
    1. Trevor: at the RC meeting there wasn't functest representation. An action was given to provide the R1 functest state. Emails showed unclarity on who to contact etc for the project. This call is to help coordinate. (bryan_att, 13:06:22)

  2. 1. Functest leader (bryan_att, 13:06:48)
  3. Agenda runthru (bryan_att, 13:07:26)
    1. Trevor runs thru the rest of the agenda sent via email to the list (bryan_att, 13:08:41)

  4. 1. Functest leader (bryan_att, 13:08:43)
    1. Uli: about the committers - we would like to add a committer from Huawei (bryan_att, 13:09:21)
    2. morgan: anyone should be able to nominate - its just a standard vote process (bryan_att, 13:10:20)
    3. Trevor: just submit and we will vote (bryan_att, 13:11:19)
    4. ... Morgan was nominated by me; does he accept? any other nominations? (bryan_att, 13:11:57)
    5. Morgan: accepts (bryan_att, 13:12:11)
    6. Trevor: any other nominations? (no answer). Majority committer vote is required, offline since we don't have majority here (bryan_att, 13:13:05)
    7. Trevor: if no other nominations for leader, there is no competition and no need for a vote? (presumed) (bryan_att, 13:14:25)
    8. ... We will asseume Morgan is the leader for now (we will verify the election process as needed) (bryan_att, 13:15:11)

  5. 2. RC1 (bryan_att, 13:15:21)
    1. Morgan: we will have 5 test cases per the wiki, automated within the CI (bryan_att, 13:16:16)
    2. https://wiki.opnfv.org/opnfv_functional_testing ? (vlaza, 13:17:08)
    3. ... for R1 this is all that is achievable. Progress is bring made on the 5 test cases (bryan_att, 13:17:08)
    4. https://wiki.opnfv.org/opnfv_functional_testing (trevor_intel, 13:17:43)
    5. https://wiki.opnfv.org/pharos_testing (morgan_orange, 13:17:52)
    6. this wiki page was made to replace the original page so now there are 2 - they need to be merged (iben, 13:18:37)
    7. ACTION: morgan_orange to merge these pages (iben, 13:18:53)
    8. ... will reformat the tests on the Pharos page onto the Functest wiki (bryan_att, 13:18:59)
    9. ... the Functest page will be the single ref for Functest (bryan_att, 13:19:17)
    10. ... re Pharos, it will continue to define the testbed hardware, but not the actual testing (bryan_att, 13:19:57)
    11. trevor_intel is in charge of the pharos project (iben, 13:20:23)
    12. ... need to create a RST file for the repository since that's the R1 product (bryan_att, 13:20:51)
    13. ... the testing info will include the hardware (Pharos), stacks, additional functions being tested (IPv6), etc (bryan_att, 13:21:41)
    14. ... committed the RST file for Functest (bryan_att, 13:22:41)
    15. https://gerrit.opnfv.org/gerrit/#/c/257/ (morgan_orange, 13:23:36)
    16. Trevor: what review needs to be done before commit is done? (bryan_att, 13:23:41)
    17. Morgan: already have support from various people; still working on Intel lab connection; need Jenkins support (bryan_att, 13:24:46)
    18. ... (support from Intel) (bryan_att, 13:24:58)
    19. ... will redo on a local testbed; who can help? (bryan_att, 13:25:39)
    20. Trevor: list who needs to be on a live debug session and will set it up (bryan_att, 13:26:21)
    21. Iben: a number of Jenkins server setups are underway - get together onto #opnfv; Victor is helping the setup process (bryan_att, 13:28:11)
    22. ... i.e. a number of debug sessions are needed (bryan_att, 13:28:47)
    23. https://build.opnfv.org/ci/ (bryan_att, 13:29:39)
    24. Trevor: still need to know who to setup the debug session with (bryan_att, 13:31:36)
    25. Morgan: ask the Intel person to join the IRC channel (bryan_att, 13:32:05)
    26. Trevor: will try but not sure that will help (bryan_att, 13:32:22)
    27. ... I will be the point of contact for now (bryan_att, 13:32:53)

  6. 3. Communication (bryan_att, 13:34:57)
    1. Morgan: IRC channel #testperf, Etherpad (link?), document in the repo (bryan_att, 13:35:40)
    2. https://etherpad.opnfv.org/p/functiontestrelease1activities (trevor_intel, 13:36:01)
    3. ... we should have enough channels to communicate (bryan_att, 13:36:11)
    4. ... will setup a weekly meeting for Functest, IRC only if possible; can report during Thurs meeting (bryan_att, 13:36:52)
    5. Trevor: suggest to use the weekly (Thurs) meeting for Functest update also until release (bryan_att, 13:37:16)
    6. Morgan: it's not clear the diff between the #opnfv channel and the #opnfv-ci channel (bryan_att, 13:38:51)
    7. ... the #opnfv-octopus channel (bryan_att, 13:39:20)

  7. 4. Documentation (bryan_att, 13:39:30)
    1. Morgan: for R1, the RST is the most important; ask for contributors to complete their part; test case descriptions, automation in CI, ... (bryan_att, 13:40:13)
    2. ... we can work on the wiki in the meantime (bryan_att, 13:40:27)
    3. ... sent a proposal for the repo tree for the scripts (bryan_att, 13:40:43)
    4. ... don't need more documents; assume we are using a lot of info from other projects (bryan_att, 13:41:23)
    5. Trevor: is it clear who owns the sections? (bryan_att, 13:42:31)
    6. bryan: it should be in the doc as a placeholder (bryan_att, 13:42:58)
    7. ACTION: Morgan to put contributor info into the RST (bryan_att, 13:43:24)

  8. 5. CI integration (bryan_att, 13:43:34)
    1. Morgan: Intel and Spirent are already connected (bryan_att, 13:43:56)
    2. https://etherpad.opnfv.org/p/octopus (morgan_orange, 13:44:01)
    3. ... the procedure looks pretty clear (bryan_att, 13:44:05)
    4. ... still need the scripts to run tests; but first need to get connectivity (bryan_att, 13:44:54)
    5. ... anyone from CI on the bridge/IRC? (bryan_att, 13:45:42)
    6. ... any testing already integrated into CI? (bryan_att, 13:45:53)
    7. We haven't integrated any testing in CI (fdegir, 13:46:10)
    8. Uli: no auto integration yet (bryan_att, 13:46:16)
    9. bryan: is the install a blocking issue for getting the scripts updated? (bryan_att, 13:47:32)
    10. Morgan: we can write scripts to run the tests; we don't have to wait (bryan_att, 13:49:38)

  9. 6. Testing (bryan_att, 13:50:08)
    1. Morgan: new test case is vPing (bryan_att, 13:50:25)
    2. malla: connected two machines in the POD for the ping test (bryan_att, 13:51:10)
    3. ... just doing local testing for now (bryan_att, 13:51:31)
    4. Trevor: any issues still creating VMs? (bryan_att, 13:51:46)
    5. malla: still an issue, working on it (bryan_att, 13:51:56)
    6. Trevor: need help or Intel POD support? (bryan_att, 13:52:06)
    7. malla: yes; will contact Morgan (bryan_att, 13:52:18)
    8. Morgan: the installation is not complete, the config of OpenStack is likely blocking VM creation; need to discuss with BGS people (bryan_att, 13:53:33)
    9. ... had to load a CentOS image (the ones there were private) etc (bryan_att, 13:54:01)
    10. ... the lab is pre-release based upon the Foreman installer (bryan_att, 13:54:32)
    11. ... still some config work to do; to be sure we are not trying to test with blocking issues (bryan_att, 13:54:58)
    12. bryan: who knows how to verify that the config is right; we need to document those steps (bryan_att, 13:57:21)
    13. ... then firgure out a way to automate it (bryan_att, 13:57:52)
    14. Trevor: for work on R1, POD2 assumes manual steps relative to Foreman; is Functest only supporting Foreman? (bryan_att, 13:58:29)
    15. Morgan: should support any installer (bryan_att, 13:58:45)
    16. Trevor: but with 2 weeks left; is anyone doing that for Fuel, now? (bryan_att, 13:59:05)
    17. Morgan: don't think so, all focus is on one installer; difficult to do this in parallel (bryan_att, 13:59:27)
    18. ... goal is to test using Fuel on the Ericsson POD; the challenge is to get it working in one case first (bryan_att, 13:59:55)
    19. ... in Fuel, Tempest and Rally are integrated; we need to pull that out of the installer (bryan_att, 14:00:25)
    20. ... vIMS, ODL, vPING should be testable using Fuel (bryan_att, 14:00:49)

  10. 7. vIMS test suite progress (bryan_att, 14:01:01)
    1. Martin: blocked by inability to bring up VMs on the POD2 platform (bryan_att, 14:01:21)
    2. ... working to debug the OpenStack installation left by the Foreman installer; appears incomplete/misonfigured (bryan_att, 14:01:48)
    3. ... need to feed that back to BGS (bryan_att, 14:02:05)
    4. Morgan: if we are blocked, should we pause on the Ericsson POD? (bryan_att, 14:03:04)
    5. (corrected) should work on the Ericsson / Fuel POD in the meantime since we have a block on the Intel POD (bryan_att, 14:04:32)
    6. Trevor: need to coordinate with who is using the Ericsson POD (bryan_att, 14:04:58)
    7. Morgan: will reach out to (Fatih Degirmenci) and Jonas Bjurel can be contacted regarding Ericsson POD (bryan_att, 14:06:20)
    8. Need to get back to BGS (Foreman) for starting point to beable to spin up VMs (trevor_intel, 14:08:48)
    9. continue on Thursday test and performacne meeting (trevor_intel, 14:09:25)


Meeting ended at 14:09:37 UTC (full logs).

Action items

  1. morgan_orange to merge these pages
  2. Morgan to put contributor info into the RST


Action items, by person

  1. morgan_orange
    1. morgan_orange to merge these pages


People present (lines said)

  1. bryan_att (99)
  2. iben (31)
  3. trevor_intel (12)
  4. morgan_orange (10)
  5. fdegir (10)
  6. vlaza (8)
  7. collabot (5)
  8. fuqiao (3)
  9. Malla (3)
  10. pbandzi (2)
  11. ulik (2)
  12. boss_mc (1)
  13. icbts (1)
  14. Chitti (1)


Generated by MeetBot 0.1.4.