#opnfv-testperf: Functest weekly meeting November 17th

Meeting started by morgan_orange at 10:02:36 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 10:02:41)

  1. OPNFV Summit report (morgan_orange, 10:08:59)
    1. several presentations performed during the Summit (morgan_orange, 10:09:09)
    2. good exchanges with other test projects, synchro on the test strategy for Brahmaputra (morgan_orange, 10:09:40)
    3. https://wiki.opnfv.org/brahmaputra_testing_page (morgan_orange, 10:09:53)
    4. For B-Release Functest shall be run on 4 labs corresponding to the 4 installers (labs identified), including several possible configurations (controllers) (morgan_orange, 10:10:45)
    5. ACTION: morgan_orange upadte functest B-Release page to precise dependencies towards feature projects (morgan_orange, 10:11:11)
    6. Copper => possible new Rally and test (for congress) (morgan_orange, 10:11:36)
    7. Doctor wait for Doctor suite - Doctor does everything, Functest could just help to generalize the tests on the different labs (morgan_orange, 10:12:07)
    8. ONOS suite to be provided by Qinglong (morgan_orange, 10:13:01)
    9. OVNO wait for suite from Stuart (morgan_orange, 10:13:15)
    10. PolicyTest => meeting with Keith on friday to integrate these tests (ODL suites) + extend ODL test suites (morgan_orange, 10:13:41)
    11. Promise => to be clarified with Peter (action atken in Promise) (morgan_orange, 10:14:23)
    12. the identified lab for B-release as mentioned in the wiki page: Fuel/LF POD 2, Joid/Intel POD 5, Apex/Intel POD2, Compass/Huawei (morgan_orange, 10:15:07)

  2. Preparation Friday Meeting on ODL test case extension (morgan_orange, 10:16:29)
    1. goal see how to import new upstream test suites from ODL (integration + Policy Test) (morgan_orange, 10:16:50)
    2. ACTION: pbandzi update the dedicated wiki page https://wiki.opnfv.org/odl_new_test_suites (morgan_orange, 10:17:10)
    3. ACTION: pbandzi need to update current suite to be able to integrate the new tests (morgan_orange, 10:17:29)

  3. ONOS status (morgan_orange, 10:17:40)
    1. ACTION: Qinglong provide update to the project (lots of pending Jira of Sprint #2) (morgan_orange, 10:18:42)

  4. tempest smoke suite: target 0 error? (morgan_orange, 10:18:55)
    1. Juha Kosonen (juhak, 10:19:12)
    2. 9 errors on the last tempest Run on LF POD2 (morgan_orange, 10:30:15)
    3. more errors on Nokia internal POD (40 errors on smoke tests) (morgan_orange, 10:30:29)
    4. ACTION: morgan_orange setup Functest on Orange Pod (morgan_orange, 10:30:43)
    5. ACTION: morgan_orange grant access to Orange Pod to viktor_nokia and juhak (morgan_orange, 10:31:09)
    6. ACTION: viktor_nokia check LF POD2 tempest error to discuss next week (morgan_orange, 10:31:46)

  5. B-Release Sprint #2 status / start of Sprint #3 (morgan_orange, 10:32:07)
    1. Jira Sprint #2 finished last week (morgan_orange, 10:32:22)
    2. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 10:33:21)
    3. proposition to ruin Sprint #3, old Jiras moved from Sprint #2 to Sprint #3 + new ones linked to feature tests (morgan_orange, 10:34:28)
    4. refactoring of Sprint, Sprint 3 = jira remaining sprint 2, all tasks related to feature tests postponed to Sprint 4 (morgan_orange, 10:37:17)
    5. ACTION: morgan_orange update Jira (morgan_orange, 10:37:21)

  6. AoB (morgan_orange, 10:37:35)
    1. slides used during the Summit (morgan_orange, 10:38:39)
    2. http://events.linuxfoundation.org/sites/events/files/slides/Functest%20in%20Depth_0.pdf (morgan_orange, 10:38:41)
    3. http://events.linuxfoundation.org/sites/events/files/slides/Dashboard%20Summit.pdf (morgan_orange, 10:39:19)
    4. http://events.linuxfoundation.org/events/opnfv-summit/program/slides (morgan_orange, 10:39:28)
    5. people from cloudify met during the summit (as cloudify is used for vIMS test case) (morgan_orange, 10:40:00)
    6. testcase is now properly running (morgan_orange, 10:40:10)
    7. http://213.77.62.197/results?case=vIMS (morgan_orange, 10:40:18)
    8. Nokia lab is proceeding (morgan_orange, 10:40:29)
    9. discussion on how we could represent Functest result in a synthetic way for the landing page of the testing dashboard (morgan_orange, 10:45:08)
    10. ACTION: everybody prepare discussions next week on this topic (morgan_orange, 10:45:52)


Meeting ended at 10:47:16 UTC (full logs).

Action items

  1. morgan_orange upadte functest B-Release page to precise dependencies towards feature projects
  2. pbandzi update the dedicated wiki page https://wiki.opnfv.org/odl_new_test_suites
  3. pbandzi need to update current suite to be able to integrate the new tests
  4. Qinglong provide update to the project (lots of pending Jira of Sprint #2)
  5. morgan_orange setup Functest on Orange Pod
  6. morgan_orange grant access to Orange Pod to viktor_nokia and juhak
  7. viktor_nokia check LF POD2 tempest error to discuss next week
  8. morgan_orange update Jira
  9. everybody prepare discussions next week on this topic


Action items, by person

  1. juhak
    1. morgan_orange grant access to Orange Pod to viktor_nokia and juhak
  2. morgan_orange
    1. morgan_orange upadte functest B-Release page to precise dependencies towards feature projects
    2. morgan_orange setup Functest on Orange Pod
    3. morgan_orange grant access to Orange Pod to viktor_nokia and juhak
    4. morgan_orange update Jira
  3. viktor_nokia
    1. morgan_orange grant access to Orange Pod to viktor_nokia and juhak
    2. viktor_nokia check LF POD2 tempest error to discuss next week
  4. UNASSIGNED
    1. pbandzi update the dedicated wiki page https://wiki.opnfv.org/odl_new_test_suites
    2. pbandzi need to update current suite to be able to integrate the new tests
    3. Qinglong provide update to the project (lots of pending Jira of Sprint #2)
    4. everybody prepare discussions next week on this topic


People present (lines said)

  1. morgan_orange (94)
  2. viktor_nokia (12)
  3. collabot` (4)
  4. fdegir (3)
  5. boris-42 (3)
  6. juhak (1)


Generated by MeetBot 0.1.4.