#opnfv-testperf: Functes/ODL test scope extension November 20th

Meeting started by morgan_orange at 16:00:11 UTC (full logs).

Meeting summary

    1. https://jira.opnfv.org/browse/ONOSFW-141 (jose_lausuch, 16:00:12)
    2. Morgan Richomme (morgan_orange, 16:00:18)
    3. Jose Lausuch (jose_lausuch, 16:00:40)
    4. https://etherpad.opnfv.org/p/functiontest (morgan_orange, 16:05:43)
    5. the goal is to discuss on the extensions of ODL test scope in Functest (morgan_orange, 16:06:01)
    6. for the moment we have basic tests (create/update/delete port/network/subnet) (morgan_orange, 16:06:23)
    7. ODL team has created lots of integration tests (morgan_orange, 16:06:38)
    8. the idea is to include the most significant one into Functest (morgan_orange, 16:06:52)
    9. https://wiki.opnfv.org/odl_new_test_suites (morgan_orange, 16:07:06)
    10. pbandzi started looking at the topic (morgan_orange, 16:07:21)
    11. https://etherpad.opnfv.org/p/functiontest (morgan_orange, 16:07:35)
    12. amaged__ (morgan_orange, 16:09:51)
    13. no real criteria (so far) to move a test from ODL to Functest in OPNFV (morgan_orange, 16:10:15)
    14. but no need to import internal tests, we shall considered ODL as part of the wholution and priviledge End to End tests (morgan_orange, 16:10:41)
    15. mininet may be required (not installed currently when running ODL tests) (morgan_orange, 16:11:28)
    16. Robot already used to run the basic tests (morgan_orange, 16:11:37)
    17. question amaged__: do we want to put priority to a group of functions ? or just leave it open to the submitters to add what they want (morgan_orange, 16:15:58)
    18. too short to define procedure to easily import tests from ODL in an open way, but we should keep it mind for next steps (morgan_orange, 16:16:38)
    19. question mininet on jumphost or compute (morgan_orange, 16:18:33)
    20. everything we need either in docker file or compute (morgan_orange, 16:18:48)
    21. not in jumphost (morgan_orange, 16:18:54)
    22. let's vote next tuesday :) (morgan_orange, 16:19:13)
    23. we created companion project (morgan_orange, 16:19:48)
    24. SFC / yardstick (morgan_orange, 16:19:52)
    25. GBP / Functest (morgan_orange, 16:20:00)
    26. it is true that we should develop something to track it otherwise risk to be lost or to overlap (morgan_orange, 16:20:22)
    27. ACTION: amaged__ help peter to find significant test cases for B release to be added into Functest (morgan_orange, 16:24:42)
    28. https://wiki.opnfv.org/odl_new_test_suites wiki page used to track /add testcases (morgan_orange, 16:26:24)
    29. or directly in Jira backlog (morgan_orange, 16:26:29)
    30. next meeting Functest weekly, we will keep some time for ODL discussions (morgan_orange, 16:30:26)


Meeting ended at 16:30:29 UTC (full logs).

Action items

  1. amaged__ help peter to find significant test cases for B release to be added into Functest


Action items, by person

  1. amaged__
    1. amaged__ help peter to find significant test cases for B release to be added into Functest


People present (lines said)

  1. morgan_orange (79)
  2. jose_lausuch (43)
  3. amaged__ (10)
  4. collabot` (3)
  5. mbeierl (3)


Generated by MeetBot 0.1.4.