#opnfv-testperf: Functest weekly meeting May 31th

Meeting started by morgan_orange at 08:01:23 UTC (full logs).

Meeting summary

  1. call roll (morgan_orange, 08:01:40)
    1. lhinds (lhinds, 08:01:40)
    2. Morgan Richomme (morgan_orange, 08:01:44)
    3. Juha Haapavirta (JuhaHaapa, 08:01:48)
    4. Juha Kosonen (juhak, 08:01:49)
    5. Viktor Tikkanen (viktor_nokia, 08:01:52)
    6. agenda: https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:52)
    7. Jose Lausuch (jose_lausuch, 08:01:57)

  2. action points follow-up (morgan_orange, 08:01:57)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-05-24-08.00.html (morgan_orange, 08:02:01)
    2. AP1: refactoring Testcase.yaml done (morgan_orange, 08:02:18)
    3. AP2: group Rally full and Tempest full in 1 Tier done (morgan_orange, 08:02:33)
    4. AP3 integration of success criteria directly in testcases.yaml (morgan_orange, 08:03:01)
    5. rather than hardcoded in the code of the test cases (morgan_orange, 08:03:18)
    6. AP4 add security_scan in DB and in testcase.yaml done (morgan_orange, 08:05:33)
    7. AP5 add start/stop fields in API: done on refactored API (not in testresults.opnfv.org yet) but hopefully before the ned of the week (Serena did a great job) (morgan_orange, 08:06:35)
    8. AP6 add filter param for API: not done yet (morgan_orange, 08:07:00)
    9. AP7: add type, also ready for next version of the API (morgan_orange, 08:07:17)

  3. Sprint #8 follow-up (morgan_orange, 08:07:42)
    1. First run on Master for Apex (morgan_orange, 08:08:03)
    2. Functest jenkins dashboard refactored (thanks to May-meimei) (morgan_orange, 08:08:27)
    3. https://build.opnfv.org/ci/view/functest/ (morgan_orange, 08:08:36)
    4. ACTION: morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs (morgan_orange, 08:12:31)
    5. fist compass/ocl also integrated (morgan_orange, 08:13:12)
    6. ACTION: ollivier look at ODL results on Apex/Master scenario (morgan_orange, 08:18:06)
    7. ACTION: juhak see the reasons of the 95% on rally (morgan_orange, 08:18:23)
    8. Rally errors analyzed, 2 jora created (morgan_orange, 08:22:31)
    9. https://jira.opnfv.org/browse/APEX-161 (morgan_orange, 08:22:51)
    10. https://jira.opnfv.org/browse/APEX-147 (morgan_orange, 08:22:58)
    11. ACTION: May-meimei have a look why gsutils not installed on CI POD Intel POD6 (morgan_orange, 08:27:00)
    12. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&view=planning.nodetail (morgan_orange, 08:29:25)

  4. Berlin Summit (morgan_orange, 08:41:03)
    1. pres Berlin under review, contributions welcome (morgan_orange, 08:43:06)
    2. we will probably needs several breakout sessions (morgan_orange, 08:43:16)
    3. one on D river already.... (morgan_orange, 08:43:24)
    4. one for integration, several feature projects will be there, the design summit would be convenient to work on integration (morgan_orange, 08:43:48)
    5. https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Planning (morgan_orange, 08:44:23)

  5. Test conditions definition in testcase.yaml (morgan_orange, 08:46:48)
    1. already mentioned in the introduction (morgan_orange, 08:46:54)

  6. Functest test coverage Map (morgan_orange, 08:47:25)
    1. https://wiki.opnfv.org/display/functest/Testing+Coverage (morgan_orange, 08:49:22)
    2. for testing coverage a long long time ago we suggested 3 representations Domain/Component/ETSI (morgan_orange, 08:49:46)
    3. ACTION: all contribute to domain page (morgan_orange, 08:50:19)

  7. Functest / ETSI TST group (morgan_orange, 08:50:53)
    1. ACTION: all contact ETSI colleague to get feedback on the opportunity to formalize Functest for ETSI /TST (morgan_orange, 08:54:20)

  8. AoB (morgan_orange, 08:55:35)
    1. thanks to SerenaFeng, the API is almost fully (and nicely) refactored => need to share it with the community in Berlin (morgan_orange, 08:56:17)
    2. target put it in testresults.opnfv.org before the end of the week (morgan_orange, 08:56:37)
    3. question on Kibana dashboard update (no feedback from juraj) (morgan_orange, 09:02:23)
    4. https://git.opnfv.org/cgit/releng/tree/utils/test/scripts (morgan_orange, 09:03:45)
    5. ACTION: morgan_orange grant access to testresults.opnfv.org to SerenaFeng (morgan_orange, 09:05:33)


Meeting ended at 09:05:56 UTC (full logs).

Action items

  1. morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs
  2. ollivier look at ODL results on Apex/Master scenario
  3. juhak see the reasons of the 95% on rally
  4. May-meimei have a look why gsutils not installed on CI POD Intel POD6
  5. all contribute to domain page
  6. all contact ETSI colleague to get feedback on the opportunity to formalize Functest for ETSI /TST
  7. morgan_orange grant access to testresults.opnfv.org to SerenaFeng


Action items, by person

  1. jose_lausuch
    1. morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs
  2. juhak
    1. morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs
    2. juhak see the reasons of the 95% on rally
  3. May-meimei
    1. May-meimei have a look why gsutils not installed on CI POD Intel POD6
  4. morgan_orange
    1. morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs
    2. morgan_orange grant access to testresults.opnfv.org to SerenaFeng
  5. SerenaFeng
    1. morgan_orange grant access to testresults.opnfv.org to SerenaFeng
  6. viktor_nokia
    1. morgan_orange jose_lausuch viktor_nokia juhak have a look at first Apex Master logs
  7. UNASSIGNED
    1. ollivier look at ODL results on Apex/Master scenario
    2. all contribute to domain page
    3. all contact ETSI colleague to get feedback on the opportunity to formalize Functest for ETSI /TST


People present (lines said)

  1. morgan_orange (170)
  2. jose_lausuch (85)
  3. viktor_nokia (13)
  4. lhinds (12)
  5. SerenaFeng (10)
  6. juhak (8)
  7. JuhaHaapa (6)
  8. May-meimei (3)
  9. collabot` (3)
  10. fdegir (2)


Generated by MeetBot 0.1.4.