#opnfv-testperf: Testing group weekly meeting January 5th

Meeting started by morgan_orange at 15:00:14 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:00:38)
    1. Morgan Richomme (morgan_orange, 15:01:01)
    2. kubi (kubi001, 15:01:09)
    3. HelenYao (HelenYao_, 15:01:23)
    4. Trevor Cooper (trevor_intel, 15:01:26)
    5. Yujun Zhang (yujunz, 15:01:27)
    6. Larry Lamers (ljlamers, 15:01:46)
    7. agenda : https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 15:02:02)
    8. Rex (Mingjiang, 15:02:03)
    9. LeoWang (leo_wang_, 15:02:09)

  2. action point follow-up (morgan_orange, 15:02:14)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-12-15-15.00.html (morgan_orange, 15:02:23)
    2. yuyang_ plan a Bottleneck update for the testing community beginning of January => done (morgan_orange, 15:02:34)
    3. Mark Beierl (mbeierl, 15:02:36)
    4. trevor_intel create an etherpad page on stress test: with short term view (Danube) and longer view (stress test strategy) => done (morgan_orange, 15:02:55)
    5. morgan_orange cretae a page for vnfOnBoarding for testing => done (morgan_orange, 15:03:09)
    6. https://wiki.opnfv.org/pages/viewpage.action?pageId=8687767 (morgan_orange, 15:03:18)

  3. Process of Testperf Ecosystem Diagram Modification (morgan_orange, 15:04:32)
    1. https://wiki.opnfv.org/display/testing (morgan_orange, 15:04:44)
    2. https://global.gotomeeting.com/join/305553637 (mbeierl, 15:06:23)
    3. Jack (JackChan, 15:06:27)
    4. will come back on diag topic once everybody is connected (morgan_orange, 15:07:43)

  4. A new test case development plan (morgan_orange, 15:08:04)
    1. https://wiki.opnfv.org/display/meetings/TestPerf?preview=/2926539/8688394/test_case_development_plan.pptx (morgan_orange, 15:08:18)
    2. linked to Dovetail project whose goal: define and provide a set of OPNFV related validation criteria (morgan_orange, 15:09:45)
    3. Functest is running Tempest since Arno. In the default smoke suite list there are currently 165 cases by default (that can be extended if needed) for tempest.api.network => I count more than 50 tests (morgan_orange, 15:21:13)

  5. back to Process of Testperf Ecosystem Diagram Modification (morgan_orange, 15:36:54)
    1. yujunz show the new version of the diagram (qtip externalized) (morgan_orange, 15:37:12)
    2. moving QTIP out of qualification testing to another box benchmark (yujunz, 15:38:13)
    3. trevor_intel reminds that one the main goal of the initial graph was to avoid duplication/overlap in domains/tooling (morgan_orange, 15:40:30)
    4. show the relationship as a vision accross the test projects (morgan_orange, 15:40:45)
    5. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-January/014310.html (yujunz, 15:41:38)
    6. test projects are still very independent (vsperf versus yardstick) (morgan_orange, 15:41:55)
    7. ACTION: trevor_intel suggest an evolution of the graph in order to stick to the reality as close as possible (remove cperf?, change connections to identify standalone/interactions between project, which project exposes what to who,...) (morgan_orange, 15:48:42)
    8. kubi001 mentions a risk to get fragmentation, multiplication of domains (morgan_orange, 15:49:43)

  6. Review Danube priorities (morgan_orange, 15:50:30)
    1. ACTION: averybody review mail sent yesterday (morgan_orange, 15:52:15)

  7. Update on stress testing (morgan_orange, 15:52:24)
    1. https://etherpad.opnfv.org/p/DanubeStressTest (trevor_intel, 15:52:39)
    2. 3 scenarios proposed in the etherpad (morgan_orange, 15:53:32)
    3. a user of the platform shall be able to run (morgan_orange, 15:53:56)
    4. it shall be simple (morgan_orange, 15:54:01)
    5. basic level of performance (morgan_orange, 15:54:14)
    6. first test to try to break the system (experimental) (morgan_orange, 15:54:36)
    7. still one week to review the different high level proposal (morgan_orange, 15:58:51)
    8. ACTION: kubi001 make synthesis of the proposal for week 4 (morgan_orange, 15:59:43)

  8. Bottlenecks & Yardstick update (morgan_orange, 16:01:13)
    1. postponed to next week (morgan_orange, 16:01:29)

  9. AoB (morgan_orange, 16:01:40)
    1. Reminder: APAC slot next week (mbeierl, 16:02:58)
    2. ACTION: mbeierl summary on discussion on unit tests (best practices, recommendations,..) + presentation on week 3 (morgan_orange, 16:03:03)


Meeting ended at 16:03:13 UTC (full logs).

Action items

  1. trevor_intel suggest an evolution of the graph in order to stick to the reality as close as possible (remove cperf?, change connections to identify standalone/interactions between project, which project exposes what to who,...)
  2. averybody review mail sent yesterday
  3. kubi001 make synthesis of the proposal for week 4
  4. mbeierl summary on discussion on unit tests (best practices, recommendations,..) + presentation on week 3


Action items, by person

  1. kubi001
    1. kubi001 make synthesis of the proposal for week 4
  2. mbeierl
    1. mbeierl summary on discussion on unit tests (best practices, recommendations,..) + presentation on week 3
  3. trevor_intel
    1. trevor_intel suggest an evolution of the graph in order to stick to the reality as close as possible (remove cperf?, change connections to identify standalone/interactions between project, which project exposes what to who,...)


People present (lines said)

  1. morgan_orange (41)
  2. yujunz (8)
  3. collabot (4)
  4. mbeierl (3)
  5. trevor_intel (2)
  6. Mingjiang (1)
  7. leo_wang_ (1)
  8. kubi001 (1)
  9. JackChan (1)
  10. ljlamers (1)
  11. HelenYao_ (1)


Generated by MeetBot 0.1.4.