#opnfv-testperf: Test community weekly meeting March 23rd

Meeting started by morgan_orange at 15:00:02 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:00:05)
    1. Morgan Richomme (morgan_orange, 15:00:12)
    2. Uli Kleber (uli-k, 15:00:17)
    3. Jose Lausuch (jose_lausuch, 15:00:32)
    4. agenda https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 15:00:42)
    5. https://global.gotomeeting.com/join/305553637 (jose_lausuch, 15:00:49)
    6. Yujun Zhang (yujunz, 15:01:00)
    7. jose_lausuch would like to discuss the status of k8 scenario (no tools and tests today) (morgan_orange, 15:02:48)

  2. action point follow up (morgan_orange, 15:03:10)
    1. AP1: morgan_orange ask jmorgan1 on an api to get infra resources (morgan_orange, 15:03:27)
    2. jack answered during the session, API will be available (morgan_orange, 15:03:40)
    3. AP2: trevor plan a slot during the hackfest to discuss this topic (morgan_orange, 15:03:51)
    4. done (morgan_orange, 15:03:59)
    5. AP3 trevor : plan sessions on stress test strategy during the plugfest (morgan_orange, 15:04:07)
    6. done (morgan_orange, 15:04:10)
    7. https://wiki.opnfv.org/pages/viewpage.action?pageId=9569132 (morgan_orange, 15:04:32)
    8. AP4 MANO Testing (Prakash & Bryan) (morgan_orange, 15:04:59)
    9. done (morgan_orange, 15:05:00)
    10. AP5 trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3 (morgan_orange, 15:05:09)
    11. Trevor Cooper (trevor_intel, 15:05:11)
    12. see next topic (morgan_orange, 15:05:16)
    13. AP6 morgan_orange slot next week to select the top 3 (morgan_orange, 15:05:26)
    14. done (morgan_orange, 15:05:28)

  3. CFP Beijing (morgan_orange, 15:05:40)
    1. https://etherpad.opnfv.org/p/TestCommunitySummit (morgan_orange, 15:05:49)
    2. kubi (IRC only) (kubi001, 15:06:15)
    3. suggestion to submit #2, i.e meeting with the community through a Panel (morgan_orange, 15:10:04)
    4. Rex (Mingjiang5, 15:10:48)
    5. David McBride (dmcbride, 15:13:03)
    6. Ross Brattain (rbbratta, 15:13:50)
    7. ACTION: jose_lausuch => proposal on hands on testing / Design Summit / tutorial (morgan_orange, 15:32:13)
    8. ACTION: morgan_orange => proposal meeting the testing community / Design summit / panel (morgan_orange, 15:32:37)
    9. ACTION: yujunz How do we consume the tests / Design or standard session (morgan_orange, 15:33:01)
    10. ACTION: trevor_intel Plugfest - stress test strategy / design or standard session (morgan_orange, 15:33:19)
    11. ACTION: jose_lausuch => proposal upstream and Xcollaoration / design summit (morgan_orange, 15:33:37)
    12. ACTION: dmcbride Testing and milestones alignment / CI challenges / Features + Installer + CI + testing equation /  panel / design summit  (morgan_orange, 15:34:03)
    13. ACTION: morgan_orange challenge / micro service approach how to consumme API /Design summit (morgan_orange, 15:34:23)
    14. ACTION: nikolas jose_lausuch Testing and CI gating / Design Summit (morgan_orange, 15:34:45)

  4. plugfest (morgan_orange, 15:34:49)
    1. https://wiki.opnfv.org/pages/viewpage.action?pageId=9569132 (morgan_orange, 15:35:27)
    2. several topics suggested for the plugfest (morgan_orange, 15:35:35)
    3. follow-up with previous discussion done in Plugfest #2 (morgan_orange, 15:36:10)

  5. Scenario descriptor and test list (morgan_orange, 15:45:15)
    1. https://gerrit.opnfv.org/gerrit/#/c/30677/ (morgan_orange, 15:45:44)
    2. discussion on the scenario descriptor (morgan_orange, 15:54:37)
    3. suggestion remove reference to tests as they could be dynamically retrieved through the test api based on the scenario name (morgan_orange, 15:54:56)
    4. using the test api allows to get a custom list of tests, results, trust indication from all the test projects (morgan_orange, 15:55:22)
    5. http://testresults.opnfv.org/test/api/v1/scenarios?name=os-fake-ha (morgan_orange, 15:57:19)

  6. AoB (morgan_orange, 15:58:13)
    1. discussion on the k8 scenarios (morgan_orange, 15:58:22)
    2. no tests associated with the scenario (morgan_orange, 15:58:30)
    3. testing group cannot give a "testing" green light (morgan_orange, 15:58:47)
    4. tests shall be planned by scenario owner (test project could be contacted) (morgan_orange, 15:59:04)
    5. suggestion declare scenario as experimental (i.e. no testing evidence in this case) (morgan_orange, 15:59:30)
    6. always interesting to have experimental scenarios (morgan_orange, 16:00:22)
    7. ACTION: dmcbride bring discussion to be done at the TSC (morgan_orange, 16:00:29)


Meeting ended at 16:06:46 UTC (full logs).

Action items

  1. jose_lausuch => proposal on hands on testing / Design Summit / tutorial
  2. morgan_orange => proposal meeting the testing community / Design summit / panel
  3. yujunz How do we consume the tests / Design or standard session
  4. trevor_intel Plugfest - stress test strategy / design or standard session
  5. jose_lausuch => proposal upstream and Xcollaoration / design summit
  6. dmcbride Testing and milestones alignment / CI challenges / Features + Installer + CI + testing equation /  panel / design summit 
  7. morgan_orange challenge / micro service approach how to consumme API /Design summit
  8. nikolas jose_lausuch Testing and CI gating / Design Summit
  9. dmcbride bring discussion to be done at the TSC


Action items, by person

  1. dmcbride
    1. dmcbride Testing and milestones alignment / CI challenges / Features + Installer + CI + testing equation /  panel / design summit 
    2. dmcbride bring discussion to be done at the TSC
  2. jose_lausuch
    1. jose_lausuch => proposal on hands on testing / Design Summit / tutorial
    2. jose_lausuch => proposal upstream and Xcollaoration / design summit
    3. nikolas jose_lausuch Testing and CI gating / Design Summit
  3. morgan_orange
    1. morgan_orange => proposal meeting the testing community / Design summit / panel
    2. morgan_orange challenge / micro service approach how to consumme API /Design summit
  4. trevor_intel
    1. trevor_intel Plugfest - stress test strategy / design or standard session
  5. yujunz
    1. yujunz How do we consume the tests / Design or standard session


People present (lines said)

  1. morgan_orange (51)
  2. uli-k (6)
  3. collabot` (4)
  4. jose_lausuch (4)
  5. dmcbride (4)
  6. trevor_intel (1)
  7. Mingjiang5 (1)
  8. rbbratta (1)
  9. kubi001 (1)
  10. yujunz (1)
  11. gabriel_yuyang (0)


Generated by MeetBot 0.1.4.