#opnfv-testperf: Test Working Group

Meeting started by mbeierl at 15:09:47 UTC (full logs).

Meeting summary

    1. https://www.linkedin.com/feed/update/urn:li:activity:6459462227706540032/ (acm, 15:10:15)
    2. Al Morton (acm, 15:13:02)
    3. Mark Beierl (mbeierl, 15:13:14)
    4. https://wiki.opnfv.org/display/meetings/Test+Working+Group+Weekly+Meeting for signing up as a volunteer chair (mbeierl, 15:17:48)
    5. https://drive.google.com/file/d/1Of5ffkT_UaCPbG82MzKzgcNKUJYgFB_O/view?usp=sharing (georgk, 15:18:09)

  1. review of the Test Tool presentation (mbeierl, 15:19:49)
    1. Feedback from Emma: I suggest a set of questions for each project overview. (mbeierl, 15:20:52)
    2. What resources does it test? (mbeierl, 15:21:02)
    3. What deployment stage is it used at? (mbeierl, 15:21:11)
    4. What are the most common usecases? (mbeierl, 15:21:25)
    5. What kind of test can I run? (mbeierl, 15:21:34)
    6. How extensible/customizable is the tool? (mbeierl, 15:21:43)
    7. ACTION: Send email to test PTLs asking for the info above, as well as to provide a single PPT slide type picture of their project (mbeierl, 15:36:34)
    8. a second co-presenter slot is open and can be extended to anyone who wants to help present (mbeierl, 15:37:49)
    9. ACTION: mbeierl to send out email (mbeierl, 15:40:22)

  2. Network impairment (mbeierl, 15:56:19)
    1. Al mentioned that netem (tc in the Linux kernel) cannot be used when DPDK comes into play as DPDK bypasses the kernel (mbeierl, 15:56:44)
    2. DEMU https://scinapse.io/papers/2735220890 TLEM https://scinapse.io/papers/2507693785 PROX https://01.org/intel-data-plane-performance-demonstrators/prox-overview (acm, 15:57:09)
    3. so even with two DPDK boxes talking through a whitebox Linux server running netem, the whitebox might not keep up with DPDK (mbeierl, 15:57:20)
    4. Mark mentioned the old Anue boxes could do line rate impairment, but doesn't know the product feature today (mbeierl, 15:58:04)


Meeting ended at 16:10:27 UTC (full logs).

Action items

  1. Send email to test PTLs asking for the info above, as well as to provide a single PPT slide type picture of their project
  2. mbeierl to send out email


Action items, by person

  1. mbeierl
    1. mbeierl to send out email


People present (lines said)

  1. mbeierl (18)
  2. collabot` (3)
  3. acm (3)
  4. georgk (1)


Generated by MeetBot 0.1.4.