#opnfv-vswitchperf: VSPERF Weekly call

Meeting started by maryamtahhan at 15:01:15 UTC (full logs).

Meeting summary

    1. Data Plane Performance Demonstrator (billyoma, 15:08:11)
    2. could be a good VNF (billyoma, 15:08:42)
    3. not a replacement for VSPERF (billyoma, 15:09:10)
    4. near end of 2nd sprint (billyoma, 15:11:53)
    5. Simple Perf Test VSPERF-91 done (billyoma, 15:12:44)
    6. Several LTD related jobs completed this week \o/ (billyoma, 15:14:48)
    7. VSPERF-97 IMIX testing being moved to blocked. Need to agree/design API to specify various IMIXes. (billyoma, 15:15:00)
    8. Xena - working of RFC2544. No integration yet. (billyoma, 15:20:31)
    9. Rick will have send an email to ML about some concerns about repeatability of tests across different TGs. We can then start a discussion on this at next weeks meeting. (billyoma, 15:21:35)
    10. Spirent - issue w. lic. server at Hillsborough. (billyoma, 15:22:48)
    11. Moongen (billyoma, 15:23:49)
    12. bidir tests working. Also latency measurements (billyoma, 15:24:14)
    13. Spirent traffic gen update: Pushed the initial Spirent integration code to gerrit for review. Mayram is helping work through a Jenkins build error that seems unrelated to my code. (spirentbrian, 15:24:56)
    14. no update this week (billyoma, 15:25:13)
    15. there is patch in gerrit for the re-org'd doc structure. (billyoma, 15:26:02)
    16. RELENG will build this standardized doc structure each night to html (for each OPNFV project) (billyoma, 15:27:11)
    17. draft updated to a new version (billyoma, 15:27:29)
    18. slides being prep'd for a readout next week. (billyoma, 15:27:48)
    19. Will ask BMWG if draft can be frozen for a while as the LTD is currently in a state of flux. (billyoma, 15:28:23)
    20. readout is to the IETF (billyoma, 15:29:09)
    21. synch with IXIA being arranged. (billyoma, 15:29:31)
    22. We need new tests that a) cover more relevant UCs b) cover more cells in the test matrix (on the wiki) (billyoma, 15:31:04)
    23. https://www.irccloud.com/pastebin/tmARvQhy/ (billyoma, 15:39:59)
    24. encryption of traffic taking place (billyoma, 15:45:00)
    25. ACTION: Brian Castelli offered to try an dig out some documentation on test methods regarding testing performance for multiple flows and across complex/large match/action tables. (billyoma, 15:51:28)
    26. There was a proposed Deployment Scenario involving SRIOV that did not fit with current naming convention (billyoma, 15:53:37)
    27. (billyoma, 15:55:31)
    28. Should we stick with: (billyoma, 15:55:48)
    29. Should we stick with: (billyoma, 15:56:11)
    30. P2P, PVP, PVVP … (billyoma, 15:56:12)
    31. Or should we migrate to: (billyoma, 15:56:12)
    32. T1n – VSWITCH Onboard port Forwarding ( either P2P port forwarding or flow based ) (billyoma, 15:56:12)
    33. T1u – VSWITCH Forwarding with user space L2 forwarding (billyoma, 15:56:12)
    34. T1v – VSWITCH Forwarding with one VM ( either switch based port forwarding or flow based ) (billyoma, 15:56:12)
    35. T2v – VSwitch Forwarding with two VMs ( either switch based port forwarding or flow based with DNAT on VM1 ) (billyoma, 15:56:12)
    36. ACTION: Rick will have send an email to ML about some concerns about repeatability of tests across different TGs. We can then start a discussion on this at next weeks meeting. (billyoma, 16:00:22)
    37. ACTION: Maryam will schedule the talk on new topology naming and virtual topology for test towards top of next meeting. (billyoma, 16:05:42)


Meeting ended at 16:05:58 UTC (full logs).

Action items

  1. Brian Castelli offered to try an dig out some documentation on test methods regarding testing performance for multiple flows and across complex/large match/action tables.
  2. Rick will have send an email to ML about some concerns about repeatability of tests across different TGs. We can then start a discussion on this at next weeks meeting.
  3. Maryam will schedule the talk on new topology naming and virtual topology for test towards top of next meeting.


People present (lines said)

  1. billyoma (58)
  2. collabot (3)
  3. spirentbrian (1)
  4. maryamtahhan (1)


Generated by MeetBot 0.1.4.